Bug 1802 - std_erspplot copyaxis error
std_erspplot copyaxis error
Status: RESOLVED WORKSFORME
Product: EEGLAB
Classification: Unclassified
Component: General
_13.x
PC windows Matlab 8.0
: P3 normal
Assigned To: Bugzilla Manager
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-07 08:07 PDT by isajinnis
Modified: 2015-12-22 06:22 PST (History)
2 users (show)

See Also:


Attachments
Screenshot of the error. Note the incorrect y axes. (596.78 KB, image/png)
2015-10-07 08:07 PDT, isajinnis
Details

Note You need to log in before you can comment on or make changes to this bug.
Comment 2 isajinnis 2015-12-22 06:22:27 PST
(In reply to comment #1)
> Dear Isajinnis, 
>  Thanks for for your report. We can't reproduce the bug with EEGLAB version
> 13.5.4b and MATLAB 2014b. Would you mind to give a try to the new release and
> check if it works OK for you. Please, let us know the result so we can follow
> up the bug report.
>  Best,
>  Ramon


Thank you for looking in to this. Unfortunately, I seem to get the same error with 13.5.4b.

I did notice one more thing however - before the plot pops up I see the following message in the command window:
"Warning: different channel montage or electrode order for the different datasets"

Could that be related?
Comment 1 Ramon Martinez-Cancino 2015-12-03 22:19:18 PST
Dear Isajinnis, 
 Thanks for for your report. We can't reproduce the bug with EEGLAB version 13.5.4b and MATLAB 2014b. Would you mind to give a try to the new release and check if it works OK for you. Please, let us know the result so we can follow up the bug report.
 Best,
 Ramon
Description isajinnis 2015-10-07 08:07:24 PDT
Created attachment 946 [details]
Screenshot of the error. Note the incorrect y axes. 

When using 'std_erspplot' from the command line or the GUI:

The figure correctly displays all channels in a single plot, but when a specific channel is clicked, I get the following error:

"Error using str2num (line 32)
Requires string or character array input.

Error in copyaxis (line 97)
   eval(command);
 
Error while evaluating Image ButtonDownFcn"

The individual channel ERSP plot will then have a wildly incorrect axis on the freq side. We recently upgraded from R2012 to R2014b so I wonder if that is the issue, as there was no problem when plotting in R2012 (the individual channel figure would pop up correctly in a new window). 

Here are the parameters I normally use:
%%%
[STUDY, allersp, alltimes, allfreqs] = std_erspplot(STUDY,ALLEEG,...
    'channels',{'Cz' 'E1' 'E2' 'E3' 'E4' 'E5' 'E6' 'E7' 'E8' 'E9' 'E10'...
    'E11' 'E12' 'E13' 'E14' 'E15' 'E16' 'E17' 'E18' 'E19' 'E20' 'E21' ...
    'E22' 'E23' 'E24' 'E25' 'E26' 'E27' 'E28' 'E29' 'E30' 'E31' 'E32' 'E33'...
    'E34' 'E35' 'E36' 'E37' 'E38' 'E39' 'E40' 'E41' 'E42' 'E43' 'E44' 'E45'...
    'E46' 'E47' 'E48' 'E49' 'E50' 'E51' 'E52' 'E53' 'E54' 'E55' 'E56' 'E57'...
    'E58' 'E59' 'E60' 'E61' 'E62' 'E63' 'E64'});
%%%

I am running:
eeglab 13.4.4b
Matlab R2014b
Win 7 x64

Initially I posted this to eeglablist, where Makoto was gracious enough to look at it. It appeared to be an overload problem at first, but it seems he tested it and found that not to be the case. He wrote:

"Dear Isaiah,

I checked it with my Matlab but it's NOT the overload issue. My apology.
Probably this is a bug in EEGLAB. Please file it to EEGLAB bugzilla
https://sccn.ucsd.edu/bugzilla/enter_bug.cgi
Thank you for your patience and cooperation."

Here is an archive link to the whole conversation.
http://sccn.ucsd.edu/pipermail/eeglablist/2015/010387.html

I have attached a screenshot of the error where you can see the correct all channels plot and several child figures with incorrect axis values. I have tested multiple STUDYs/designs across several experiments, and the issue is present regardless. 

Thank you for your help,