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The EEGLAB Matlab software

/. N\ \\
4
Centerfor

Computtﬂonal

Neuroscience

main graphic interface

=z EEGLAB Shell - Konsole

Session Edit View Bookmarks Settings Help

- 0O X

B E

/home/arno> matlab -nodesktop
<MATLAB?>
Copyright 1984-2002 The MathWorks, Inc.
Version 6.5.0.180913a Release 13
Jun 18 2002

Using Toolbox Path Cache. Type "help toolbox_path_cache" for

For product information, visit www.mathworks.com.

>> eeglabl]

File Edit Tools Plot Stucy Datasets Help

To get started, type one of these: helpwin, helpdesk, or demo.

—No current dataset

- Create a new or load an existing dataset:

Use "File > Import data" (new)
Or "File > Load existing dataset" {old)
- If new,

“File > Import epoch info" (data epochs) else
“File > Import event info" (continuous data)
"Edit > Dataset info" (add/edit dataset info)
"File > Save dataset" (save dataset)

- Prune data: "Edit > Select data"

- Reject data: "Tools > Reject ¢continuous

- Epoch data: "Tools > Extract epochs”

- Rermove baseline: "Tools > Remove

- Run ICA: "Tools > Run ICA"
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Importing a dataset

EEGLAB v5.03

Edit  Tools Plot Study Datasets  Help |
| =

From ASClIffloat file or Matlab array \

Iimgor EF:":":h‘m_":' “  From continuous or seg. EGI .RAW file
Irtigore 2ysa iy “ From Multiple seg. EGI .RAW files
Export

From BCI2000 ASCII file

From Shapmaster .SMA file

Load existing dataset

Save current dataset(s)

From MNeuroscan .CNT file
From MNeuroscan .EEG file
From ERPSS .RAW or .RDF file

Save current dataset as

Clear dataset(s)

s?w;

ente
Computational
Neu roscience

Create study -

From Biosemi .BDF file using BIOSIG

Load existing studly .
From other formats using BIOSIG

Save current stuclsy

Eim i i e . From ANT EEProbe .CNT file
Sawve current stucly as
From ANT EEProbe AVR file

Clear study,
- From Brain ¥is. Rec. .vhdr file
Memory options
e i From Brain Yis. Anal. Matlah file
Save history -
- From CTF folder (MEG)
Quit

From INStep (ASC file
From Mayo .MEF files

Troubleshooting, other data formats...

From 4D .m4d pdf file ]

EEGLAB supports many

different raw data formats
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Imported EEG data

| EEGLAB v7.1.6.18b

File Edit Tools Plot Study Datasets Help

EEGLAB GUI

displays dataset

basics
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The example data: Sternberg working memory

L
File
../Data/stern.set
Data
Continuous data (not epoched), ref'd to right mastoid
Task
3-7 letters to memorize, among 1-5 letters to ignore
50% chance of probe letter being ‘in-set’
Fixation Maintenance
( ﬁec) (1.4 sec) (2'4@890) P'ﬁbe
+ M| L) TG IP]|Y]|Q W] =T
I - ﬂ/
Memorize

Ignore

Was this letter in the memorized set?

RESPONSE




Comments in EEGLAB structure

4,

N ‘()

Computational
Neu roscience

About this dataset

Data acquired by: Julie Onton -
Data acquired on: Oct 15, 1874

Task ('eventname'):

- Every trial preceded by 5 sec fixation ('fix') -
3,5,7 letters to memorize (in black, ex, 'B')

- 5,3,1 letters to ignore (in green, ex, 'gB')

- B8-letters total per trial

- 2-4 sec variable maintenance period ('UM')

- Probe letter (in red, ex, 'rB')prompted a button
press response

- Subject was to indicate by left or right mouse
button (with right hand) whether the probe

letter was in-set (left,'in') or out-of-set
(right, 'out')

- If the response was correct, subject heard one
one tone ('correct'), if incorrect, a different
tone ('wrong')

Reference electrode placed on right mastoid

(Subject indicated sleepiness toward the end of
session)

[oen |

>> BEEG.comments

File B30 Tools Plot Study Datasets Help

Dataset info

[ Eventfields ntinuous Data——

Eventvalues
‘ About this dataset INSO4istern.set

i 71
Channel locations 610133
Select data 1

Select data using events 1303
Select epochs or events 250

Copy current dataset 0.000
A 2440.528
ppend datasets
Delete dataset(s) unknawn
Yes
ICA weights Yes
Dataset size (Mhb) 3514

y
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Edit Tools Plot Study Datasets

Memory options

EEGLAB v6.03b

Help

Import data »
Import epoch info »
Import event info »
Export »

Load existing dataset
Sawve current dataset(s)
Save current dataset as

Clear dataset(s)

SWaI’lZ

Center for
Compu(ational
Neuroscience

Set when loading a STUDY

Create study »

Clear study

Sawve history

Load existing studhy
Save current study

Save current study as

Quit
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Re-reference data (if necessary/desired)

Swartz ¥

Center for
Compu(ational
Neuroscience

Change sampling rate
Filter the data
Re-reference
Interpolate electrodes

Reject continuous data by eye
Extract epochs
Remove baseline
Run ICA

Remove compon

Automatic chann
Automatic epoch
Reject data epock
Reject data using

Locate dipoles us

Peak detection us|
FMRIEB Tools
Locate dipoles usiige=orerrs

EEG = pop reref( EEG, 39); Y
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TN

Swartz ¥
Center for
Campu(ational
Neuroscience

Sternberg Continuous -- Reref'd

— |

Edit description
Browse

h % - old dataset

Savein: | | MATLAB File Edit Tools
T Neme ' Date modified :

| external 11/10/2009 5:54 AM  File folder wiernberg Lontinu
| functions 11/10/2009 5:50 AM  File folder

lugins 11/10/2009 5:52 AM  File folder

plug
H sample_data 11/10/2009 5:52 AM  File folder

sample_locs 3 letolder

ple_| 11/10/2009 5:52 AM  File fold

Plot Study Datasets Help

Recent Places

Sampling rate
[n] Start | sSel
1ul =il

SrENCE

1annel locations

[ALLEEG EEG CURRENTSET] = pop newset (ALLEEG,EEG, 1, 'setname',..
'Sternberg Continuous -- Reref''d’);



Multiple active datasets (ALLEEG)

| EEGLAB v7.1.6.18b C=aeey | | A eecLag 716180

File Edit Tools Plot Study Datasets Help File Edit Tools Plot Study BREICHIS

Dataset 1:Sternberg Continuous Data
¥ Dataset 2:Sternberg Continuous -- Reref'd

Select multiple datasets
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Scroll channel data

Computational
Neurosclence

y
%’-
File Edit Tools Study  Datasets Help
Channel locations 4

—#2: Stel

Filename:
Channels
Frames pe
Epochs
Events
Sampling
Epoch sta
Epoch enc
Referenc
Channel Iq
ICA weigh
Dataset si

Channel data (scroll)

Channel spectra and maps

Channel properties

Channel ERP image
Channel ERPs 4
ERP map series 4
Sum/Compare ERPs

Component activations (scroll)
Component spectra and maps
Component maps »

Component properties

Component ERP image
Component ERPs 4
Sum/Compare comp. ERPs

Data statistics 4

Time-frequency transforms P
Cluster datasetICs

Figure Display Settings Help N

Chan.

oancel | [Eventtypes | exf (<[ 55 | 5] 35 (eve srosse assss | 9719 |

Time Yalue

>> pop eegplot(EEG,1,1,1);
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Scroll channel data

.\ & Center [abal
il Cﬁmputaﬂo nal
O G

- Scroll channel actlvltles eegplotO u_u

Figure Display Settmgs Help

Event markers

= 2 =
=0 o A N N e
chgnnels, S
time, | ——
== NCreAse s s ey
events | EEE= ey | Seroll
“‘ % % A s e e A T WW buttons
seclepoch B e e e e scaling

Chan.  Time Yalue
CA"CE"l E"e'""pesl ===l s =] = greve sr7e11 o020sa7 | 3719
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Data importing and channel analysis

Task 2
Import channel location file

Exercise...
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Import channel locations

-
Swartz
Center for
Compu(ational
Neuroscience

| EEGLAB v7

m Z[i & Tools Plot Study Datasets

Dataset info
Event fields
Event values -451543
About this dataset 0.54374
Channel locations Aresis . 0.79487

LEYE Opt. head center
Rotate axis

Transform axes

Select data 079917 Xyz ->= polar & sph.
Select data using events -0.15585 Sph. -= polar & xyz
Select epochs or events 451543 Polar -> sph. & xyz
-7.8725
Copy current dataset -
T raTs 11379 Set head radius

Sl Set channel types
Delete dataset(s)

Set reference

Delete chan -har

__msetchan | << | < |

Plot 2-D

.. S —n ~ Append chan |
| eseskng e <] | PB3D00) |
 cwea | e | o

7 file formats supported
(Polhemus, BESA, ...)
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LEYE
-45.1543
0.54374
0.79487
079917
-0.15585
451543
-7.8725
11379

Opt. head center
Rotate axis
Transform axes

SWale 1

Center for
Compu(ational
Neuroscience

Xyz -= polar & sph.
Sph. -= polar & xyz
Polar -= sph. & xyz

Set head radius
Set channel types
Set reference

nel NUMDE DT

™ | 1
< | < | v - | = | amendchan
| Noseatngx o) Pei3D0v) |
= N "
Sl ocsnep_| | Lookup ocs s
File Edit View Insert Tools Desktop Window Help

DEE (M RAUDLEAL- 2|08 nDO

Channel locations

PEPEP2 ™
39AFZeARAT O

3oF1'|70F3F£2fF

FYE,

71 of 71 electrode locations shown
Click on electrodes to toggle name/number




Imported channel locations

B EEGLAB V717,18

File Edit Tools Plot Study Datasets Help
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Data importing and channel analysis

Task 3
Import data events

Exercise...
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Z1I8 Edit Tools

Import data events

Plot Study Datasets Help

Import data »
Import epoch info

[« Import events from Matlab array or ASCI| file
 Import events from data channel
 Import from Presentation event file

From Matlab array or ASCII file

From data channel

Import event info

Export

. *Import from Neuroscan file

Load existing dataset

Save current dataset(s)

Save current dataset as
Clear dataset(s)

From Presentation .LOG file
From Neuroscan .ev2 file

Create study 4

Load existing study
Save current study
Save current study as
Clear study

Memory and other options

History scripts »

Quit
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Appearance of an event channel

Cente
Computational
Neurosc ience

Scroll activity — eegplot()
Figure Display Settings Help

Scale
50

4 3 ] 7 i )

Chan. Time Value

CLOSE| [Eventtypes] << =i 4 | =l 3=l 1 sime sasr | 50 |
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Imported data events

)

‘B EEGLAB v7.17.18k o]
File Edit Tools Plot Study Datasets Help N If event import was

successful,

you will see an

appropriate

number here
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| EEGLAB v7.17.18b
m =08 Tools

Dataset info
Event fields
Event values

About this dataset
Channel locations
Select data
Select data using events
Select epochs or events

Copy current dataset
Append datasets
Delete dataset(s)

Insert event
BEFORE
current event

Plot Study Datasets Help

Review event values

Swartz ¥
Center for
Compu(ational
Neuroscience

Event 'type' and 'latency’
are recognized fields

Delete
Append event || CURRENT
AFTER event
current event

Edit event values - pop_editeventvals()

Latency (sec) 4,964
 Type | object

Srsercevent << B W2 ML 1 o> B Aopenc evenc |

& _IClick for decreasing order
secondary sorting fielc _IClick for decreasing order

Delete event |

To resort: first
select Main
sorting field
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Review event values

-
Swartz
Center for
Compu(ational
Neuroscience

| EEGLAB v7.1.

m 08 Tools Plot Study Datasets Help

Dataset info

Event fields

Event values
About this dataset

Channel locations

Select data
Select data using events
Select epochs or events

Copy current dataset
Append datasets
Delete dataset(s)
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Number of

event fields

is unlimited

Trial

Event_Type

Type

Latency (sec)

Ttime

Uncertainty

Duration

Uncertainty2

ReqTime

ReqDur

Init_index

Init_time

Duration (sec)

Load




Renaming events
-

.f
B EEGLAB v7.1.7.18b =
File 210 Tools Plot Datasets Help ~

Dataset info
Event fields

Neuroscience

ntinuous -- Rere...—

Eventvalues
About this dataset

o 1) input original 'type' code
Select data 1

Select data using events 1303 2) inpUt neW 'type' COde

250
Copy curent datazet | 0000 3) Keep/delete all other events

Append datasets 2440528

Delete dataset(s) $:EZS

Channel locations

Select events — pop_selectevent()

Selection Field Descriptions Selection (value, list or real range "min<=max") If set, select

Field To edit: Edit > Event fields Bx: "Target" or 2:4,5 or 4.5 <= 13 all BUT these
Event indices | N
latency (s) No description [ -
type No description [ bpl _
_|Select all events NOT selected above Set this button (to leftjand "all BUT" buttons (above) for logical OR
Rename selected event type(s)as type: [ button 1

Retain old avant tyec a5y in tidw; figld named: |

|_|Keep only selected events and remove all other events |

Cancel | Help | Ok




Renaming events

Swartz ¥
Center for

Compu(ational
Neuroscience

| EEGLABV7.17.1
m =08 Tools

Dataset info
Event fields
Event values

About this dataset

Channel locations

Select data

Plot Study Datasets Help

Edit event values — pop_editeventvals()

Select data using events 303
Copy current dataset Latency (sec) | “
Append datasets _ Type || ( buttonl )

Delete dataset(s)

RILLlIRS No field selectec « _|Click for decreasing order
econaary sorting rielc No field selectec = _IClick for decreasing order
 Cancel | Help | ok |
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Event durations

Neuroscience

Scroll channel activities — eegplot) C o I o r d e n ote S

/ event duration

Figure Display Settings Help

e0s
e06
ed?
e0d
e0g
ell
ell
elz
eld
eld4
e15
e16
el?
eld
elg
e20
e21
244
e23
e24
e25
e26
e27
e28
e29
e30
e31
e3z
e33

70

Chan. Time Value

+
CANCEL Event types ‘ << < 50 > > e33 51,7242 -13.3 70 REJECT
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Data importing and channel analysis

Task 4
Extract data epochs
Select epochs/events
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Extract epochs

Swartz ¥
Center for
Compu(ational
Neuroscience

Change sampling rate
Filter the data
Re-reference

Interpolate electrodes
Reject continuous data by eye
Extract epochs

Remove baseline
Run ICA

Remove components

Automatic channel rejection

Automatic epoch rejection

Reject data epochs »
Reject data using ICA »
Locate dipoles using DIPFIT 2x  »
Peak detection using EEG toolbox
FMRIE Tools »
Locate dipoles using LORETA  »
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Extract epochs

/4 y B

Swartz ¥
enter for
Compu(ational
Neuroscience

File Edit Tools Plot Study Datasets Help

EEG = pop epoch ( EEG, {'out', 'in' },...
[-1 2], 'newname',... Sl e
'Sternberg Continuous -- Reref'd epochs', ... Jach star
'epochinfo', 'yes');

[ALLEEG EEG CURRENTSET] = pop newset (ALLEEG, ..
EEG, 2, 'setname', 'Sternberg Response Epochs',
'gui', 'off');

EEG = pop rmbase ( EEG, [-1000 01):; ‘ _
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 EcGLAB V717188

m 08 Tools Plot Study Datasets Help
Dataset info
Event fields
Event values
About this dataset
Channel locations
Select data
Select data using events

Select epochs or events

Copy current dataset
Append datasets
Delete dataset(s)

>> EEG = pop selectevent (EEG, 'type',{'in'}, ...
'deleteevents', 'off', 'deleteepochs',6'on');

>> [ALLEEG EEG CURRENTSET] = pop newset (ALLEEG,EEG,4,...
'setname’', 'faces only epochs');



Select epochs with specific events

-
Swartz
Center for
Compu(ational
Neuroscience

ate No description
Dataset info . durs s No description
Event fields e No description

Event values LB

. No description
About this dataset No description

Channel locations erts No description
Select data - No description

Select data using events No description
GEIECE AT No description
Sglect epocns or events . pr—
Copy current dataset i No descrioti

Append datasets ' me No description

Delete dataset(s) No description
: : No description

| — _
EEGLAB Workshop Xl, September 7-9, 2010, Hsinchu, Taiwan: Klaus Gramann — Data import



Repeat for ‘out-of-set’ responses

Swartz 5 ¢

Center for

Computalional
Neuroscience

Save without overwriting and go back to all epochs

Repeat process for ‘out’ trials

Sternberg: Probe- In Set

C:Wsers\julie\DocumentsWorksho

Cancel
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Separate datasets with different conditions

| EEGLAB v7.27.18¢ = || [ eecLas V727188 = |
File Edit Tools Plot Study, Datasets Help N File Edit_Tools Plot Study Datasets Help N
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Merge (append) datasets

Swartz ¥
Center for
Compu(ational
Neuroscience

Plot Study Datasets Help

Dataset info

Event fields
Eventvalues

About this dataset
Channel locations
Select data

Select data using events
Select epochs or events

Copy current dataset

Append datasets
Delete dataset(s)
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Merged datasets

B EEGLAB v7.2.7.18¢

File Edit Tools Plot Study, Datasets Help
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Data importing and channel analysis

Task 4
Channel analysis
Exercise...
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Analysis of ERPs

g e
. ERP data and scalp maps -- pop_timtopo() _ S=NACIN
3 ol Plotting time range (ms): ’ -200 500
\Q"”' Scalp map latencies (ms, NalN -= max-RMS) ’ NaN
Plot title: ‘ERP data and scalp maps of !
7 —_———— — Scalp map options (see == help topoplot): ‘
File Edit Tools Bl Study Datasets Help N ! Cancel Help
#3: St Channel locations » h
- otel Channel data (scroll) s
_ Channel spectra and maps
Filename: Channel properties
Channels _
Frames pe Channel ERP image
Epochs Channel ERPs »|  With scalp maps
Events ERP map series »  Inscalp/rect array

Sampling | Sum/Compare ERPs
EpDCh sta Component activations (scroll)

Ep?Ch &Ny Component spectra and maps
ETErenc

omponent maps
Channellc ~ <°™P P 4
ICAweighi Component properties
Dataset si Component ERP image

Component ERPs »

Sum/Compare comp. ERPs

Data statistics »

Time-frequency transforms ~ »
Cluster datasetICs

-4: |I” r ST 1 1 1 3
-200 100 0 100 200 300 400 500

>> pop_timtopo (EEG, [-200 500], [NaN], 'ERP data and scalp maps');




o Analysis of ERPs
= r3

ente

“s Computaﬂonal
> k_\.’ Neuroscience

B EEGLAB v7.17.18b C=LE

File Edit Tools Study  Datasets Help N

: DEEE AL
Channel locations 4
—#2:8tel | hs
annel data (scroll) Stemberg memorize epochs
. Channel spectra and maps REYE
Filename: Channel properties
Channels

Events ERP map series 4| Inscalp/rect. array

AF
ﬂ e %Fg i
Sampling | Sum/Compare ERPs F’?W? %vd,_w ?'quv ] i) ﬁ . {?‘}&WFB F10
Epoch sta Component activations (scroll) ‘{V&’V‘ ’ K F3 M FTUﬂWV‘ F2 4
19 7 ; /

Frames pe Channel ERP image - 1 n
Epochs Channel ERPs 4 With scalp maps LE?JE-?QAV ; o FPI A P2

Epl:ll:h e Component spectra and maps
Reference

Channel g~ ComPenentmaps » I res FC?V&’% Fé‘fﬂﬂw .
ICA weigh Component properties JFM, % " ]
Dataset si Component ERP image E P .
Component ERPs » | - :
Sum/Compare comp. ERPs ‘%AIPT}AA‘ cﬁg’}w‘ c;{]ﬁfﬁ‘ 05?%;394‘ cSY_ﬁVA"’ cr@j wﬁ}qhﬂ« . TP?%@

9 A szy}ouﬂq : Tp%v‘_

Data statistics 4 A’}?A‘ng%“ﬂ* P’ﬁ{r\ﬁﬂ* B
S — gl !
- Topographic ERP plot - pop_plottopo() ‘ LEIQM i %woy%tz Pgﬁw&‘
L

Channels to plot 1:71 Pod i of O%T

Plot title Sternberg memorize epochs

Plat single trials [ (set=yes) -

Plot in rect. array [ | (set=yes) {—

COther plot options (see help) ‘ 'ydir', 1 597 200 4%
Tine (ms)

Cancel
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&

Channel ERP in rectangular array

File Edit Tools

/2 b \
Ceme

Computational
Neuroscience

Study  Datasets Help

T EEEE

Channel locations 4

#2: Ste Channel data (scroll)
_ Channel spectra and maps
(F:l:'leannann;FS. Channel properties
Frames pe Channel ERP image
Epochs Channel ERPs 24 With scalp maps
Events ERP map series 4l  Inscalp/rect. array
Sampling Sum/Compare ERPs
EpOCh sta Component activations (scroll)
EpfﬂCh ik Component spectra and maps
ETErence
Channella Component maps 4
ICA weight Component properties
Datasetsi Component ERP image
Component ERPs »
Sum/Compare comp. ERPs

Data statistics 4

- Topographic ERP plot - pop_plottopo() s Eléu

Channels to
Plot title

plot 171 |

Sternberg memorize epochs ‘

Plot single trials
Plot in rect. array
Cther plot options (see help)

Cancel

[ | (set=yes)
Sk

'ydir', 1

Stemberg memorize epochs

o1 22 -3 -4 -5 o6 o1 -8
"L‘VA‘“V’ *’VMF A\T‘ﬁ‘\f‘ﬂ’ Afrﬁv& *V%w *Ww mmﬁmm "*"‘vﬂvw
g ) 1 1 3 “u T 6
Ao e i i s o L
- 18 1 ) Y 2 i o
T T e
% % a1 i B ) 3 )
i "v“‘vavv“v‘ w‘wpw wﬂvﬁw e 7
o u % % :37 B n )
o e e e et oA A
4 i 0 i i 4 :47 48
s oo " N N LS "W"T,PV&"
") i) 1 i) 8 54 & &
AL A S A - = e
a 8 5 ) 6t 0 5 o
MO MRS SRV SRS A AT A
5 5 o 5 i 0 n B
A AN At A A\fﬁg@ AP A
= & = = & = = 0 )
Time (ms)
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Analysis of ERPs

- =
‘ B Plot ERP scalp maps in 2-D -- pop_topoplot() _ E=NEE
- v Plotting ERP scalp maps at these latencies ‘ 0:25:275] ’
\Qr:" (range: -200 to 496 ms, NaN -= empty):
g e ——
B ceoLas v7.1.7.18-IEIQ!;:n =
Figure 2 E'_lg
File Edit Tools Study  Datasets Help -
File N
Channel locations » - —
—#2: Stel ths—— || DEsE&G 220
Channel data (scroll)
_ Channel spectra and maps 0 ms

I(::':'Ieannanrzles. Channel properties

Frames pe Channel ERP image

Epochs Channel ERPs »

Events ERP map series "l In2-D

Sampling Sum/Compare ERPs In3-D

Epoch sta Component activations (scroll)

EprCh =it Component spectra and maps

Cﬁaer::;cl Component maps »

ICA weigh Component properties

Dataset si Component ERP image
Component ERPs »
Sum/Compare comp. ERPs
Data statistics 4
Time-frequency transforms P
Cluster datasetICs

Sternberg memorize epochs

pop_ topoplot (EEG,1,[0:25:275], ‘Memorize',[3 4],0, 'electrodes', 'off');
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Compare ERPs across conditions

File Edit Tools Plot Study EREIEHIE

Dataset 1:Sternberg Continuous Data

¥ v Dataset 2:Sternberg Memorize epochs

Dataset 3:Sternberg Ignore epochs

Select multiple datasets

How do 'Memorize'
and 'lgnore' ERPs
differ?
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Compare ERPs across conditions

B EeGLaB V717180

ile Edit Tools Baks

F Study Datasets Help

Compare ERPs

Channel location | g
Channel data (sc
Channel spectra :
Channel properti
Channel ERP ima
Channel ERPs

ERP map series

from two conditions

Sampling Sum/Compare ER

—noch stz Component acti

Data statistics

Time-frequency transforms
Cluster datasetICs

>>pop comperp (ALLEEG,1,[2 3],[],'addavg',6 'off',6 'addstd', 'off’',
'addall','on','diffavg',6 'off','diffstd', 'off', 'lowpass’',K 20,
'"tplotopt', {'ydir',1});
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. Compare ERPs across conditions
-

.\ N Center b3
% ol Computaﬂonal
\.{(,.:':; Neurosc ience
Bl Figure 3 C=alagX
File
T T EEER

_ Click on an axis
Eft%%?jﬁi %;Z%W j;:ﬁ Fﬁ}“ﬁwm—}gw F- r}vﬂm ﬁ}vﬂﬁ‘ to see larger image

Figure 2

File

DEE& 2P0

-
—— #2 Sternberg Memorize epochs (n=600)
—— #3 Sternberg Ignore epochs (n=300)
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%
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Time (ms
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Analysis of ERP differences

Plot difference
RMS “popcompe® hatyween two conditions s

>> pop comperp (ALLEEG,1, 2, 3,'addavg',6 'off',..
'addstd', 'off', 'diffavg','on',6 'diffstd', 'off'’',
'lowpass',20, 'tplotopt',6 {'ydir',k1});
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Analysis of ERP differences

%le ERP
= difference

between
F | m F%%A?WFWW 2 conditions

-200 -100 0 100 200 300 400
Time (ms
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Remove channel

/. N\ \\
Centerfor

Compmxﬂonal
Neuroscience

Figure Display Settings Help N

§

|

--n;‘.-.*

Scale
35
1 I 1 I
450 451 452 453 454
Chan. Time Value
CANCEL | Event types | << | """ < 449 ;l = | o1 4510988 36619 35 ﬂ REJECT
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| EEGLAB v7.1

m =08 Tools Plot Study Datasets Help
Dataset info

Event fields
Eventvalues
About this dataset

Channel locations

Select data

Select data using events
Select epochs or events

Copy current dataset
Append datasets
Delete dataset(s)

B E

Scroll dataset
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Removing channel(s)

<SPS

Scroll dataset
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Channel removed

/. N\ \\
N |
Center for-

Compmxﬂonal
Neuroscience

Figure Display Settings Help

LS

fat Scale
: : 3 MMWWMWWWWWWWW
Bl 35
POrA "
] ) D T ° -+
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Chan. Time Yalue

;| REJECT

P8 4535014 41308 35 |

CANCEL | Event types | << | ;‘ 449
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Interpolate bad channel

Swartz ¥

Center for
Campu(ational
Neuroscience

Choose a channel from other dataset

Select from non-data channels
Select from other dataset
Use list of other dataset

Change sampling rate
Filter the data » F

Re-reference

‘ Interpolate electrodes terpolation method
~ Reject continuous data by eye -
_ Hep | ok |

Auto-select deleted

channel from other dataset

Extract epochs
Remove baseline

Run ICA

Remove components

Automatic channel rejection
Automatic epoch rejection

Reject data epochs »
Reject data using ICA »

Locate dipoles using DIPFIT 2.x  »
Peak detection using EEG toolbox

FMRIB Tools 4 Select from non-data channels
Locate dipoles using LORETA 4 Select from other dataset

. UseTist of other dataset” "

canca | tep | ok |
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Interpolated channel

o

B Scroll channel activities -- eegplot(
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Exercise

ALL
-Load stern.set
-Do not save your changes under the same filename!

Novice
-Re-reference the data to Cz.
-Scroll data and explore plotting options under 'Settings'.

Intermediate

-Review events in Edit->Event values, rename an event in Select
epochs/events.

-Remove a channel and then replace it by interpolation.

Advanced

-Epoch the data on Memorize and Ignore letters separately, then
use pop_comperp to compare ERPs between conditions.

-Explore other menu options.




