Basic scripting with EEGLAB

(Menus write both dataset and global history)

Memory options

« Automated processing on groups of subjects
(possibly on several processors).

 Richer options for plotting and processing
functions (time-frequency decompositions, ...)

« Selecting data/epoch based on event context
« Export data

» Custom processing...



EEGLAB Scripting

Raw data preprocessing Group level analysis

da fo; datainfo;
pop_editoptions( 'option storedisk', 1);
o =" )23 eSS ta'; outputE! =

sfudjéommand = {};

for iSubj = 1:length(sInfo) % generate STUDY commands
for iSubject = 1:length(sInfo)
fileName = fullfile(outputEEGFolder, [ sInfo(iSubject).name '.set' ]);
studyCommand = [ studyCommand { 'index' iSubject 'load' fileName 'subject’
sInfo (iSubject) .name } ];

% load dataset
EEG = pop_biosi

end;

'plugins/dipfit2.3/standard /elec/standard_1005.elc’;
pop_chanedit (EEG, 'lookup', fullfile(fileparts(which('eegl
t( EEG, 0.5, 0, [], O, 0); % high pass filter
t( EEG, 0, 55, [], 0, 0); %
(EEG, 'nochannel’, s 3) -
POP_! EEG, []):; % average ce (
eeq_eegrei( EEG, sInfo(iSubj).bad data); % re

% create data

[STUDY ALLEEG] = std editset( [], [], 'name', 'test',6 'commands', studyCommand,
'updatedat','off', 'filename', 'test.study', 'resave', 'on');

STUDY = std makedesign(STUDY, ALLEEG, 1, 'name','STUDY.design 1', 'delfiles','off’,

'defaultdesign','off', 'variablel', 'type', 'valuesl’', {'2' '4' });

:E;uf oA s EEG, 'icat N Dmekilil)s % update workspace variables and redraw EEGLAB
= pop_runica ( , 'icatype', 'sobi'); CURRENTSTUDY = 1; EEG = ALLEEG; CURRENTSET = [l:length(EEG)];
[STUDY, ALLEEG] = std _checkset (STUDY, ALLEEG) ;

% tag bad components
g o eeglab redraw

% p: ute and plot data

al anlocs = eeg _mergelocs (ALLEEG.chanlocs) ;

[STUDY ALLEEG] = std_precomp (STUDY, ALLEEG, {},'interp', 'on', 'recompute',6'on',6'erp', 'on');
STUDY = pop_statparams (STUDY, 'condstats','on', 'singletrials',6 'on', 'mode'.'fieldtrip’,
'fieldtripmethod', 'montecarlo’,'fieldtripmcorrect’,'cluster');

[STUDY erp] = std erpplot (STUDY,ALLEEG, 'channels',{allchanlocs.labels}, 'topotime’,[300 400]);
print results.eps -depsc

et( EEG, 'filepath', outputEEGFolder,




Using EEGLAB history for basic scripting

Task 1

Create a script from ‘eegh’ output
Task 2

Adapt your script with variables
Task 3

Create a Matlab function
Task 4

Exercise...



Edit

Tools Plot

St

Memory options
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Import data
Import event info

Export

< <]

<

Load existing dataset
Sawve current dataset(s)
Save current dataset as

Clear dataset(s)

Create study

Load existing study
Save current stud i
Save current stu Ei"g,ﬂ' as

Clear study

Save history

Memory and other options

Change memory options
to allow more than one dataset in memory

Quit




Create a script from ‘eegh’ output

Start by loading a continuous dataset

"B EEGLAE 3b oo S
Edit Tools Plot Study Datasets

Import data P R
Import epoch info

Help.

| EEGLAB 18b

File Edit Tools Plot Study Datasets Help ~

Import event info

bt G A

Export

Load existing dataset
Save current dataset(s)
Save current dataset as
Clear dataset(s) o St
Create study » i S
Load existing study

Save current study

Save current study as

Clear study

Memory and other options

History scripts (-
Quit




Create a script from ‘eegh’ output

Change sampling rate
Filter the data

Re-reference

Interpolate electrodes

Reject continuous data by eye
Extract epochs

Remove baseline
Run ICA

Remove components

Automatic channel rejection

Automatic epoch rejection
Reject data epochs »
Reject data using ICA »

Locate dipoles using DIPFIT 2x
Peak detection using EEG toolbox

FMRIB Tools »
Locate dipoles using LORETA P

Epoch on Memorize letters

Sternberg: Memorize letters




Create a script from ‘eegh’ output

EEGLAB v7.27.1 == Plot an IC ERP image
AlO8 Study Datasets Help
Channel locations

Channel data (scroll)
Channel spectra and maps

Channel properties

Channel ERP image
Channel ERPs 4
ERP map series 4
Sum/Compare ERPs

Component activations (scroll)

-200 596

___-ﬂ-_l

Component spectra and maps

Component maps »

Component properties

Component ERP image

Component ERPs

Sum/Compare comp. ERPs
Data statistics

Time-frequency transforms
Cluster datasetICs




Create a script from ‘eegh’ output

File ~

DEES ®O0

| I I I I I I
-200 -100 100 200 300 400 500
Time (ms)




Retrieve commands from eegh

Write a script to do this:

>> eegh



Retrieve commands from eegh

>> eegh
[ALLEEG EEG CURRENTSET ALLCOM] = eeglab;

EEG = pop loadset('filename', 'stern 125Hz.set');
[ALLEEG EEG CURRENTSET] = eeg store(ALLEEG, EEG, 0);

EEG = pop epoch( EEG, { B’ 'C' ‘D" ... }, [-0.2 0.6],
'Memorize epochs', 'epochinfo', 'yes');
[ALLEEG EEG CURRENTSET] = eeg store(ALLEEG, EEG, 1);

EEG = pop rmbase( EEG, [-200 0]);
[ALLEEG EEG] = eeg store(ALLEEG, EEG, CURRENTSET);

figure; pop erpimage(EEG,0, [3],[], Comp.

3',10,1,{},11, "', verplabel', , 'erp', 'on', 'cbar',
‘on', 'topo',{mean(EEG.icawinv(:,[3]),2) EEG.chanlocs EEG

})i

'newname’

.chaninfo



Create a Matlab script

File Edit Debug Parallel Desktop Window Help

Sal=1FE 1 RF

: Shortcuts [2] How to Add [2] What

o New to MATLAB? Watch this Video

>
>
>
>
=
>> edit |

4\ Start

B

Editor - Untitled5

File Edit Text Go Cell Tools

Debug Desktop Window Help

NSl | sRR20(o22-Meas i |[B-AXBRE BB | stk Base v [0 .~
B8 -0 |+ | +11 |x|s%|0
1 |

|script ILn 1 Col 1
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Create a Matlab script

Copy and paste from Matlab window:
ewvor-ureneos 0 I, e )

File Edit Text Go Cell Tools Debug Desktop Window Help 's|?l X
Ndd| $RR9e |- AMasf|R-B0BRE BB |sack| e v| [ v
BB -0 |+ s[11 |x|%a®|O

[ALLEEG EEG CURRENTSET ALLCOM] = eeglab: O
EEG = pop_loadset( 'filename', 'stern.set', 'filepath', 'C:\\Users''julie’’Docum

EEG. = pop: epoch( EEG;, 1 P ¢! ¢ 9P 35 9 G R IR YR Pap
[ALLEEG EEG CURRENTSET] = pop_newset (ALLEEG, EEG, 1, 'gui', 'off');

EEG = pop_rmbase( EEG, [-200 O3 2

[ALLEEG EEG] = eeg_store (ALLEEG, EEG, CURRENTSET):

figure; pop_erpimage (EEG,0, [3],[],'Comp. 3',10,1,{(},([]1,'' , 'verplabel','',K6 'er|—

W -3 M = W M =

Save as ‘ploterpimage.m

In MATLAB folder

'
ln 7 Col 51 [OWR .:




Run your

new script

t&File Edit Debug Parallel Desktop Window Help

NS R o | MR |0

C:\Users\julie\Documents\MATLAB

: Shortcuts [2] Howto Add (2] What's New

o New to MATLAB? Watch this Video, see Demos, or read Getting Started.

e
>

>

>

==

>> edit

>> ploterpimage

|4 Startl




Exercise page 1

>> eeglab

% load dataset stern 125hz.set in data folder
% epoch on 'memorize letter' B, C, etc...
% plot erpimage for component 3

>> eegh
% open Matlab editor
>> edit

% copy & paste eegh results into a new
% file and save it (ploterpimage.m)

>> clear

>> close all

>> ploterpimage
>> eeglab redraw



Command line tools
write a simple plugin

List of plugins (bolded plugins are installed) No install s... B No topicfil... a

no rating - SASICA v1.3.4 (1521 downloads)
no rating - PrepPipeline v0.55.3 (1407 downloads)
- MFFimport v2.2 (1365 downloads; 2 rating)
no rating - corrmap v2.02.1 (1267 downloads)
no rating - iirfilt v1.03 (1240 downloads)
no rating - LIMO v2.0 (1238 downloads)
no rating - BCI2000import v0.36 (1086 downloads)
no rating - biopac v1.00 (1039 downloads)
no rating - loadcurry v2.0 (1005 downloads)
no rating - PACT v0.20 (984 downloads)
no rating - VisEd v1.05 (370 downloads)
no rating - std_envtopo v4.03 (934 downloads)
no rating - mass_univ v03272017 (927 downloads)
- trimOutlier v0.17 (898 downloads; 1 rating)
- NihonKoden v1.11 (796 downloads; 1 rating)
- ICLabel v1.1 update available (793 downloads; 1 rating)
no rating - loadhdf5 v1.1 (754 downloads)

no ratina  DECICA vd 00 (760 downlando)

Rate this plugin Web documentation Upload new plugin
Tags: import
Status: installed

Description of the plugin:

Import files in XDF format saved by the LabRecorder Python program to record LSL streams. This
plugin only imports EEG and Marker streams. To import a multi-stream XDF file and sync the different
data streams at the same sampling frequency for subsequent processing in EEGLAB, use the Mobilab
extension.

Cancel Remove Install/lUpdate



EEGLAB v4.6b =)
Starting EEGLAB = i
—No current dataset
>> eeglab o
eeglab: options file is /Volumes/donnees/data/STUDY ste ; %reat,,e a new or load an existing dataset
. . se "File = Import data (new)
Adding path to all EEGLAB functions Or "File > Load existing dataset' (ald)
Adding path to eeglab/external/bioelectromagnetism_ligt - If new,
Adding path to eeglab/external/biosig-partial "File > Import epoch info” (data epochs) else
Adding path to eeglab/external/fieldtrip-partial ..E'clft:;'B”;ggg;ﬁ?g..’?;%dggg??;ggiﬁﬁ%
Adding path to eeglab/external/fieldtrip-partial subfolders "File > Save dataset’ (save dataset)
EEGLAB: adding plugin function "eegplugin_VisEd" - Prune data: "Edit > Select data” !
EEGLAB: adding "eepimport1.02" plugin (see >> help ec || = Ese£8ia 1oeie 7 Relect ORI dats
EEGLAB: adding "bdfimport" plugin (see >> help eegplu - Remove baseline: "Tools > Remave baseline”
EEGLAB: adding "brainmovie0.1b" plugin (see >> help € -RunICA: "Tools » Run ICA"
EEGLAB: adding "ctfimport1.03" plugin (see >> help eec

EEGLAB: adding "dipfit2.2" plugin (see >> help eegplugi ,
EEGLAB: adding "EEG toolbox ERP plotting" plugin (see >> help eegplugin_eeg_toolbox)
EEGLAB: adding "erpssimport1.00" plugin (see >> help eegplugin_erpssimport)
EEGLAB: adding "fmrib1.21" plugin (see >> help eegplugin_fmrib)

EEGLAB: adding "iirfilt1.01" plugin (see >> help eegplugin_iirfilt)

EEGLAB: adding "eepimport1.02" plugin (see >> help eegplugin_ascinstep)

EEGLAB: adding "loreta1.0" plugin (see >> help eegplugin_loreta)

EEGLAB: adding "Butter1.0" plugin (see >> help eegplugin_ ERPLAB _filters)

EEGLAB: adding "Measure_Product1.0" plugin (see >> help eegplugin_mp_clustering)
EEGLAB: adding plugin function "eegplugin_miclust"

EEGLAB: adding "4dneuroimaging1.00" plugin (see >> help eegplugin_4dneuroimaging)
>>




eepimport1.02
bva_io1.30
ctfimport1.01

dipfit4.0
fmrib1.2b
iirfilt1.0

Proper EEGLAB plugins

Data importing for EEprobe data (Oostenved & ANT company)
Brain vision analyzer import/export plugin (Widmann & Delorme)
MEG CTF import plugin (Carver, Weber & Delorme)

4-shell and BEM (Oostenveld & Delorme)

Removal of artifact from simultaneously EEG/fMRI recording (Niazi)
Non-linear IIR filtering (Pozdin)

Matlab toolboxes interfaced as plugins

BIOSIG
File-IO
Fieldtrip
LIMO-EEG
SIFT

Data importing for rare data binary format (Schloegl)

Data importing (Oostenveld)

Source localization and time-freq. decompositions (Oostenveld)
General linear model and EEG

Source information flow toolbox



T e e e v - €  EEGLAB plugin manager

Import data

Import epoch info
Import event info

v vYVvYYVYY

lataset:
Export (new)

" (load)
BIDS tools

a folder)

Load existing dataset
Save current dataset(s)
Save current dataset as
Clear dataset(s)

o locations)

ntinuous datal

bv eve"
Create study p fke cimel

ta using ICA"

Load existing study 18"
Save current study JEE=rerave

Save current study as
Clear study / Clear all

Preferences

History scripts >

Manage EEGLAB extensions
Quit
From finders' course .mat file

List of plugins (bolded plugins are installed) No install s... a No topicfil...

no rating - SASICA v1.3.4 (1521 downloads)
no rating - PrepPipeline v0.55.3 (1407 downloads)
- MFFimport v2.2 (1365 downloads; 2 rating)

Kk k4 - xdfimport v1.14 (1363 downloads; 1 rating)

no rating - corrmap v2.02.1 (1267 downloads)
no rating - irfilt v1.03 (1240 downloads)
no rating - LIMO v2.0 (1238 downloads)
no rating - BCI2000import v0.36 (1086 downloads)
no rating - biopac v1.00 (1039 downloads)
no rating - loadcurry v2.0 (1005 downloads)
no rating - PACT v0.20 (984 downloads)
no rating - VisEd v1.05 (370 downloads)
no rating - std_envtopo v4.03 (934 downloads)
no rating - mass_univ v03272017 (927 downloads)
- trimOutlier v0.17 (898 downloads; 1 rating)
- NihonKoden v1.11 (796 downloads; 1 rating)
- ICLabel v1.1 update available (793 downloads; 1 rating)
no rating - loadhdf5 v1.1 (754 downloads)

na rating DERICA 1A 00 (7RO A

Rate this plugin

Tags: import

Status: installed

Description of the plugin:

Import files in XDF format saved by the LabRecorder Python program to record LSL streams. This
p|ugln only imports EEG and Marker streams. To import a multi-stream XDF file and sync the different
at the same sampling frequency for subsequent processing in EEGLAB, use the Mobilab

extenslon

Cancel Remove Install/Update

Upload new plugin

é

Haps Q@ G & - QoL @ H B

EEGLAB online plugin page

® G Plug-inlistall x  + (-}
* BHo ¢ GO » 2

B EeGLAB @ EEGLAB B NEMAR 2 8¢ () Welcome to NEM... lonis Discovery Pl... » | B5 Other Bookmarks Reading List

(&) & scen.ucsd.edu/eeglab/plugin_uploader/plugin_list_all.php

List of plug-ins available for download in
EEGLAB 2019.1 and later versions

You may download the .zip file associated with the plug-ins below and unzip it in the "plugins" subfolder of your EEGLAB
distribution. However, this list is primarily provided for informational purposes. To install plug-ins of interest, we recommend that you
use the EEGLAB extension manager (in the EEGLAB GUI window, select menu item "File > Manage plug-ins"). Note: it is not
possible to install new plug-ins in the EEGLAB compiled version. However, you may use a plug-in when running the compiled
version by including the plug-in code base in the EEGLAB script you run.

Plug 7 » Numberof ,

A A
Y  description Y Contact Y Ratings’ downloads ¥

Plug-in name Version

AAR 131130 ICA-based Automatic Download artifact,ica G. Gomez- 3287 0
Artifact Removal. Herrero
Note that this
extension overloads
the "pca.m" Matlab
function and can lead
to unexpected
behaviors of EEGLAB
when running ICA.
Adjust 111 Adjust plug-in to Download ica,artifact James Charles kieeve 3540
remove artifacts
automatically
AMICA 15.2 Powerful Amica ICA Download ica 2273
decomposition plug-
in (requires available
compiled binary).
Related:
postAMICAUtility
ANTeepimport 113 Import ANT .cnt data Download import v 3059
and trigger files
ARfitStudio 0.41 Cleans event-related Download artifact,preprocessing ~ Miyakoshiand ¥ 530
transient artifacts Mullen
using ARfit (beta)



3 levels of functions

Top: Administrative functions: handle EEG/ALLEEG structures
eeglab(), eeg_checkset(), pop_delset(), ...

Middle: Pop functions: interactive functions using EEG structure
pop_erpimage(), pop_topoplot(), pop_envtopo(), ...

Bottom: Signal processing functions: perform signal processing
erpimage(), topoplot(), envtopo(), ...



Writing EEGLAB plugins

* Assuming that you have a signal Process any newtimef()
processing function called xxxxx Input data

e a pop_xxxxx function will T T
mterfgce your signal processing _ Process EEG bop. newtimef()
function

structure

* aeegplugin_xxxxx function will
add the menu to the main
interface (and history etc...)



Pop functions

Called with the EEG structure only pop_xxxxx(EEG), they pop-up
a GUI asking for more arguments

Called with enough arguments, the simply call the signal
processing function

Title of wi. .. B@

function [EEG, com] = pop_sample( EEG, param1); Enter the parameter:
| 0

com ="; % empty history

if nargin <2 ) ] Cancel| Help | 0Ok |
% pop up window if less than 2 arguments
result = inputdig({ 'Enter the parameter:' }, 'Title of window', 1, {'0'})

if length( result ) == 0 return; end;

param1 =eval( [ [ result{1} '] ]1); % the brackets allow to process matlab arrays
end;

sample( EEG.data, param1); % run sample function

com = sprintf('pop_sample(EEG, %d );', param1); % return history




EEGLAB Data Structures

EEG - root ‘dataset’ structure
.data - the dataset data (2-D, 3-D matrix)
.chanlocs - channel locations substructure
.event - data events substructure
.epoch - data epochs substructure
ALLEEG - vector of loaded EEG datasets

CURRENTSET - index in ALLEEG of current EEG dataset
STUDY - root ‘studyset’ structure

.Cluster - component clustering substructure



EEG structure

Number of data points

EEG= setname:'Epoched from "ee 114 continuous" per trial
filename:'ee114squaresepochs,

filepath:'fhomefarn Number of channels
pnts:384/
nbchan:32

trials: 80 <« .
srate: 128 Number of trials

xmin -1 _
xmax:1.9922 Sampling rate
data:[32x384x80 double]
icawinv:[32x32 double] i imi
icasphere:[32x32 double] \ Time limits
Icaweights:[32x32 double]

Data
icaact:[32x384x80 double]

event:[1x157 struct]
epoch:[1x80 struct] ICA scalp maps
chanlocs:[1x32 struct]
comments:[8x150 char]

averer{:'[r]w' ICA activity
eventdescription:{1x5 cell}
epochdescription:{}
specdata:(] Epoch/event
specicaact:[] inf ti
reject:[1x1 struct] Information
stats:[1x1 struct]
splinefile:[]
ref'common’

history:[7x138 char] Channel location
urevent:[1x154 struct]
times:[1x384 double]




EEG=

The EEG
structure can
be extended

to include

new fields

store
information
for future
access

EEG structure

Number of data points

setname:'Epoched from "ee114 continuous" per trial

filename:'ee114squaresepochs.set

filepath:'thomefarn Number of channels
pnts:384/

nbchan:32

trials: 80 <« .
srate: 128 Number of trials

xmin -1

xmax:1.9922 Sampling rate
data:[32x384x80 double]
icawinv:[32x32 double] : e
icasphere:[32x32 double] \ Time limits

icaweights:[32x32 double] Data
icaact:[32x384x80 double]

event:[ 1157 struct]}

epoch:[1x80 struct] ICA scalp maps
chanlocs:[1x32 struct]
comments:[8x150 char]

avererlzi'[r]w' ICA activity
eventdescription:{1x5 cell}
epochdescription:{}
specdata[] Epoch/event
specica_act:[] inf ti
reject:[1x1 struct] Information
stats:[1x1 struct]
splinefile:[]
ref'common’

history:[7x138 char] Channel location
urevent:[1x154 struct]
times:[1x384 double]




EEG.data =

Continuous data

2.1 38 49 51 48 3.9

-13 -24 -05 -03 14 25 ..

052 47 33 12 07 1.3




Data epochs

(21 38 49 51 48

EEG.data =|-13 -24 -05 -03 14
52 47 33 12 07

(21 38 49 51 438
~13 -24 -05 -03 14
|52 47 33 12 07

(21 38 49 51 48
~-13 -24 -05 -03 14
|52 47 33 12 07

Plot ERP for your data

3.9
2.5
1.3

3.9
2.5
1.3

3.9
2.5
1.3

>> figure; plot(mean(EEG.data,3));
>> figure; plot(EEG.times, mean(EEG.data,3)’);

Trials 1: EEG.data(:,:,1)

Trials 2: EEG.data(:,:,2)

Trials 3: EEG.data(:,:,3)



eegplugin functions

* eegplugin_erp.m function in “plugins” folder of EEGLAB

% eegplugin_erp() - plot ERP plugin
function eegplugin_erp( fig, try_strings, catch_strings)

% create menu
plotmenu = findobj(fig, 'tag’, ‘plot’); % find plot menu

% create submenu
uimenu( plotmenu, 'label’, 'ERP plugin’, ...
‘callback’, 'figure; plot(EEG.times, mean(EEG.data,3));’);

To test, load file in sample data folder eeglab_data epochs_ica.set



eegplugin functions

>> eeglab

eeglab: adding "BIOSIGv0.86" plugin

eeglab: adding "eepimport1.02" plugin (see >> help eegplugin_eepimport)
eeglab: adding "bva_i01.30" plugin (see >> help eegplugin_bva_io)
eeglab: adding "ctfimport1.01" plugin (see >> help eegplugin_ctfimport)
eeglab: adding "dipfit2.0" plugin (see >> help eegplugin_dipfit2_0)

ab: adding plugin function "eegplugin_erp"™ >
eeglab: adding "TmrbT.Zb" plugin (see >> help eegplugin_fmrib)

eeglab: adding "icaclust1.00" plugin (see >> help eegplugin_icaclust)
eeglab: adding "iirfilt1.0" plugin (see >> help eegplugin_iirfilt)
eeglab: adding "loreta1.0" plugin (see >> help eegplugin_loreta)

eeglab: adding "newtimefreq1.00" plugin (see >> help eegplugin_ne Bl Frewre o 2
igure No.

BE=X

>>
File Edit Yiew Insert Tools Window Help

EEGLAB v4.6b [ 2% ‘ :

DEEdE YA/ BP0

File Edit Tools Plot Datasets Help

Channel locations » 20

#1: Ep Channel data {scroll) >ontinuo...
Channel spectra and maps 15
Filename  Channel properties hsICA . set
Channelé  Channel ERP image 10
Frames 1 Channel ERPs >
Epochs ERP map series > 5
Events SumjCompare ERPs
Sampling  component activations (scroll) 0% b
Epoch st Component spectra and maps ¥
Epoch er  Component maps > 5
Average Component properties
Channel Component ERP image -10
ICA Weig Component ERPs 14
Dataset ¢ SumjCompare comp. ERPs / 15
Data statistics 4 /
Time-frequency transforms » // -?10 0on _5010 Ul

ERP plugin

1 1 1
500 1000 1500 2000




PCA plugin

function vers = eegplugin_pcaf(fig, trystrs, catchstrs)
vers = ‘pca1.00';

% find tools menu
menu = findobj(fig, 'tag’, 'tools’);

% PCA command

cmd = [ '[~ EEG.icawinv] = runpca(EEG.data(:,:));'];
cmd = [ cmd 'EEG.icaweights = pinv(EEG.icawinv);’ ];
cmd = [ cmd 'EEG.icasphere = eye(EEG.nbchan);’ ];

% create menu
uimenu( menu, 'Label', ‘Run PCA', 'CallBack’, cmd, 'separator’, 'on');

'import data’ -> File > import data menu
'import epoch’ -> File > import epoch menu
'import event' -> File > import event menu
‘export’ -> File > export

‘tools’ -> tools menu

‘plot’ -> plot menu



EXxercice

Write a plugin to plot ERPs

Copy and paste code from PDF

Save eegplugin_erp.m in the plugins
folder of EEGLAB

Restart EEGLAB

Load epoched EEGLAB dataset
(eeglab_data epochs ica.set from
sample data subfolder of EEGLAB)

Use plugin menu

Flo Edt View Insert Tooks Window Hep

BEX]




