EEGLAB overview



EEGLAB history

1997 — EEG/ICA Toolbox (Salk Institute)

2001 — 15t EEGLAB for artifact rejection (Salk Institute)

2003 — 1stintegrated EEGLAB issued to wide audience (Salk Institute)

2004 — 18t EEGLAB support from US. NIH and reference paper (UCSD)

2006 — 18t EEGLAB plug-ins, STUDY structure, and component clustering tools
2009+ — New associated toolboxes: NFT, SIFT, BCILAB, MPT,

2011 — EEGLAB, the most widely used EEG research environment

2014 — EEGLAB plugin manager

2018 — EEGLAB single trial and LIMO integration



EEGLAB overview

Collection of about 600 functions (70 000 lines of code)

About 250 000 download over the past 10 years

6,500 users on the discussion list and 15,000 on the diffusion list
NIH funding since 2003

/5 plugins

Supporting 288 million of dollars of research as of 2017

140,000 EEGLAB
session/month
(mixpanel)



Hanke & Helcencko, 2011, Frontier in Neuroinformatics

Software popularity: Electrophysiology, MEG/EEG

EEGLAB [168]

Neuroshare [9)
Openelectrophy 7]

BrainStorm [56] BrainSuite' [6]

Brainvision Analyzer [55] EMSE' [5)
LORETA/SLORETA [48) MClust [4]
RTXI (3]

MNE suite [31] cedspike’ [2]

Relacs [2]
Elekta Neuromag [21] NeuroScope' (2]
Chronux (17) Klusters' [2]
OpenMEEG [16] netstation' [2]
Trellis-neuro [1]
nutmeg' [1]
erplab' [1)
FMAToolbox' [1]
datariver’ [1]
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EEGLAB compared to other
EEG software packages

EEG Data Analysis

Environments EEGLAB Fieldtrip | Brainstorm | BVA* BESA | ERPLAB# |SPM§ | Curry | ASA | EMSE
License (Open Source,

Commercial) Open Open Open Com| Com Open Open| Com |Com| Com
User base*** &&&E&EE&EEEEEE | &&&E& &&& &&& | && & & & & &
Matlab based (Y/N) Y Y Y N N Y Y N N N
Time-freq. decomposition Y Y N Y N N Y N N N
Sourc.e.l'ocallzanon +++ ++++ ++++ + ++++ § R P [
capabilities +

Plug-ins & scripting " "
(Yes/No/Basic) Y Y B Y B B B B ?N ’N
Statistics (Yes/No/B=basic) Y Y N N N B Y N N N
ICA (Y/N/B=basic) Y Y** N B B N N B ?N ?
Group level analysis "

(Y/N/B=basic) Y B Y Y Y B ‘ Y Y Y
Cloud & GPU computing B B N N N N N N N N

*Brain Vision Analyzer (Brain Products Inc.);
**Uses an EEGLAB function for ICA
***As per a 2011 survey by (Hanke et al., 2011)

# Built as a plug-in to EEGLAB for ERP research
§ SPM and DCM (Dynamical Causal Modeling) for ERPs




Plug-In

10NS

Extens

S. Makeig et al. (2011)



Source Information Flow Toolbox

Pre-
processing

Model Fitting
and Validation

Connectivity

Frequency (Hz)

Statistics

Group
Analysis

Visualization

Time (sec)



BCILAB - C. Kothe

JLeIE) Ssoae 51X

Data Source | Offline Analysis Online Analysis  Settings Help

i e i — Selected approach |lastapproach ("Spectrally Weighted C -
=14} " Bt By New approach... Ctrl+N P l il ("Se y Y9 —I
= v A

EI.S' = '_ ¥ Moadify approach... Ctri+M Calibration data source I lastdata ("imag.vhdr") Z'
ignal Processing ) .
[=] SignalProcessing Review/edit approach... Ctrl+R Parameter Search
FilterOrdering Save approach... Ctrk+S Loss/Performance Metric [Atomatically chosen |
[=] Resampling Train new model... Chrl+T
SamplingRate Cross-validation folds 5
Channe'IJSelzction Apply'model to data... Ctr+A  |ooalel De I
e —— Visualize model... Cr+V [ Spacing around test trials I 5
S —— Investigate results. .. Ctrl+1 = 5'
Surfacelaplacian iIe S e e Transform data by model... Ctrl+P - 2
FIRFilter - rmance estimates
— - e \ ¢ —
Projection Do de | B RRARODBDEL- S| 0EE | ol .
IIRFilter ption folds | 10

Standardization . e I5—
SparseReconstruction .

[=] EpochExtraction

TimeWindow s
EventTypes Iter cluster
BaselineRemoval
WindowSelection Hode pool | (use current config)
SpectralTransform Spec-CSP Pattern 1 Spec-CSP Pattern 2 Spec-CSP Pattern 3
[=] SpectralSelection 0.04 0.04 0.05
P ;space as | lastmodel
FrequencySpecification 0.02 1 002
E Feature Extraction : : 0 ispace as l laststats
[=] FeatureExtraction
PatternPairs a 2 40 a 40 a 20 40 Cancel | OK I
ParameterP
ParameterQ
SpectralPrior
MaxIterations bn, ' Z0',0,'F1',1, 'Err',2,
[=] PluginFunctions . o .
b 'n-SlackShrink',1,'1-51¢
FeatureAdaptor Spec-CSP Pattern 6 Spec-CSP Pattern 5 Spec-CSP Pattern 4 o el ? b s ]
ICA 0.05 0.04 0.04 poly’,1,'rbL!, 2, sigmoic
Annotate the Signal with a spatial pubsetHeurstic’, 1, 'Fixed}
ICA) (Fl_ica). 0.02 0.02 h,'12',2);
0 R 0 R 0 R ling, 'slack',1, 'margin',:
Help | 0 20 40 0 20 40 0 20 40
= oo e g~ 5 =1 5d -w 5d -2 3£
[ O = F AJ P 4 b 3 ) i




NFT: Neuroelectromagnetic Forward Head Modeling Toolbox

Segmentation Electrode
- K
Mesh Generation - - -
Registration Template Warping
B Forward Problem Solution o ® ==
i > _ .II l 44 _
Cndions 109
,_ ot /data/projects/zeynep/NFT_demo/jop3.elp
[ Mumber of Nodes
[T Number of Bements
,7 Number of Nodes Eler

Load Source Space

http://sccn.ucsd.edu/nft



List of data import extensions

Plug-in name & Version Short plug-in description $ Link # Contact & Comments &
MFFimport & 1.00 Import MFF files from the EGI company | Download @& | S. Chennu 3 User comments
ANTeepimport & 1.10 Import ANT .cnt data and trigger files | Download & | M. van de Velde 5} User comments
BCI12000import & 0.36 Import BCI2000 data files Download & C. Boulay 3 User comments
BDFimport 1.10 Import BDF data files Download @@ | A.Delormesd | User comments
biopac 1.00 Import BIOPAC data files Download & | A.DelormeS |User comments
ctfimport 1.04 Import CTF (MEG) data files Download & D. Weber 3 User comments
erpssimport 1.01 Import ERPSS data files Download @@ | A.Delormesd | User comments
INSTEPascimport 1.00 Import INSTEP ASCII data files Download & | A.DelormeS |User comments
neuroimaging4d 1.00 Import Neuroimaging4d data files Download & | C. Wienbruch & |User comments
Procominfinity 1.00 Import Procom Infinity data files Download @@ | A. Delorme 3 User comments
WearableSensing 1.09 Import Wearable Sensing files Download & S. Pilen 3 User comments
NihonKoden 0.10 Import Nihon Koden MOO files (beta) | Download & = M. Miyakoshi &4 | User comments
xdfimport 1.12 Import files in XDF format Download & C. Kothe 3 User comments
bva-io & 1.5.12 Import Brain Vision Analyser data files | Download & = A. Widmann},  User comments
Fileio & Daily Import multiple data files formats | Download [ | R. Oostenveld & |User comments
Biosig &’ 2.88 Import multiple data files formats Download % | A.Schloegld |User comments
Cogniscan & 1.1 Import Cogniscan data files Download & P. Sajda 3 User comments
NeurOne & 1.0.3.2 Import NeurOne data files Download & Support 5 User comments
loadhdf5 1.0 Load hdfs files recorded with g.recorder Download & |Simon L. Kappel = |User comments




List of data processing extensions

=

Plug-in name % Version Short plug-in description $ Link # Contact % Comments &
rERP & 0.4 Estimate overlapping ERPs using multiple regression Download @& M. Burns § User comments
LIMO S 1.5 Linear MOdelling of EEG data Download & C. Pemet 3 User comments
corrmap & 2.02 Cluster ICA components using correlation of scalp maps Download & S. Debener 3 User comments
bioelectromag & 1.01 Uses Bioelectromagnetism toolbox for ERP peak detection Download @& D. Weber S User comments
VisEd & 1.05 Add/Edit dataset events Download @& J. Desjardins 5 User comments
loreta 1.10 Export and import data to and from LORETA software Download & A. Delorme 5 User comments

iirfilt 1.02 Non linear filtering using IIR filter Download & M. Pozdin 5 User comments
std_envtopo 2.39 Plot STUDY ICA cluster contribution to ERP Download & M. Miyakoshi 3 User comments
std_selectiCsByCluster & 0.10 Forward-project clustered ICs to channels (beta) Download & M. Miyakoshi &3 User comments
std_dipoleDensity & 0.23 Plot STUDY ICA cluster dipole density (beta) Download & M. Miyakoshi 5 User comments
std_ErpCalc 0.11 Test and visualize simple effects on ERP (beta) Download & M. Miyakoshi 3 User comments
pvaftopo 0.10 Plot topography of percent variance accounted for (beta) Download & M. Miyakoshi 5 User comments
trimOutlier & 0.16 Trim outlier channels and datapoints interactively (beta) Download & M. Miyakoshi 5 User comments
clean_rawdata B 0.31 Cleans continuous data using Artifact Subspace Reconstruction Download & | Miyakoshi and Kothe & |User comments
AR(itStudio & 0.10 Cleans spiky artifacts using AFfit (beta) Download @& |Miyakoshi and Mullen &3 | User comments
Mutual_Info_Clustering 1.00 Group single dataset ICA components by Mutual Information Download & N. Bigdely User comments
mass_univ & 130502 Mass Univariate ERP Toolbox Download & D. Groppe 5 User comments
REGICA & 1.00 ICA regression based EOG removal Download @& M. Klados User comments
MARA & 1.1 Multiple Artifact Rejection Algorithm Download @& I. Winkler 5 User comments

firfilt 5 1.6.1 Routines for designing linear filters Download & A. Widmann 2 User comments
PACT & 0.17 Computes phase-amplitude coupling for continuous data Download &2 M. Miyakoshi User comments
fMRIb & 2.00 Remove fMRI artifacts from EEG Download & | J. Dien 3 & R. Niazy |User comments
SIFT & 1.33 Analysis and visualization of multivariate connectivity Download & T. Mullen S User comments
AAR S 131130 ICA-based Automatic Artifact Removal Download @@ | G. Gomez-Herrero & |User comments
Adjust & 1.1 Automatic Detector - Joint Use of Spatial and Temporal features Download & Adjust Support 3 User comments
Cleanline & 1.02 Removes sinusoidal artifacts (line noise) Download @& T. Mullen 5 User comments
Fieldtrip-lite & Daily Adds source localization and statistics tools to EEGLAB Download [J R. Oostenveld 5 User comments
EYE-EEG & 0.41 Open source MATLAB tool for simultaneous eye tracking & EEG Download & 0. Dimigen 5 User comments

- . .-

as aa -




EEGLAB standard processing pipeline

Single subject
Import binary data, events and channel location
Edit, Re-reference, Resample, High pass filter data
Reject artifacts in continuous data by visual inspection
Extract epochs from data & reject artifactual epochs
Visualize data measures
Perform ICA decomposition

— Perform source localization of components

— Analyze components contribution to ERP

— Analyze components contribution to spectrum

S o

Multi-subjects

1. Build study and STUDY design
2. Pre-compute measures

3. Cluster components

4, Analyze clusters

Advanced analysis using scripting and EEGLAB command line functions



The EEGLAB Matlab software

® OO EEGLAB v13.x dev

File Edit Tools Plot Study Datasets Help

MATLAB R2012a 4

File Edit Debug Parallel Desktop Window

}
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Shortcuts 2] Howto Add 2] What's New
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>>
fx >> eeglab

4\ Start

——No current dataset

- Create a new or load an existina
Use "File > Import data"
Or "File > Load existing dataset"
- If new.
"File > Import epoch info" (data
"File > Import event info" (continuous
"Edit > Dataset info" (add/edit
"File > Save dataset" (save dataset)
- Prune data: "Edit > Select data"
- Reject data: "Tools > Reject
- Epoch data: "Tools > Extract evochs"
- Remove baseline: "Tools > Remove

- Run ICA: "Tools > Run ICA"

—




1. Importing data

Import/load data

O @ EEGLAB v13.x (dev)
I Edit Tools Plot Study Datasets Help
Import data

Import epoch info
Import event info
Export

Load existing dataset
Save current dataset(s)
Save current dataset as
Clear dataset(s)

Create study

Load existing study
Save current study
Save current study as
Clear study / Clear all

Memory and other options

History scripts

> Using EEGLAB functions and plugins »

: Using the FILE-1O interface
> Using the BIOSIG interface
Troubleshooting data formats...
(data
(continuous
/edit

e dataset)
data"

ct

ct evochs"
Remove
(o

—

>

Manage EEGLAB extensions »

Quit

From ASCII/float file or Matlab array

From Netstation binary simple file
From EGI Net Station .MFF file
From Multiple seg. Netstation files
From Netstation Matlab files

From BCI2000 ASCII file
From Snapmaster .SMA file

From Neuroscan .CNT file
From Neuroscan .EEG file

From Biosemi BDF file (BIOSIG toolbox)
From EDF/EDF+ /GDF files (BIOSIG toolbox)
From Biosemi BDF and EDF files (BDF plugin)

From a NeurOne file (.ses)
From BIOPAC MATLARB files

From Brain Vis. Rec. .vhdr file
From Brain Vis. Anal. Matlab file

From ERPSS .RAW or .RDF file
From EGI .MFF file



1. Importing data

Import events

| NON EEGLAB v13.x (dev)

m Edit Tools Plot Study Datasets Help

Import data > |

Import epoch info L

>
Import event info >

Export >

Load existing dataset
Save current dataset(s)
Save current dataset as :

|

From Matlab array or ASCII file
From data channel

From Presentation .LOG file
From E-Prime ASCII (text) file
From Neuroscan .ev2 file

Clear dataset(s)

Load existing study
Save current study
Save current study as
Clear study / Clear all

Create study » is

History scripts >
Manage EEGLAB extensions »

Quit

Memory and other options r



1. Importing data

Data info

@00

Scrolling data

Scroll channel activities -- eegplot()

[ NON EEGLAB v13.x (dev)
File Edit Tools Plot Study Datasets Help
—#1: Continuous EEG Data

Filename: ...sample data/eeglab data.set

Channels per frame 32

Frames per epoch 30504

Epochs 1

Events 154

Sampling rate (Hz) 128

Epoch start (sec) 0.000

Epoch end (sec) 238.305

Reference unknown

Channel locations No

ICA weights No

Dataset size (Mb) 4.3

Figure Display Settings Help
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1. Importing channel location

Import channel location

O O EEGLAB v13.x (dev)
File m Tools Plot ; Datasets Help
___, Datasetinfo

Event fields

Event values
About this dataset
| Channel locations

¥ Select data
¥ Select data using events
Select epochs or events

Copy current dataset
Append datasets
Delete dataset(s) from memory

A M

Edit events & mark bad channels

«E23
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2. Edit, Re-reference, Resample, High pass filter data

© @®
File

Edit/select data

EEGLAB v13.x (dev)
Tools Plot Study Datasets

Dataset info
Event fields
Event values
About this dataset
Channel locations

Select data
Select data using events
Select epochs or events

Copy current dataset
Append datasets
Delete dataset(s) from memory

Edit events & mark bad channels

Preprocessing data

[ NON ) EEGLAB v13.x (dev)
File Edit Plot Study Datasets Help

#1: Co C_hange sampling rate b
Filter the data >
Re-reference

Filenam
Interpolate electrodes

Channel . .
Reject continuous data by eye

Frames

Rl Extract epochs

A Remove baseline

Sampling

Epoch st Run ICA

Epoch en Remove components

Referenc . . .
Automatic channel rejection

Channel . ¢ . .

Lca weiq Automatic continuous rejection

g9 .

Dataset Automatic EDOCh rejection
Reject data epochs >
Reject data using ICA > fl
Remove artifacts using ACSTP
Clean continuous data using ASR
Locate dipoles using DIPFIT 2.x  »
LIMO EEG 2.0 >



3. Reject artifacts in continuous data by visual inspection

Reject portions of continuous data

‘@00 Scroll channel activities —- eegplot()
Figure Display Settings Help

[ NON EEGLAB v13.x (dev)

File EditPIot Study Datasets Help

#1:ConJ C'hange sampling rate 3
Filter the data >
Re-reference
Filename
Interpolate electrodes
Channels : " e
. Reject continuous data by eye
rames p
€<
bl Extract epochs =
Events Remove baseline A R
Sampling oy
Epoch st Run ICA
Epoch en Remove components v
Referenc i X X g
Automatic channel rejection ¥
Channel . ; . . ¥ Sl
rca vel Automatic continuous rejection
weig 37
Datased Automatic epoch rejection 7 -
= 537 538 539 540
Reject data epochs >
Reject data using ICA > L Can. Time Vale =
J g P CANCEL] ~ Event types| [=] =35 =1 rpt saz.7es8 57501 [ 37 | = =2
Remove artifacts using ACSTP l Y )
Clean continuous data using ASR Bad portion of data

A 4

Locate dipoles using DIPFIT 2.x
LIMO EEG 2.0 >

Bad channel



4. Extract epochs from data & reject artifactual epochs

Preprocessing data

[ NON ) EEGLAB v13.x (dev)
File Edit Imu Plot Study Datasets Help
_ 41.cont Change sampling rate | | NON Extract data epochs - pop_epoch()
Filter the data >
i Re-reference Time-locking event type(s) ([=all) square [ ...
Channels Int.erpolate-electrodes Epoch limits [start, end] in seconds -12
ceamol Reject continuous data by eye ’
Name for the new dataset Continuous EEG Data epochs
Epochs Extract epochs D>
Events Remove baseline Out-of-bounds EEG limits if any [min max]
Samplin
Epoch s Run ICA
Epoch e Remove components Help Cancel Ok
Referenc

Automatic channel rejection
Automatic continuous rejection
Automatic epoch rejection

Channel
ICA weig

Dataset

Reject data epochs >
Reject data using ICA > L
-
Remove artifacts using ACSTP
Clean continuous data using ASR
. . L DN W, T S
Locate dipoles using DIPFIT2.x  » 2 b m Wm
Ve S AR MW
B e B B e i MM S P
LIMO EEG 2.0 > e W*‘MWWWM: Bgperm T e
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4. Extract epochs from data & reject artifactual epochs

File Edit Plot Study Datasets Help

—#1: Cont

Filename
Channels
Frames p
Epochs
Events
Sampling
Epoch st
Epoch en
Referenc
Channel

ICA weig

Dataset

EEGLAB v13.x (dev)

Change sampling rate

Filter the data

Re-reference

Interpolate electrodes

Reject continuous data by eye

Extract epochs
Remove baseline

Run ICA
Remove components

Automatic channel rejection
Automatic continuous rejection
Automatic epoch rejection
Reject data epochs

Reject data using ICA

Remove artifacts using ACSTP

Clean continuous data using ASR

Locate dipoles using DIPFIT 2.x
LIMO EEG 2.0

>

Reject data (all methods)
Reject by inspection

Reject extreme values

Reject by linear trend/variance
Reject by probability

Reject by kurtosis

Reject by spectra

Export marks to ICA reject

Reject marked epochs

Different color = different rejection methods

v scroll activity — eegplot()

2

Figure Display Seftings Help
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| NON ) EEGLAB v13.x (dev)
File Edit Toolsm Study Datasets Help

— #1:ContinuousEg  Channel locations

Channel data (scroll)
Channel spectra and maps
Channel properties
Channel ERP image
Channel ERPs

ERP map series

Filename: ...samp
Channels per fram
Frames per epoch
Epochs
Events

Sampling rate (Hz

> With scalp maps
> In scalp/rect. array

—

5. Visualize data measures

Sum/Compare ERPs

Epoch start (sec)
Component activations (scroll)
Component spectra and maps
Component maps >
Component properties
Component ERP image
Component ERPs >

ﬁ Sum/Compare comp. ERPs
>

Data statistics

Epoch end (sec)
Reference
Channel locations
ICA weights

Dataset size (Mb)

Time-frequency transforms >

Plot ERP

[ NON ) Figure 2: plottopo()
File Edit View Insert Tools Desktop Window Help
» DEdS b ALODRL-" NE mm
[ NON ] Figure 3
EEG Data epoc File Edit View Insert Tools Desktop Window Help
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5. Visualize data measures

Plot ERP
map series

[ NON ) EEGLAB v13.x (dev)
File Edit Tools m Study Datasets Help
—#1: EEGDataepoc  CNannel locations >

Channel data (scroll)

Filename: .../eeal  Channel spectra and maps
Channels per fram  Channel properties

Frames per epoch Channel ERP image

Epochs Channel ERPs >

Sampling rate (Hzl  Sum/Compare ERPs
Epoch start (sec)

Epoch end (sec) Component activations (scroll)
Reference Component spectra and maps
Channel locations Component maps >
Component properties

Dataset size (Mb) Component ERP image
Component ERPs >

ﬁ Sum/Compare comp. ERPs
Data statistics >

Time-frequency transforms >

ICA weights

In2-D
In 3-D

Tv Figure No. 2

File Edit View Insert Tools Window Help

[czR&a| hA /| 220

0ms

"ee114 continuous" epochs ERP

20
10
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-20 °

v Figure No. 2

File Edit View Inset Tools Window Help
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5. Visualize data measures

Figure No. 2: spectopo()
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5. Visualize data measures
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| NON | EEGLAB v13.x (dev)
File Edit Tools Study Datasets Help
Channel locations >

—#1: EEG Data epoc

Channel data (scroll)

Filename: .../eeal  Channel spectra and maps

Channels per frami  Channel properties
diialadiaas  Channel ERPimage
EECChE Channel ERPs 2
ERSSES ERP map series >

Sampling rate (Hz Sum/compare ERPs
Epoch start (sec)

Epoch end (sec) Component activations (scroll)

Reference Component spectra and maps

Channel locations| Component maps >

ICA weights Component properties

Dataset size (Mo)| Component ERP image
Component ERPs >

ﬁ Sum/Compare comp. ERPs
Data statistics >

Time-frequency transforms >

Single-trial ERPs at Cz

50

T

T

100

T

150

200

T

250

3001

350

Median RT

100

300 500 700 900
Time (msec)



EEGLAB standard processing pipeline

6. Perform ICA decomposition
— Perform source localization of components
— Analyze components contribution to ERP
— Analyze components contribution to spectrum



6. Perform ICA decomposition
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Localizing components

Figure No. 2
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(v Figure No. 4 - ™
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Component contribution to the ERP

EEGLAB v13.x (dev)
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Component contribution
to the EEG spectrum

Figure No. 2: spectopo()
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Component time-frequency
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EEGLAB standard processing pipeline

Single subject

Multi-subjects

1. Build study and STUDY design
2. Pre-compute measures

3. Cluster components

4, Analyze clusters
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Channel plotting

View and edit current channels -- pop_chanplot()
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EEGLAB standard processing pipeline

Advanced analysis using scripting and EEGLAB command line functions



EEG structure
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3 levels of functions

Administrative functions: handle EEG and ALLEEG

structures
eeglab(), eeg_checkset(), pop_delset(), ...

Pop functions: interactive functions using EEG structure
pop_erpimage(), pop_topoplot(), pop_envtopo(), ...

Signal processing functions: perform signal processing
erpimage(), topoplot(), envtopo(), ...



Command line tools

(“eegh” Menus write both dataset and global history)

« Automated processing on groups of subjects (possibly
on several processors).

« Richer options for plotting and processing functions
(time-frequency decompositions, ...)

« Custom processing...



EEGLAB Scripting

[ALLEEG EEG CURRENTSET ALLCOM] = eeglab;

pop_editoptions( 'option storedisk', 1);

subjects = {'S01' 'S02' 'S03' 'sS04' 's05' 's06' 'sS07' 's08' 'sS09' 's10' 'sS11l' 'sSi2'};
filepath = '/Users/arno/temp/STUDY'; % XXXXX Change path here XXXXX

if ~exist(filepath), error('You need to change the path to the STUDY'); end;

commands = {}; % initialize STUDY dataset list

% Loop through all of the subjects in the study to create the dataset
for loopnum = 1l:length(subjects) %for each subject

IgnoreFile = fullfile(filepath, subjects{loopnum}, 'Ignore.set');

MemorizeFile = fullfile(filepath, subjects{loopnum}, 'Memorize.set');

ProbeFile = fullfile(filepath, subjects{loopnum}, 'Probe.set');

commands = {commands{:}
{'index' 3*loopnum-2 'load' IgnoreFile 'subject' subjects{loopnum} 'condition' 'Ignore'}
{'index' 3*loopnum-1 'load' MemorizeFile 'subject' subjects{loopnum} 'condition' 'Memorize'}
{'index' 3*loopnum 'load' ProbeFile 'subject' subjects{loopnum} 'condition' 'Probe'}};

end;

% Uncomment the line below to select ICA components with less than 15% residual wvariance

% commands = {commands{:} {'dipselect', 0.15}};

[STUDY, ALLEEG] = std editset(STUDY, ALLEEG, 'name', 'Sternberg', 'commands',6 commands,'updatedat',6 'on');

% Update workspace variables and redraw EEGLAB

CURRENTSTUDY = 1; EEG = ALLEEG; CURRENTSET = [l:length (EEG)];
[STUDY, ALLEEG] = std_checkset (STUDY, ALLEEG) ;

eeglab redraw

[STUDY ALLEEG] = std precomp (STUDY, ALLEEG, {},'rmicacomps','on', 'interp', 'on', 'recompute',6'on',6'erp',6 'on');
STUDY = pop_erpparams (STUDY, 'topotime', [200 300] )
[STUDY erpdata] = std _erpplot(STUDY,ALLEEG, 'channels',6 {'LEYE' 'REYE' 'OZ' 'O2' 'FP1l' 'FPZ' 'FP2' 'AF7'

'AF3' 'AFZ' 'AF4' 'AF8' 'F9' 'F7' 'F5' 'F3' 'Fl1l' 'FZ' 'F2' 'F4' 'F6' 'F8' 'F10' 'FT9'

'FT7' 'FC5' 'FC3' 'FCl' 'FCZ' 'FC2' 'FC4' 'FC6' 'FT8' 'FT10' 'T7' 'C5' 'C3' 'Cl' 'CZ'

'C2' 'C4' 'Cé' 'T8' 'TP9' 'TP7' 'CP5' 'CP3' 'CP1l' 'CPZ' 'CP2' 'CP4' 'CP6' 'TP8' 'TP10'

'P7' 'P5' 'P3' 'P1' 'PZ' 'P2' 'P4' 'P6' 'P8' 'PO9' 'PO7' 'PO3' 'POZ' 'PO4' 'PO8' 'PO1l0' 'Ol1l'});

dlmwrite ('erpfile.txt',6 squeeze (erpdata{l}), 'delimiter', '\t', 'precision',6 2);
dlmwrite ('erpfile.txt',6 squeeze (erpdata{2}),'-append', 'roffset', 1, 'delimiter',6 '\t',6 'precision',6 2);
dlmwrite ('erpfile.txt',6 squeeze (erpdata{2}),'-append', 'roffset', 1, 'delimiter',6 '\t',6 'precision',6 2);



Pros/Cons of Matlab based open source

* Pros

— Easy to program, highly modular and extendable

— Not dependent on any platform (64-bit) and highly
optimized

— Large community of users (latest development in signal
processing research)

— Powerful scripting capabilities

« Cons
— Matlab required for which you have to pay
— Large memory requirements

— Matlab bugs, possible version differences, cross-
platform compatibility problems

— Poor graphical interface
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Preliminary Workshop Program (with corresponding PDFs)

Purple lettering = lecture

Tuesday, September 4th 2018

Overview and ICA Theory/Practice
8:30AM — 9:45AM -- Mining event-related brain dynamics | (Scott Makeig)
9:45AM — 10:15AM -- EEGLAB overview (Arnaud Delorme)
-- Coffee Break--

10:30AM — 11:30AM -- ICA theory (Scott Makeig)

12:30-2:00PM < Lunch -- On your own

ICA and time-frequency

--Coffee Break--

3:30PM — 4:15PM -- Time-frequency decompositions: Theory and practice (Scott Makeig)
4:15PM — 5:15PM -- Source information flow and Granger-Causal modeling tools (Arnaud Delorme)

Wednesday, September 5th 2018

Source Localization
8:30AM — 9:15AM -- Forward and inverse modeling (Scott Makeig)
9:15AM — 10:00AM -- DIPFIT practicum (Arnaud Delorme)

-- Coffee Break--

10:15AM - 11:15AM -- Why cluster ICA components? (Scott Makeig)
11:15AM - 12:00AM -- Robust statistics and correction for multiple comparisons (Arnaud Delorme)
12:00AM - 12:30AM -- Creating a STUDY, STUDY design, and basic plotting (Arnaud Delorme)

12:30AM-2:00PM Lunch -- On your own

Group analysis and ICA clustering in EEGLAB
2:00PM - 3:15PM -- Group analysis using EEGLAB studies: Methods to cluster ICA components (Arnaud Delorme)

-- Coffee Break--

4:00PM — 5:00PM -- Mining event-related brain dynamics Il (Scott Makeig)



