EEGLAB overview



EEGLAB history

1997 — EEG/ICA Toolbox (Salk Institute)

2001 — 18t EEGLAB for artifact rejection (Salk Institute)

2003 — 18t integrated EEGLAB issued to wide audience (Salk Institute)

2004 — 1t EEGLAB support from US. NIH and reference paper (UCSD)

2006 — 18t EEGLAB plug-ins, STUDY structure, and component clustering tools
2009+ — New associated toolboxes: NFT, SIFT, BCILAB, MPT,

2011 — EEGLAB, the most widely used EEG research environment

2014 — EEGLAB plugin manager

2018 — EEGLAB single trial and LIMO integration



EEGLAB overview

Collection of about 600 functions (70 000 lines of code)

About 250 000 download over the past 10 years

6,500 users on the discussion list and 15,000 on the diffusion list
NIH funding since 2003

75 plugins

Supporting 288 million of dollars of research as of 2017

140,000 EEGLAB
session/month
(mixpanel)



Hanke & Helcencko, 2011, Frontier in

Software popularity: Electrophysiology, MEG/EEG

BrainStorm [56]
Brainvision Analyzer [55]

LORETA/SLORETA [48]

MNE suite [31]

Elekta Neuromag [21]

Chronux [17)

OpenMEEG [16])

Neuroinformatics

Neuroshare [9)
Openelectrophy (7]
BrainSuite' [6]
EMSE' [5)
MClust [4]

RTXI [3]
cedspike' [2]
Relacs [2]
NeuroScope' (2]
Klusters' [2]
netstation’ [2]
Trellis-neuro [1]
nutmeg' [1]
erplab' [1])
FMAToolbox' [1]

datariver’ [1]
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EEGLAB compared to other
EEG software packages

EEG Data Analysis

. . . .
Environments EEGLAB Fieldtrip |Brainstorm | BVA* BESA |ERPLAB# |SPM§|Curry |ASA | EMSE
License (Open Source,

Commercial) Open Open Open Com| Com Open Open| Com |Com| Com
User base*** 8&&8&&E&EE&EEEE | &&&&& &&& &8&& | && & & & & &
Matlab based (Y/N) Y Y Y N N Y Y N N N
Time-freq. decomposition Y Y N Y N N Y N N N
Sourcg.lpcallzatlon e+ b bt + bt § R [P P
capabilities +

Plug-ins & scripting " "
(Yes/No/Basic) Y Y B Y B B B B ?N ?N
Statistics (Yes/No/B=basic) Y Y N N N B Y N N N
ICA (Y/N/B=basic) Y Y** N B B N N B ?N ?
Group level analysis 2

(Y/N/B=basic) Y B Y Y Y B ‘ Y Y Y
Cloud & GPU computing B B N N N N N N N N

*Brain Vision Analyzer (Brain Products Inc.);
**Uses an EEGLAB function for ICA
***As per a 2011 survey by (Hanke et al., 2011)

# Built as a plug-in to EEGLAB for ERP research
§ SPM and DCM (Dynamical Causal Modeling) for ERPs




EEGLAB
Plug-In
Extensions

S. Makeig et al. (2011)



Source Information Flow Toolbox

Pre-
processing

Model Fitting
and Validation

Connectivity

Frequency (Hz)

Statistics

Group

. Visualization
Analysis

Time (sec)



BCILAB - C. Kothe

) Review/edit approach ) BCILAB 0.9 M [=] | . a model = |D|ﬂ
A h i Data Source | Offline Analysis Online Analysis Settings Help
[ [ — Selected approach Ilastapproach ("Spectrally Weighted C... ZI
= %‘ I‘ b ‘3.‘2 New approach... Ctrl+N
= T Modify approach... Ctrl+Mm Calibration data source | lastdata ("imag.vhdr") ;I
[E] signal Processing Review/edt h CtrR
[=] SignalProcessing SMIEWIECK 20pC0aC. .. d Parameter Search
FilkerOrdering Save approach... CtrHS Loss/Performance Metric |Automatically chosen |
[=] Resampling Train new model... Ctrl+T o
SamplingRate Apply model to data Ctri+A Cross-validation folds I 5
- Parallel De
ChannelSelection . ) )
: Visualize model... Cr+v F— Spacing around test trials I 5
Rereferencing I :
Investigate results... Ctrl+I
) Figure 2: Common Spatial P 9 - |DI5|
Surfacelaplacian e e e Transform data by model... Ctrl+P o CS
FIRFilter rmance estimates
. > i3 " o~ N
Projection Dode | RRONDEL- |2 (0| ad .
. ation folds 10
IIRFilter I
Standardization 4 test trials |5—
SparseReconstruction
[=] EpochExtraction
TimeWindow B
EventTypes uter cluster
BaselineRemoval
WindowSelection Hode pool I (use current config)
SpectraTransform Spec-CSP Pattern 1 Spec-CSP Pattern 2 Spec-CSP Pattern 3
[= SpectralSelection 0.04 0.04 0.05
pectr : :space as | lastmodel
FrequencySpecification 0.02 0.02
[E] Feature Extraction : 0 0 ispace as I laststats
[=] FeatureExtraction p ;
PatternPairs g 2 40 u 40 0 20 40 Cancel OK
ParameterP
ParameterQ
SpectralPrior
Maxdterations bn, ' z0',0,'F1',1, 'Err’',2,
[=] PluginFunctions - - -
l 'n-SlackShrink',1,'1-51¢
FeatureAdaptor Spec-CSP Pattern b Spec-CSP Pattern 5 Spec-CSP Pattern 4 poly',1, 'rbf',2, ' sigmoic
ICA 0.05 0.04 0.04 : ’_'_ ] f ! . -
Annotate the Signal with a spatial pubsetHeurstic', 1, 'Fixed}
ICA) (flt_ica). 0.02 1 0.02 1 1,'12',2);
0 : 0 A 0 . ling, 'slack',1, 'margin',:Z
Help I 0 20 40 0 20 40 0 20 40
e g SPELIITOEN A S M T e Frve

r-.v
A e

3 3 3 3 Y Y ~




NFT: Neuroelectromagnetic Forward Head Modeling Toolbox

Segmentation Electrod
. ectrode
Mesh Generation . . :
Registration Template Warping
B Forvard Problem Solution = e s
File - —~
ﬁmm:‘w T | ww
Show Mesh| Load sensor locations

Nurrioer of Layers
/data/projects /zeynep/NFT _demo/jop3.elp

Number of Nodes

dipole

Ll

http://sccn.ucsd.edu/nft



List of data import extensions

Plug-in name & Version Short plug-in description $ Link #£ Contact & Comments &
MFFimport &’ 1.00 Import MFF files from the EGI company = Download & S. Chennu 3 User comments
ANTeepimport & 1.10 Import ANT .cnt data and trigger files | Download @& | M. van de Velde & 'User comments
BCI2000import & 0.36 Import BCI2000 data files Download C. Boulay 3 User comments
BDFimport 1.10 Import BDF data files Download @@ | A. Delorme 5 User comments
biopac 1.00 Import BIOPAC data files Download @@ | A. Delorme 5 User comments
ctfimport 1.04 Import CTF (MEG) data files Download & D. Weber 3 User comments
erpssimport 1.01 Import ERPSS data files Download A. Delorme 3 User comments
INSTEPascimport 1.00 Import INSTEP ASCII data files Download @@ | A. Delorme 5 User comments
neuroimaging4d 1.00 Import Neuroimaging4d data files Download @@ | C. Wienbruch & |User comments
Procominfinity 1.00 Import Procom Infinity data files Download @@ | A. Delorme 5 User comments
WearableSensing 1.09 Import Wearable Sensing files Download & S. Pillen 3 User comments
NihonKoden 0.10 Import Nihon Koden MO0O files (beta) | Download & = M. Miyakoshi&, | User comments
xdfimport 1.12 Import files in XDF format Download C. Kothe 5 User comments
bva-io 5 1.5.12 Import Brain Vision Analyser data files | Download & =~ A. Widmann=} | User comments
Fileio & Daily Import multiple data files formats Download [ | R. Oostenveld 3 |User comments
Biosig & 2.88 Import multiple data files formats Download & | A. Schloegls | User comments
Cogniscan & 1.1 Import Cogniscan data files Download & P. Sajda 3 User comments
NeurOne & 1.0.3.2 Import NeurOne data files Download & Support 3 User comments
loadhdf5 1.0 Load hdf5 files recorded with g.recorder Download @ |Simon L. Kappel & User comments




List of data processing extensions

Plug-in name & Version Short plug-in description $ Link $ Contact 4 Comments &
rERP & 0.4 Estimate overlapping ERPs using multiple regression Download &’ M. Burns § User comments
LIMO S 15 Linear MOdelling of EEG data Download & C. Pernet 3 User comments
corrmap @& 2.02 Cluster ICA components using correlation of scalp maps Download & S. Debener 3 User comments
bioelectromag & 1.01 Uses Bioelectromagnetism toolbox for ERP peak detection Download & D. Weber User comments
VisEd & 1.05 Add/Edit dataset events Download & J. Desjardins 5 User comments
loreta 1.10 Export and import data to and from LORETA software Download & A. Delorme 5 User comments
iirfilt 1.02 Non linear filtering using IIR filter Download M. Pozdin 3 User comments
std_envtopo 2.39 Plot STUDY ICA cluster contribution to ERP Download @& M. Miyakoshi 3 User comments
std_selectiCsByCluster & 0.10 Forward-project clustered ICs to channels (beta) Download & M. Miyakoshi 3 User comments
std_dipoleDensity & 0.23 Plot STUDY ICA cluster dipole density (beta) Download & M. Miyakoshi 55 User comments
std_ErpCalc 0.11 Test and visualize simple effects on ERP (beta) Download & M. Miyakoshi 3 User comments
pvaftopo 0.10 Plot topography of percent variance accounted for (beta) Download & M. Miyakoshi 5 User comments
trimOutlier & 0.16 Trim outlier channels and datapoints interactively (beta) Download & M. Miyakoshi 5 User comments
clean_rawdata 0.31 Cleans continuous data using Artifact Subspace Reconstruction Download i | Miyakoshi and Kothe & |User comments
ARfitStudio & 0.10 Cleans spiky artifacts using AFfit (beta) Download @ |Miyakoshi and Mullen & | User comments
Mutual_Info_Clustering 1.00 Group single dataset ICA components by Mutual Information Download &7 N. Bigdely & User comments
mass_univ & 130502 Mass Univariate ERP Toolbox Download & D. Groppe 3 User comments
REGICA & 1.00 ICA regression based EOG removal Download @& M. Klados 3 User comments
MARA & 1.1 Multiple Artifact Rejection Algorithm Download &7 I. Winkler S User comments

firfilt 1.6.1 Routines for designing linear filters Download & A. Widmann 5 User comments
PACT & 0.17 Computes phase-amplitude coupling for continuous data Download & M. Miyakoshi 5 User comments
fMRIb & 2.00 Remove fMRI artifacts from EEG Download & | J. Dien & & R. Niazy |User comments
SIFT & 1.33 Analysis and visualization of multivariate connectivity Download & T. Mullen 5 User comments
AAR 3§ 131130 ICA-based Automatic Artifact Removal Download @ | G. Gomez-Herrero 9 |User comments
Adjust & 1.1 Automatic Detector - Joint Use of Spatial and Temporal features Download & Adjust Support S User comments
Cleanline & 1.02 Removes sinusoidal artifacts (line noise) Download &’ T. Mullen 5 User comments
Fieldtrip-lite & Daily Adds source localization and statistics tools to EEGLAB Download [ R. Oostenveld & User comments
EYE-EEG & 0.41 Open source MATLAB tool for simultaneous eye tracking & EEG Download & 0. Dimigen 5 User comments

————— 1

- . -

-




EEGLAB standard processing pipeline

Single subject
Import binary data, events and channel location
Edit, Re-reference, Resample, High pass filter data
Reject artifacts in continuous data by visual inspection
Extract epochs from data & reject artifactual epochs
Visualize data measures
Perform ICA decomposition

— Perform source localization of components

— Analyze components contribution to ERP

— Analyze components contribution to spectrum

S o o

Multi-subjects

1. Build study and STUDY design
2. Pre-compute measures

3. Cluster components

4, Analyze clusters

Advanced analysis using scripting and EEGLAB command line functions



The EEGLAB Matlab software

® OO EEGLAB v13.x dev

File Edit Tools Plot Study Datasets Help

MATLAB R2012a J
File Edit Debug Parallel Desktop Window

I

NNNNNN

Al B9 & o =2

L7

/

ANNNN

Shortcuts 2] Howto Add 2] What's New

>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
fx >> eeglab

4\ Start

——No current dataset

- Create a new or load an existina
Use "File > Import data"
Or "File > Load existing dataset"
- If new.
"File > Import epoch info" (data
"File > Import event info" (continuous
"Edit > Dataset info" (add/edit
"File > Save dataset" (save dataset)
- Prune data: "Edit > Select data"
- Reject data: "Tools > Reject
- Epoch data: "Tools > Extract evochs"
- Remove baseline: "Tools > Remove

- Run ICA: "Tools > Run ICA"

—_—




1. Importing data

Import/load data

| NON | EEGLAB v13.x (dev)
JIW Edit Tools Plot Study Datasets Help
Import data > Using EEGLAB functions and plugins »
Import epoch info > ) )
Import event info > Using the FILE-IO interface
Export > Using the BIOSIG interface
Troubleshooting data formats...
Load existing dataset
Save current dataset(s) data
Save current dataset as  cont§
ilnuous
Clear dataset(s) Poait
dat )
Create study » B

Load existing study
Save current study
Save current study as
Clear study / Clear all

Memory and other options

History scripts >
Manage EEGLAB extensions »

Quit

data"

Bt

ct evochs"
Remove

CcA"

—_—

From ASCII/float file or Matlab array

From Netstation binary simple file
From EGI Net Station .MFF file
From Multiple seg. Netstation files
From Netstation Matlab files

From BCI2000 ASCII file
From Snapmaster .SMA file

From Neuroscan .CNT file
From Neuroscan .EEG file

From Biosemi BDF file (BIOSIG toolbox)
From EDF/EDF+ /GDF files (BIOSIG toolbox)
From Biosemi BDF and EDF files (BDF plugin)

From a NeurOne file (.ses)
From BIOPAC MATLAB files

From Brain Vis. Rec. .vhdr file
From Brain Vis. Anal. Matlab file

From ERPSS .RAW or .RDF file
From EGI .MFF file




1. Importing data

Import events

| NON | EEGLAB v13.x (dev)
m Edit Tools Plot Study Datasets Help
Import data >

Import epoch info |

> | ‘
Import event info > From Matlab array or ASCII file

Export > From data channel
o From Presentation .LOG file
Load existing dataset From E-Prime ASCII (text) file

Save current dataset(s) From Neuroscan .ev2 file
Save current dataset as ) r

Clear dataset(s)

Create study > |5

Load existing study
Save current study
Save current study as
Clear study / Clear all

Memory and other options r

History scripts >
Manage EEGLAB extensions »

Quit



1. Importing data

Data info

| NON | EEGLAB v13.x (dev)
File Edit Tools Plot Study Datasets Help
—#1: Continuous EEG Data

Filename: ...sample data/eeglab data.set

Channels per frame 82

Frames per epoch 30504

Epochs 1

Events 154

Sampling rate (Hz) 128

Epoch start (sec) 0.000

Epoch end (sec) 238.305

Reference unknown

Channel locations No

ICA weights No

Dataset size (Mb) 4.3

Scrolling data

‘@00 Scroll channel activities -- eegplot()

Figure

Settings Help

Display
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1. Importing

Import channel location

L JON

File m Tools Plot

4

E
E

{5 T -

-

EEGLAB v13.x (dev)

Datasets Help

Dataset info

Event fields

Event values
About this dataset
Channel locations

Select data
Select data using events
Select epochs or events

Copy current dataset
Append datasets
Delete dataset(s) from memory

Edit events & mark bad channels

channel location

o« H21e H18s H224 HZ20,
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2. Edit, Re-reference, Resample, High pass filter data

Edit/select data Preprocessing data

EEGLAB v13.x (dev) ® O EEGLAB v13.x (dev)
Tools Plot Study Datasets Help File Edit Plot Study Datasets Help
) Datasetinfo _#1:c°1l Change sampling rate 1
Event fields Filter the data >
Event values rilenad Re-reference
About this dataset channe] Interpolate electrodes
Channel locations Reject continuous data by eye
Frames

Select data Epochs Extract epochs
Select data using events R Remove baseline

Select epochs or events Sampling
Epoch st Run ICA

R R N T S

Copy current dataset Epoch en Remove components
Append datasets Refereng . —_—

Automatic channel rejection
Delete dataset(s) from memory Channel . < ..

rea wel Automatic continuous rejection
g

Edit events & mark bad channels Dataset Automatic S;’]D:h rejection

R pochs >

sing ICA >

Remove artifacts using ACSTP

Clean continuous data using ASR
Locate dipoles using DIPFIT 2.x »
LIMO EEG 2.0 >



3. Reject artifacts in continuous data by visual inspection

File Edit Plot Study Datasets Help

—#1: COI\‘J

Filename
Channels
Frames p
Epochs

Events

Sampling
Epoch st
Epoch en
Referenc
Channel
ICA weig

Dataset

~—

EEGLAB v13.x (dev)

Reject portions of continuous data

Change sampling rate

Filter the data

Re-reference

Interpolate electrodes

Reject continuous data by eye

Extract epochs
Remove baseline

Run ICA
Remove components

Automatic channel rejection
Automatic continuous rejection
Automatic epoch rejection
Reject data epochs

Reject data using ICA

Remove artifacts using ACSTP
Clean continuous data using ASR
Locate dipoles using DIPFIT 2.x
LIMO EEG 2.0

>

‘@00 Scroll channel activities —— eegplot()
Figure Display Settings Help
Stack
Norm
i
B
A
& A v
e s s

it

218
ey

23200002
2
o%

3
5

Scale

AP S TN %
=0

Chan. Time

CANCEL|  Eventtypes| [=<| [ (535 | [51 551 fp1 san.76s8 57501 | 97 %‘
)

Value

Bad portion of data

540

Bad channel



4. Extract epochs from data & reject artifactual epochs

Preprocessing data

EEGLAB v13.x (dev)

File Edit Imﬂ Plot Study Datasets Help

—#1: Co

Filename

Epochs

Events

Referenc
Channel
ICA weig

Dataset

Change sampling rate E

Filter the data >
Re-reference

Interpolate electrodes

Reject continuous data by eye

| NON | Extract data epochs - pop_epoch()
Time-locking event type(s) ([]=all) square e
Epoch limits [start, end] in seconds -12

Name for the new dataset

Extract epochs
Remove baseline

Run ICA
Remove components

Automatic channel rejection
Automatic continuous rejection
Automatic epoch rejection

Reject data epochs >
Reject data using ICA >

Remove artifacts using ACSTP

Clean continuous data using ASR

v

Locate dipoles using DIPFIT 2.x
LIMO EEG 2.0 >

CUONONAWN=0OONONLWN=

e

1) b ok kit

Continuous EEG Data epochs

Out-of-bounds EEG limits if any [min max]

Help

Cancel Ok




4. Extract epochs from data & reject artifactual epochs

File EditPIot Study Datasets Help

—#1:Cont

Filename
Channels
Frames p
Epochs

Events

Sampling
Epoch st
Epoch en
Referenc
Channel
ICA weig

Dataset

~—

EEGLAB v13.x (dev)

Change sampling rate

Filter the data

Re-reference

Interpolate electrodes

Reject continuous data by eye

Extract epochs
Remove baseline

Run ICA
Remove components

Automatic channel rejection
Automatic continuous rejection
Automatic epoch rejection

Reject data using ICA

Remove artifacts using ACSTP

Clean continuous data using ASR

Locate dipoles using DIPFIT 2.x
LIMO EEG 2.0

>

>

>

>

L

Reject data epochs > Reject data (all methods)

Reject by inspection

Reject extreme values

Reject by linear trend/variance
Reject by probability

Reject by kurtosis

Reject by spectra

Export marks to ICA reject

Reject marked epochs

Different color = different rejection methods

["v’ Scroll activity — eegplot()
Figure Display Setftings Help

Oz PO )
VN

%
DL Rl B i
¢
?
i3
5
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CANCEL |

0
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0
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Ch Time Value
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| NON J E
File Edit Toolsi

—#1: Continuous EE

Filename: ...samp.
Channels per fram
Frames per epoch
Epochs

Events

Sampling rate (Hz
Epoch start (sec)
Epoch end (sec)
Reference

Channel locations

ICA weights

Dataset size (Mb)

e

EGLAB v13.x (dev)

7m Study Datasets Help

Channel locations

Channel data (scroll)
Channel spectra and maps
Channel properties
Channel ERP image
Channel ERPs

ERP map series
Sum/Compare ERPs

Component activations (scroll)
Component spectra and maps
Component maps
Component properties
Component ERP image
Component ERPs
Sum/Compare comp. ERPs

Data statistics

Time-frequency transforms

With scalp maps
In scalp/rect. array

—

File Edit View

Insert

Plot ERP

Figure 2: plottopo()

» Dogde K

Tools Desktop Window Help
LM EM- A NE =mm
[ JON ] Figure 3
EEG Data epoc File Edit View Insert Tools Desktop Window Help

sz.{am » NEdde M RAOWB9LRL- 2 0E a0
30+
20 +
|
910- ‘[J )
z A ‘mﬂﬂmllf | )“.[U%\ nqﬁpﬂmﬁﬁl‘l
R i AL R
I3 !
& -10f
POz

_20-

_30-

-1000 -5010 0 5010 1UIIJU 15llJD

Time (ms)

Visualize data measures




Plot ERP
map series

EEGLAB v13.x (dev)
File Edit ToolsmStudy Datasets Help

—#1: EEG Data epoc

Filename: .../eeq.
Channels per fram
Frames per epoch
Epochs

Events

Sampling rate (Hz
Epoch start (sec)
Epoch end (sec)
Reference

Channel locations
ICA weights

Dataset size (Mb)

ﬁ Sum/Compare comp. ERPs

Channel locations

Channel data (scroll)

Channel spectra and maps

Channel properties
Channel ERP image
Channel ERPs

Sum/Compare ERPs

Component activations (scroll)
Component spectra and maps

Component maps
Component properties
Component ERP image
Component ERPs

Data statistics

Time-frequency transforms

»

ERP map series >

-

5. Visualize data measures

In2-D
In 3-D

% Figure No. 2

File Edit View Inset Tools Window Help

[DE"& YA /|28

0ms

300 ms

"ee114 continuous" epochs ERP

20
10

-10 !
-20

(v Figure No. 2

=

File Edit View Insert Tools Window Help
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5. Visualize data measures

Figure No. 2: spectopo()

File Edit View Insert Tools Window Help

Plot data EEFEIY YA e
spectrum and 6.0 10.0 22.0 Hz
maps

[ ] @ EEGLAB v13.x (dev)
File Edit Toolsm Study Datasets Help
— #1: EEG Data epoJ Channel locations >
Channel data (scroll)
40
Channels per fram  Channel properties
Frames per epoch | Channel ERP image a
G Channel ERPs > s
Events ERP map series > « 30
Sampling rate (Hz)  Sum/Compare ERPs o
Epoch start (sec) 3
Epoch end (sec) Component activations (scroll) LLo
Reference Component spectra and maps - 20
Channel locations Component maps > b
ICA weights Component properties o
Dataset size (M), Component ERP image
Component ERPs > 10 | | | | |

Sum/Compare comp. ERPs
- 5 10 15 20 25
Data statistics >

Frequency (Hz)

Time-frequency transforms >



5. Visualize data measures

Plot channel ERPimage

[ NON ) EEGLAB v13.x (dev)
File Edit Tools m Study Datasets Help
——#1: EEG Data epox Channel locations >

Channel data (scroll)

Filename: .../eeai  Channel spectra and maps

Channels per fram Channel prOpertieS

Sl Channel ERPimage
Egocas Channel ERPs >
ENSEES ERP map series >

Sampling rate (Hzl  qum/Compare ERPs
Epoch start (sec)

Epoch end (sec) Component activations (scroll)

Reference Component spectra and maps

Channel locations Component maps >

ICA weights Component properties

Dataset size (M) Component ERP image
Component ERPs >

ﬁ Sum/Compare comp. ERPs
Data statistics >

Time-frequency transforms >
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EEGLAB standard processing pipeline

6. Perform ICA decomposition
— Perform source localization of components
- Analyze components contribution to ERP
— Analyze components contribution to spectrum



6. Perform ICA decomposition

| NON ) EEGLAB v13.x (dev)
File Edit Plot Study Datasets Help

#1: EEG C.hange sampling rate | 3
Filter the data >
Re-reference
Filename
Interpolate electrodes
Channels| . .
Reject continuous data by eye
Frames p
ERoSE Extract epochs
AT Remove baseline
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Localizing components
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Component contribution to the ERP
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Component contribution
to the EEG spectrum
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Component time-frequency
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EEGLAB standard processing pipeline

Single subject

Multi-subjects

1. Build study and STUDY design
2. Pre-compute measures

3. Cluster components

4, Analyze clusters
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EEGLAB standard processing pipeline

Advanced analysis using scripting and EEGLAB command line functions
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3 levels of functions

Administrative functions: handle EEG and ALLEEG

structures
eeglab(), eeg_checkset(), pop_delset(), ...

Pop functions: interactive functions using EEG structure
pop_erpimage(), pop_topoplot(), pop_envtopo(), ...

Signal processing functions: perform signal processing
erpimage(), topoplot(), envtopo(), ...



Command line tools

(“eegh” Menus write both dataset and global history)

« Automated processing on groups of subjects (possibly
on several processors).

* Richer options for plotting and processing functions
(time-frequency decompositions, ...)

» Custom processing...



EEGLAB Scripting

[ALLEEG EEG CURRENTSET ALLCOM] = eeglab;

pop_editoptions( 'option storedisk', 1);

subjects = {'S01' 'S02' 'S03' 'sS04' 'sS05' 's06' 'sS07' 's08' 'sS09' 'sS10' 'sSll' 's12'};
filepath = '/Users/arno/temp/STUDY'; % XXXXX Change path here XXXXX

if ~exist(filepath), error('You need to change the path to the STUDY'); end;

commands = {}; % initialize STUDY dataset list

% Loop through all of the subjects in the study to create the dataset
for loopnum = 1l:length(subjects) %for each subject

IgnoreFile = fullfile(filepath, subjects{loopnum}, 'Ignore.set');
MemorizeFile = fullfile(filepath, subjects{loopnum}, 'Memorize.set');
ProbeFile = fullfile(filepath, subjects{loopnum}, 'Probe.set');
commands = {commands{:}
{'index' 3*loopnum-2 'load' IgnoreFile 'subject' subjects{loopnum} 'condition' 'Ignore'}
{'index' 3*loopnum-1 'load' MemorizeFile 'subject' subjects{loopnum} 'condition' 'Memorize'}
{'index' 3*loopnum 'load' ProbeFile 'subject' subjects{loopnum} 'condition' 'Probe'}};
end;
% Uncomment the line below to select ICA components with less than 15% residual variance
% commands = {commands{:} {'dipselect',K 0.15}};

[STUDY, ALLEEG] = std_editset(STUDY, ALLEEG, 'name', 'Sternberg', 'commands', commands,'updatedat',6 'on');

% Update workspace variables and redraw EEGLAB

CURRENTSTUDY = 1; EEG = ALLEEG; CURRENTSET = [1l:length (EEG)];
[STUDY, ALLEEG] = std_checkset (STUDY, ALLEEG)

eeglab redraw

[STUDY ALLEEG] = std _precomp (STUDY, ALLEEG, {},'rmicacomps','on',6'interp', 'on', 'recompute',6'on',6 'erp',6 'on');
STUDY = pop_erpparams (STUDY, 'topotime',[200 300] );
[STUDY erpdata] = std erpplot (STUDY,ALLEEG, 'channels', {'LEYE' 'REYE' 'OZ' 'O2' 'FP1l' 'FPZ' 'FP2' 'AF7'

'AF3' 'AFZ' 'AF4' 'AF8' 'F9' 'F7' 'F5' 'F3' 'F1' 'FZ' 'F2' 'F4' 'F6' 'F8' 'F10' 'FT9'

'FT7' 'FC5' 'FC3' 'FC1l' 'FCZ' 'FC2' 'FC4' 'FC6' 'FT8' 'FT10' 'T7' 'C5' 'C3' 'Cl' 'CzZ'

'C2' 'C4' 'Cé6' 'T8' 'TP9' 'TP7' 'CP5' 'CP3' 'CP1l' 'CPZ' 'CP2' 'CP4' 'CP6' 'TP8' 'TP10'

'P7' 'P5' 'P3' 'P1' 'PZ' 'P2' 'P4' 'P6' 'P8' 'PO9' 'PO7' 'PO3' 'POZ' 'PO4' 'PO8' 'PO10' 'O1'});

dlmwrite ('erpfile.txt',6 squeeze (erpdata{l}), 'delimiter', '\t', 'precision',6 2);
dlmwrite ('erpfile.txt', squeeze (erpdata{2}),'-append', 'roffset', 1, 'delimiter',6 '\t', 'precision',6 2);
dlmwrite ('erpfile.txt', squeeze (erpdata{2}),'-append', 'roffset', 1, 'delimiter',6 '\t', 'precision',6 2);



Pros/Cons of Matlab based open source

* Pros
— Easy to program, highly modular and extendable

— Not dependent on any platform (64-bit) and highly
optimized

— Large community of users (latest development in signal
processing research)

— Powerful scripting capabilities

 Cons
— Matlab required for which you have to pay
— Large memory requirements

— Matlab bugs, possible version differences, cross-
platform compatibility problems

— Poor graphical interface
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https://sites.google.com/ucsd.edu/eeglab-2018/eeglab-home

- (Google EEGLAB 2018)

DAY 2- FRIDAY NOVEMBER 9TH, 2018

8:00 AM - Registration open -- Coffee/tea & bagels available
8:30 AM -- Mining Event-Related Brain Dynamics I - Scott Makeig
9:45 AM -- EEGLAB Overview - Arnaud Delorme

10:15 AM -- Coffee Break
10:30 AM -- ICA Decomposition Theory & Evaluation - Scott Makeig
11:30 PM -- Time-frequency Measures - John Iversen

12:15 PM -- Get-together Group Lunch On-site

1:25 PM -- Schedule Overview: Workshop Track System - Arnaud Delorme

1:30 PM - Spotlight: High-resolution Forward Head Modeling and Source Localization - Zeynep Akalin Acar

1:45 PM - Spotlight: Imaging natural cognition via Mobile Brain/Body Imaging (MoBI) - Scott Makeig et al.

2:00 - 5:30 PM -- Concurrent Basic & Advanced Track Sessions (including coffee break)

TRACK A

(Auditorium)

Basic Track: Processing Data

using EEGLAB

Julie Onton et al.

TRACK B

(Vizlab)

High-resolution Forward
Head Modeling and Source
Localization

Zeynep Akalin Acar

(repeated on Sunday)

2:00 PM - A1: Data import,
preprocessing and plotting

- Julie Onton

2:45 PM - A2: Performing
ICA decomposition &
visualization - Julie Onton

3:30 PM -- Coffee
break

2:00 PM -- B1: Building head
models using the
Neuroelectromagnetic
(NEM) Forward Problem
Toolbox (NFT)

2:45 PM -- B2: Forward and
inverse problem solutions

TRACK C

(INC open space)

Imaging natural cognition via
Mobile Brain/Body Imaging
(MoBl)

Scott Makeig et al.

(not repeated)

2:00 PM -- C1: Mobile
Brain/Body Imaging
motivation, theory, and
practice - Scott Makeig

2:45 PM -- C2: Multimodal
data collection and
analysis: Lab Streaming

TRACKD

(Tearoom)

New EEG tools and measures

John Iversen et al.

(repeated on Sunday)

2:00 PM -- D1: Automated
source classification and
online ICA - Luca Pion-
Tonachini

2:30 PM -- D2: EEG
Nonstationarity and
AMICA - Shawn Hsu


https://sites.google.com/ucsd.edu/eeglab-2018/eeglab-home

