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LAB v12.0.0.0b

Plot Study Datasets

Help

——No current dataset

Pre-processing

- Create a new or leoad an existing

Use "File > Import data"”
Or "File > Load existing dataset”™
- If new,
"File > Import epoch info™ (data
"File > Import event info"™ (continuous
"Edit > Dataset info" (add/edit
"File > Save dataset™ (save dataset)
- Prune data: "Edit > Select data"
- Reject data: "Teoels > Reiject
- Epoch data: "Tools > Extract epochs”™
- Remove baseline: "Tcols > Remove
- Run ICA: "Tools > Run ICA"
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Starting

EEGLAB/SIFT

SIFT Requirements:

e Matlab 2008b or later

* Signal Processing Toolbox
* Statistics Toolbox
e EEGLAB
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EEGLAB/SIFT

iig Edit Debug Parallel Desktop Window Help

|. Clear the Matlab Path
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New - Izﬂ F] @ Current Folder:
Open... ¥0
: 2| STARTTCE 2] SIFT Star
Close Command Window &®W Ld—l 4 2
er

Import Data... PR K &
Save Workspace As... #®s |' —— ——

" SetPath.. | hesphieeal
Preferences... 8, i::: ig:g::

rint... P
Print . x File Folder
Print Selection... &P File Folder
1 ...st/est_fitMVARKalman.m i?:e §°:gef
2 /Users/...r/mvar_glADMM.m F:|: Fgld::
3 /Users/...minimal/mvaar.m File Folder
4 |Users/.../mvar_dalSCSA.m File Folder
File Folder

Exit MATLAB #Q File Folder
» O lost+found File Folder
» L] User Guides And Information File Folder
» L] sw File Folder
» Ltmp File Folder
» ] usr File Folder
» ] Developer File Folder
» | var File Folder
» | bin File Folder
» o Library File Folder
» L sbin File Folder
» | etc File Folder
b dev File Folder
- Annliratinne File Fnalder
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EEGLAB/SIFT

Iig Edit Debug Parallel Desktop Window Help

New > I:ﬂ #] @ Current Folder:

Open... ¥0
Close Command Window #®W L
Import Data...

Save Workspace As... #®S {
Preferences... 38,
Page Setup... o ®RP
Print... ¥pP
Print Selection... 8P

1 ...st/est_fitMVARKalman.m
2 /Users/...r/mvar_glADMM.m
3 /Users/...minimal/mvaar.m
4 /Users/.../mvar_dalSCSA.m

Exit MATLAB #®Q
-

= lost+found
.| User Guides And Information
L SW
L tmp
L usr
| Developer
L var
. bin
2 Library
. sbin
L etc
dev
Annliratinne

F vwvvyyvyvyvyvy Yy TYyTTrYyYTT Yy
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2] STARTTCE 2] SIFT 2] Star

hd p . #v

Type

File Folder
File Folder
File Folder
File Folder
File Folder
File Folder
File Folder
File Folder
File Folder
File Folder
File Folder
File Folder
File Folder
File Folder
File Folder
File Folder
File Folder
File Folder
File Folder
File Folder
File Folder
File Folder
File Folder
File Folder
File Folder
File Folder
File Fnlder

|. Clear the Matlab Path

All changes take effect immediately.
MATLAB search path:
( AddFfolder.. ) oo

( Add with Subfolders... ) (] /Users /timmullen/Documents /WORK/Conference:*
(L /Users /timmullen/Documents /WORK/Conferences
@& /Users/timmullen

(L] /Users/timmullen/Documents /WORK/Conference:
(] /Users/timmullen/Documents /WORK/Conferences
(] /Users /timmullen/Documents /WORK/Conferences

(] /Users/timmullen/Documents /WORK/Conference:
(] /Users/timmullen/Documents /WORK/Conferences

Move to Top > [ /Users /timmullen/Documents /WORK/Conferences
(] /Users/timmullen/Documents /WORK/Conference:
Move Up > (Ul /Users /timmullen/Documents /WORK/Conference:

[ /Users/timmullen/Documents /WORK/Conference:
( Move Down ) (] /Users/timmullen/Documents /WORK/Conferences
(1 /Users /timmullen/Documents /WORK/Conference:
(L] /Users/timmullen/Documents /WORK/Conference:
(] /Users/timmullen/Documents /WORK/Conferences
(] /Users/timmullen/Documents /WORK/Conferences
[ fUsers /timmullen/Documents /WORK/Conference:
(] /Users/timmullen/Documents /WORK/Conferences
(] /Users/timmullen/Documents /WORK/Conference:
(Gl /Users /timmullen/Documents /WORK/Conference: 4

C Remove ) wnmmm len/Documents/WORK/Conference™ |

2 ( Save ) ( Close ) ( Revert
e —

( Move to Bottom )
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EEGLAB/SIFT

'ig Edit Debug Parallel Desktop Window Help

New - l[ﬂ F] @ Current Folder:
Open... ®0
s 2| STARTTCE 2] SIFT Sta
Close Command Window #W L"‘J 4 4 |
er ‘

Import Data... -0l @ B

Save Workspace As... #®S 'f —— ——

Set Path. . ! File Folder
File Folder

Preferences... 8, File Folder

int...

Print . %P File Folder

Print Selection... &P File Folder

1 ...st/est_fitMVARKalman.m g!:e §°::e'

2 /Users/...r/mvar_glADMM.m F:|: Fgl d::

3 /Users/...minimal/mvaar.m File Folder

4 [Users/.../mvar_dalSCSA.m File Folder
File Folder

Exit MATLAB #Q File Folder

™ = lost+found File Folder

» [ User Guides And Information File Folder

> L sw File Folder

» L tmp File Folder

» L] usr File Folder

» ] Developer File Folder

» var File Folder

» | bin File Folder

» o Library File Folder

» |_sbin File Folder

» | ]etc File Folder .

3 dev File Folder

. Annliratinne File Fnlder
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|. Clear the Matlab Path

All changes take effect immediately.
MATLAB search path:
( AddFfolder.. ) B

( Add with Subfolders... ) (] /Users /timmullen/Documents /WORK/Conference:*
(] /Users /timmullen/Documents /WORK/Conference:
&Y /Users/timmullen

(L] /Users/timmullen/Documents /WORK/Conference:
(] /Users/timmullen/Documents /WORK/Conferences

(] /Users/timmullen/Documents /WORK/Conferences
[ /Users /timmullen/Documents /WORK/Conference:

(] /Users/timmullen/Documents /WORK/Conferences '
Move to TOp " Q,Usefs “" - ""“' —_—
G fusers @9 00 (7 Set Path
Move Up v Gl /use

t Move Down ) g ;3:: Do you wish to restore the default path?
If you do so, you will lose your current path settings.

(__MovetoBottom ) o

(] /Users
[ /use
L /use

L /use
( No )|C Yes )

 fUse

(] /Users
QIUseulﬂmm Doc s IWORK/Con
g i 0 : : . nces ¥
( Remove ) == immulien/Documents /WORK /Lo Ll__L
2 ( Save ) (( Close ) ( Revert
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EEGLAB/SIFT

enoe 0000000 SetPah 000000000000

All changes take effect immediately.
MATLAB search path:
( Add Folder... )

‘
(' Add with Subfolders... ) L /Users /timmullen/Documents /WORK/Conference:
L /Users/timmullen/Documents /WORK/Conference:
4 /Users /timmullen
L /Users/timmullen/Documents /WORK/Conference:
L /Users /timmullen/Documents /WORK/Conference:
1 /Users /timmullen/Documents /WORK/Conference:

1 /Users /timmullen/Documents /WORK/Conference:
L /Users /timmullen/Documents /WORK/Conference:

Move to Top ) L /Users /timmullen/Documents /WORK/Conference:
] /Users/timmullen/Documents /WORK/Conference:
Move Up _ (] /Users/timmullen/Documents /WORK/Conference:

L /Users /timmullen/Documents /WORK/Conference:
( Move Down ) {1l /Users /timmullen/Documents /WORK/Conference:
) L /Users /timmullen/Documents /WORK/Conference:
L /Users /timmullen/Documents /WORK/Conference:
L /Users /timmullen/Documents /WORK/Conference:
(1 /Users /timmullen/Documents /WORK/Conference:
(1l /Users /timmullen/Documents /WORK/Conference:
(1 /Users /timmullen/Documents /WORK/Conference:
(] /Users /timmullen/Documents /WORK/Conference:
[ /UsersItimmulIenlDocumentleORK/Conferen::i:

( Remove ) %ﬂmml_l_enLQo_cu.m_en_tsLW_QRKLCon.f_egg\ € 'v

@ ( Save ) ( Close ) _ Revert

(' Move to Bottom
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2. Add EEGLAB+SIFT to path

<USB Key>/SIFT/eeglabl2 0 0 Ob/
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EEGLAB/SIFT

All changes take effect immediately.

MATLAB search path:
Add Folder...

C )

2. Add EEGLAB+SIFT to path

<USB Key>/SIFT/eeglabl2 0 0 Ob/

M /Users/timmullen/Documents /WORKI oo oo

(" Add with Subfolders... ) |G /Users/timmullen/Documents/WORK & & £ 1 () Select a Directory
] /Users /timmullen/Documents /WOF
A /Users /timmullen oo | = 7 ~
{1 /Users/timmullen/Documents /WOR [ s ] [“ — mq (ﬁ eeglabl2_0_0_0b H Q
1 /Users/timmullen/Documents /WOF
{1l /Users /timmullen/Documents /WORK ¥ DEVICES ﬁ SIFT > ﬁ Data > ~ 1ST_README.txt
£l /Users /timmullen/Documents /WOR B eeqglabl2 0 0 Ob » ml Contents.m
L /Users/timmullen/Documents /WOR H TimMull... g —— lab
Move to Top {1 /Users/timmullen/Documents /WOR g iDisk m| eegiab.m
@il /Users /timmullen/Documents /WOF = L ~ eeglablicense.txt
Move Up {1l /Users/timmullen/Documents /WOR L ﬁ external .
(i /Users /timmullen/Documents /WOR :
C Move Down ) @@ /Users/timmullen/Documents/WORK T SHARED (] functions ~
(i /Users /timmullen/Documents /WOF I “Alissa™ - lugins >
( Move to Bottom ) 1 /Users /timmullen/Documents /WOF g piug le d .
Gl /Users /timmullen/Documents /WOR & Anna Me... sample_data
& /Users/timmullen/Documents /WOF I MAC-0012 (] sample_locs m
(] /Users /timmullen/Documents /WOF
& /Users /timmullen/Documents /WORK v pL ACES
(] /Users /timmullen/Documents /WOR =
(il /Users /timmullen/Documents /WOR -« |deas.rtf
( Remove ) %ti_r_n_m_u_l_l_e_nLQo_cy_m_e_o_t_sj_ ORK (] Processing
@ ConD) Camd) | W
Save Close _ Revert -
— (] Toolboxes a ! :
ﬁ Confere... v f———m—m——————— — — — — — — — — — — —————3) < »

—
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EEGLAB/SIFT

3. Start EEGLAB

X a2 = [ Command Window

fx >> eeglab
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EEGLAB/SIFT

4. Check EEGLAB memory options

Study Datasets Help

Import data >
Import epoch info 3
Import event info I
Export 3
Load existing dataset hea

Save current dataset(s)
Save current dataset as

Clear dataset(s)

Create study 3

Load existing study
Save current study
Save current study as
Clear study

Memory and other options
H

istory scripts >

Quit
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Starting

EEGLAB/SIFT

gat e e 4. Check EEGLAB memory options

Import data >

Import epoch info - -8 00O Memory options - pop_editoptions()

Import event info 3

Export >

Load existing dataset fpd STUDY options (set these checkboxes if you intend to work with studies)

Save current dataset(s) .

Save current dataset as If set, keep at most one dataset in memory. This allows processing hundreds of datasets within studies.
Clear dataset(s) If set, save not one but two files for each dataset (header and data). This allows faster data loading in studies.
Create study & If set, write ICA activations to disk. This speeds up loading ICA components when dealing with studies.
Load existing study Memory options

Save current studh

Save current Szud: as If set, use single precision under Matlab 7.x. This saves RAM but can lead to rare numerical imprecisions.
Clear study If set, use memory mapped array under Matlab 7.x. This may slow down some computation.

Memory and other options If set, use the EEGLAB EEG object instead of the standard EEG structure (beta).

History scripts 3 ICA options

Quit If set, precompute ICA activations. This requires more RAM but allows faster plotting of component activations.
If set, scale ICA component activities to RMS (Root Mean Square) in microvolt (recommended).

Folder options

If set, when browsing to open a new dataset assume the folder/directory of previous dataset.

Toolbox options

If set, do not use Matlab additional toolboxes functions even if they are present.

EEGLAB chat option

If set, enable EEGLAB chat - currently UCSD only - restart EEGLAB after changing that option.

U 0 0 @ @aa 000 oad %

Option file: ~/eeg_options.m

(_Hep ) ( Cancel J Ok )
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2 Loading Data

<USB Key>/SIFT/Data/

Monday, June 17, 2013

™
File

Edit Tools Plot Study Datasets

Help

Import data
Import epoch info
Import event info
Export

Load existing dataset
Save current dataset(s)
Save current dataset as
Clear dataset(s)

Create study

Load existing study
Save current study
Save current study as
Clear study

Memory and other options
History scripts
Quit

>

vyvvvyy

?(:lstina

g dataset™

fdata
fcontinuous




2  Loading Data

<USB Key>/SIFT/Data/

. Jd ddlaseus)

[ G@ Data |

. Date Modified
| RespCorrect.set Wednesday, June 13, 2012 7:23 AM

Wednesday, June 13, 2012 7:23 AM

. RespWrong.set

File Format: | (*.SET*, *.set) 4]

( Cancel ) | € Open )

Monday, June 17, 2013

File Edit Tools Plot Study Datasets Help
Import data I
Import epoch info k-
Import event info > Listing
Export I
Load existing dataset
Save current dataset(s) b (data
Save current dataset as L ETmEeTie
Clear dataset(s) id/edit

ve dataset)

Create study » K daca-

Load existing study

act epochs”
Save current study - N
Save current study as s

Clear study

Memory and other options
History scripts B
Quit




Preprocessing: Select Data Range

ABvl1Z2.0.0.0D

Tools Plot Study

Datasets Help

Dataset info
Event fields

Event values
About this dataset
Channel locations

Select data
Select data using events
Select epochs or events

Copy current dataset
Append datasets
Delete dataset(s)

Edit events & mark bad channels
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Preprocessing: Select Data Range

Plot Study Datasets Help

_J Dataset info Select data in: Input desired range on->remove these
Event fields Time range [min max] (s) -1 1.25| (]
Event values - _ -
About this dataset olink range (eoc: [1110) —
Channel locations Epoch range (ex: 3:2:10) =
e 0 L=
! Select data using events
| Select epochs or events | Scroll dataset |
Copy current dataset
Append datasets Help ( Cancel || Ok |
¢ Delete dataset(s)
v
Edit events & mark bad channels
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Preprocessing: Select Data Range

Help

Dataset info

Event fields

Event values
About this dataset
Channel locations

Select data
Select data using events
Select epochs or events

Copy current dataset
Append datasets
Delete dataset(s)

Edit events & mark bad channels

Monday, June 17, 2013

Select data in: Input desired range on->remove these
Time range [min max] (s) -11.2§ a
Point range (ex: [1 10]) a2
Epoch range (ex: 3:2:10) a8
Channel range = :J
( Scroll dataset )
Help | Cancel ||| Ok |

What do you want to do with the new dataset?

Name it: RespWrong [Edit description)
__ Saveit as file: | Browse |

What do you want to do with the old dataset (not modified since last saved)?
e Overwrite it in memory (set=yes; unset=create a new dataset)

[ Cancel Y Ok ]
S —————————————————————————————————




Preprocessing: Select Components

File Help

Change sampling rate

Filter the data I
Re-reference

Interpolate electrodes

Reject continuous data by eye

Extract epochs
Remove baseline

Run ICA
Remove components

Automatic channel rejection
Automatic epoch rejection
Reject data epochs

Reject data using ICA

v

v

CleanlLine
SIFT I+

Locate dipoles using DIPFIT2.x »
Peak detection using EEG toolbox

FMRIB Tools
Locate dipoles using LORETA I

v
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Preprocessing: Select Components

File Edit Plot Study Datasets
#1: Rt Change sampling rate Component(s) to remove from data:
Filter the data Component(s) to retain (overwrites "Component(s) to remove") B1113192023:
Re-reference
T nterpolate electrodes
th:l Reject continuous data by eye (_Hep ) [ Cancel JI[ Ok )
EEOCUN Extract epochs
Fuens Remove baseline
Sampli
= Run ICA 811,13,19, 20, 23, 38, 39
USRS Remove components

channe: | Automatic channel rejection
1ca weiqa  Automatic epoch rejection
parasez | Reject data epochs

Reject data using ICA

VY
CleanlLine

SIFT >

v

v

Locate dipoles using DIPFIT2.x  »
Peak detection using EEG toolbox

FMRIB Tools
Locate dipoles using LORETA I

v
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Preprocessing: Select Components

File Edit
#1:R

Plot Study Datasets

Change sampling rate

Filter the data

Re-reference

Interpolate electrodes

Reject continuous data by eye

Extract epochs
Remove baseline

Run ICA
Remove components

Automatic channel rejection
Automatic epoch rejection
Reject data epochs

Reject data using ICA

CleanlLine
SIFT

Locate dipoles using DIPFIT 2.x
Peak detection using EEG toolbox

FMRIB Tools
Locate dipoles using LORETA

vy

>

v
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Component(s) to remove from data:
Component(s) to retain (overwrites "Component(s) to remove") B1113192023:

([ Help | | Cancel Jf[ Ok |

8,11,13, 19, 20, 23, 38, 39

enos  Confimaton 0000000000000

Please confirm, Are you sure you want to remove these components?

([ Cocel | "~ Piot EAPs Piot single trialg [ Accept |




Preprocessing: Select Components

Channel
ICA weld
Dataset

~—

Change sampling rate

Filter the data

Re-reference

Interpolate electrodes

Reject continuous data by eye

Extract epochs
Remove baseline

Run ICA
Remove components

Automatic channel rejection
Automatic epoch rejection
Reject data epochs

Reject data using ICA

CleanlLine
SIFT

Locate dipoles using DIPFIT 2.x
Peak detection using EEG toolbox

FMRIB Tools
Locate dipoles using LORETA

>

v

>

v
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Component(s) to remove from data:

(__Help |

Please confirm, Are you sure you want to remove these components?

Component(s) to retain (overwrites "Component(s) to remove")

81113192023

[ Cancel J|| Ok |

8,11,13, 19, 20, 23, 38, 39

eno  Confwemation 0000000000000

What do you want to do with the new dataset?

Name it: | RespWrong

( Eit description |

__ Saveit as file:

__ Saveit as file:

Some changes have not been saved. What do you want to do with the old dataset?

™ | Overwrite it in memory (set=yes; unset=create a new dataset)
Userstimmullen/Documents/WORK/C

Browse

Browse |

(_Cancel JI{ Ok )




Preprocessing: SIFT

Help

Change sampling rate

Filter the data

Re-reference

Interpolate electrodes

Reject continuous data by eye

Extract epochs
Remove baseline

Run ICA
Remove components

Automatic channel rejection
Automatic epoch rejection
Reject data epochs
Reject data using ICA

CleanlLine

Locate dipoles using DIPFIT 2.x
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Change sampling rate
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Remove components
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¥ Miscellaneous
VerbosityLevel 2
VariableNames
ResetConfigs
¥ Filtering
DifferenceData
v Detrend
DetrendingMethod
¥ Piecewise
SegmentLength
StepSize
Plot
AmplitudeEnvelope
¥ Normalization
¥ NormalizeData
Method

Ed

linear

® &)

0.33
0.082

IO

£

time; ensemble

SignalType

Type of signal to analyze. If 'Components’, data in EEC.icaact will
be processed. If 'Channels' EEC.data will be processed. If 'Sources'
EEC.srcpot will be processed.
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VerbosityLevel 2
VariableNames
ResetConfigs
¥ Filtering
DifferenceData
v Detrend
DetrendingMethod linear
¥ Piecewise
SegmentLength 0.33
StepSize 0.082
Plot
AmplitudeEnvelope
¥ Normalization
¥ NormalizeData
Method time; ensemble
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SignalType

Type of signal to analyze. If 'Components’, data in EEC.icaact will
be processed. If 'Channels' EEC.data will be processed. If 'Sources'
EEC.srcpot will be processed.

| Help | | Cancel | ( OK )

What do you want to do with the new dataset?

Name it: | RespWrong | [ Edit description )
__  Saveit as file:  Browse |

Some changes have not been saved. What do you want to do with the old dataset?
8 Overwrite it in memory (set=yes; unset=create a new dataset)
| sSaveit as file: /Users/timmullen/Documents/WORK/C.. | Browse |
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v Pre-processing

Connectivity
Statistics
Visualization
Help

¥ Modeling Parameters
¥ ModelingApproach Segmentation VAR
WindowLength 0.35
WindowStepSize 0.03
TaperFunction rectwin
NormalizeData
v Detrend
DetrendingMethod constant
SetArgDirectMode
ModelOrderRange [130]
Downdate
InformationCriteria sbc; aic; fpe; hq
¥ Miscellaneous
RuninParallel
¥ PlotResults
OptimalModelSelectionMethod min
PercentileLimits 90
VerbosityLevel 2
¥ Data Selection
WindowSamplePercent 80

g & &)

Eim

Algorithm

Algorithm: Vieira-Morf g
A
v

Description:

[HeIpJ [CancelJ [OKJ

l Fit AMVAR Model
I+ Validate model
g

q




Model Order

4 :
Selection

®no Checking MVAR parameters

Some warnings were generated (see below), Continue?

WARNING: Two model orders specified [1 30]
| assume you are providing a [min max] range for model order selection.
| will use p=(30) for the remaining checks...

WARNING: Ratio of number of parameters to datapoints is 0.174.
If using an unconstrained (unregularized) model fitting apprach: For best results, ratio of number of parameters to datapoints should be < 0.1.
| recommend using window length of at least 0.610 sec

OK: Time-Frequency Product is 993.712. This should be greater than p=30

OK: Given your model order of p=30, a maximum of p/2=15.0 frequency components (spectral peaks) can be estimated for each pair of variables

| Cancel | ‘[ Ok |
800 Progress

Fitting VAR[30] model (Vieira-Mor)... (13%) 53 secs
] x|
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Do you want to proceed to model fitting?
A Model-fitting GUI will be generated for you based on the options you selected above
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Do you want to proceed to model fitting?
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Model Fitting

Fil Study Datasets

Change sampling rate

Filter the data I
Re-reference

Interpolate electrodes

Reject continuous data by eye

EBDLUE Extract epochs
Events Remove baseline
Sampli

Epoch s Run ICA

Remove components

Automatic channel rejection
Automatic epoch rejection
Reject data epochs

Reject data using ICA

v

\ 4

CleanlLine

Simulation I+ ‘

. . v Pre-processing
Locate dipoles using DIPFIT2.x »

Peak detection using EEG toolbox Connectivity

FMRIB Tools > Statistics >
Locate dipoles using LORETA »  Visualization >
Help I
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Model Fitting

¥ Modeling Parameters
i Vieira-Morf
ModelOrder
WindowlLength 0.35
WindowStepSize 0.03
Yo Xé ‘ TaperFunction rectwin
e — = EpochTimeLimits 0
F||e Edlt P|0t StUdy Datasets He|p WIndo\NSamp|ePercent 100
. - ¥ Window Preprocessing
- S .
v Detrend WV
—_ Re-reference DetrendingMethod constant
Interpolate electrodes ¥ Miscellaneous
Reject continuous data by eye Timer g
SetArgDirectMode v
Extract epochs VerbosityLevel 2
Remove baseline
ModelOrder
Run ICA VAR model order.
Epoch Remove components
Automat!c channel I:ejeFtlon ( Help ) ( Cancel ) (oK |
Automatic epoch rejection
Reject data epochs 8 e
Reject data using ICA I
4
CleanlLine
Simulation I
. ) v Pre-processing ’
Locate dipoles using DIPFIT2.x »
Peak detection using EEGC toolbox Connectivity
FMRIB Tools »  Statistics >
Locate dipoles using LORETA »  Visualization >
Help I
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M O d EI v Pre-processing
SGEER G EEGGREUGENGL I N v Model Order Selection

Val | Cl ati on Connectivity v Fit AMVAR Model

Statistics [ alidate mode
Visualization I+
Help I
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Simulation [

M O d EI v Pre-processing
SGEER G EEGGREUGENGL I N v Model Order Selection

I I Connectivity v Fit AMVAR Model
Validation Connac i AMVAR Mo
Visualization I+
Help I

YT e
ﬁz*z.s@'v%é

¥ vValidation Methods
v CheckResidualWhiteness 4
SignificancelLevel 0.05
MultipleComparisonsCorrection none
NumberOfAutocorrelationLags 500 |
' ™ Ljung-Box

v CheckResidualVariance W ACF

NumberOfAutocorrelationLags 50
CheckConsistency L ™ Li-McLeod
CheckStability E

¥ Data Reduction ( Cancel ) &

| WindowSamplePercent 70
¥ Miscellaneous TTp—

VerbosityLevel 2
PlotResults V]

WhitenessCriteria
Whiteness criteria. These are the statistical tests used to test for
uncorrelated residuals

[ Help | ( Cancel | [ oK )
e
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SGEER G EEGGREUGENGL I N v Model Order Selection

>

Val | Cl ati on Connectivity v Fit AMVAR Model
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Help
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¥ vValidation Methods

v CheckResidualWhiteness 4
SignificancelLevel 0.05
MultipleComparisonsCorrection none
NumberOfAutocorrelationLags 50

v CheckResidualVariance

W ACF

CheckConsistency

NumberOfAutocorrelationLags 50
[ ]

W Li-McLeod

MR @ Ljung-Box

CheckStability E

WindowSamplePercent 70

¥ Data Reduction Cancel &

¥ Miscellaneous [TTp—

VerbosityLevel 2
PlotResults 4

WhitenessCriteria
Whiteness criteria. These are the statistical tests used to test for
uncorrelated residuals
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)0 rigure £: RespWrong - Model Val
File Edit View Insert Tools Desktop Window Help
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¥ Connectivity Estimation I

/  Connectivity

(ConnectivityMeasures —___________[nDTF; dDTF08; nPDC; S IR 12
¥ Options

SquaredModulus 4
ConvertSpectrumToDecibels W
Frequencies 1:40

. . ¥ Miscellaneous

Simulation I+ VerbosityLevel

v Pre-processing

Model fitting and validation »

et Measures are categorized as follows:
Statistics . + DIRECTED TRANSFER FUNCTION MEASURES
Visualization > DTF: Directed Tranfer Function
Help I+ nDTF: Normalized DTF
dDTF: Direct DTF
dDTFO8: Direct DTF (with full causal normalization)
ffDTF: Full-frequency DTF
+ PARTIAL DIRECTED COHERENCE MEASURES
PDC: Partial Directed Coherence
nPDC: Normalized PDC
CPDC: GCeneralized Partial Directed Coherence
PDCF: Partial Directed Coherence Factor
RPDC: Renormalized Partial Directed Coherence
+ CRANCER-GEWEKE CAUSALITY MEASURES
CCC: Cranger-Geweke Causality
+ SPECTRAL COHERENCE MEASURES
Coh: Complex Coherence
iCoh: Imaginary Coherence
pCoh: Partial Coherence
mCoh: Multiple Coherence
+ SPECTRAL DENSITY MEASURES
S:  Complex Spectral Density

ERTE ‘[OK*]

-
‘ - roaress

Estimating connectivity for RespWrong... (14%) 33 secs

ConnectivityMeasures
Select measures to estimate.

L2
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/  Connectivity

Simulation I
v Pre-processing
Model fitting and validation »

Statistics I
Visualization [
Help >

_M

File Edit Debug Desktop Window Help

Connectivity estimation will require 2.7344 MB of memory (pt
Make sure you have enough memory available.
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¥ Connectivity Estimation

(] DTF
¥ Options
SquaredModulus 4 g :g.l;
ConvertSpectrumToDecibels W —
Frequencies 1:40 8 dDTFO8
¥ Miscellaneous Q ffOTF
VerbosityLevel Ll pDC
™ nPDC
ConnectivityMeasures ~ GPDC
Select measures to estimate. =) PDCF
Measures are categorized as follows: _] RPDC
+ DIRECTED TRANSFER FUNCTION MEASURES [ ] GGC
DTF: Directed Tranfer Function ] Coh
nDTF: Normalized DTF ] iCoh
dDTF: Direct DTF ] pCoh
dDTFO8: Direct DTF (with full causal normalization) ‘[Zl‘ mCoh
ffDTF: Full-frequency DTF

+ PARTIAL DIRECTED COHERENCE MEASURES
PDC: Partial Directed Coherence
nPDC: Normalized PDC
CPDC: GCeneralized Partial Directed Coherence
PDCF: Partial Directed Coherence Factor
RPDC: Renormalized Partial Directed Coherence
+ CRANCER-GEWEKE CAUSALITY MEASURES
CCC: Cranger-Geweke Causality
+ SPECTRAL COHERENCE MEASURES
Coh: Complex Coherence
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8 ¥ DisplayProperties

Visualization:

) |

T° F G . d ¥ [MatrixLayout Partial pi
I m e ~ req U e n Cy I"I UpperTriangle dDTFO8 "
UT_ColorLimits 100 "
LowerTriangle dDTFO8 "
LT_ColorLimits 100 "
. . Diagonal S 1
Simulation > D_ColorLimits 100

v Pre-processing AllColorLimits 99.7 ::
Model fitting and validation » TimesToPlot [-0.826171875 1.060... I

v Connectivity FrequenciesToPlot [1:40]
Statisti PlotContour = "
tatistics I PlottingOrder 0 "
Visualization Time-Frequency Grid SourceMarginPlot dipole "
Help »  BrainMovie3D NodeLabels 0 "
’ EventMarkers {{o, 'r", "', 2} "
FrequencyScale linear "
Colormap [0 0 0.50666666666... M
¥|Thresholding "
¥ |Thresholding Simple "
PercentileThreshold [97.5 3] "
AbsoluteThreshold (] "
¥ DataProcessing 1|

Baseline I[-1 -0.25]
Smooth2D -
¥ Miscellaneous

DipolePlottingOptions
¥|FrequencyMarkers
FrequencyMarkers [3715]
FrequencyMarkerColor (0.7 0.7 0.7] )
¥ TextAndFont El

MYl ote ) - - o . S,

Baseline
Time range of baseline [Min Max] (sec). Will subtract baseline from
each point. Leave blank for no baseline.

CoHep || cawel || ok |
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7 Causal BrainMovie3D

Simulation I
v Pre-processing Load Config 5L
Model fitting and validation » Save Config S
v Con.ne.ctlwty ConnectivityMethod dDTFO8
Statistics > MovieTimeRange [-0.826171875 1.0...
Visualization Time-Frequency Grid FrequenciesToCollapse 1:15
BrainMovie3D FreqCollapseMethod max
; TimeResamplingFactor 0
SubtractConditions =
Baseline (]
¥ DisplayProperties
v ShowNodeLabels v
Nodelabels 12345678
NodesToExclude
EdgeColorMapping PeakFreq
EdgeSizeMapping Connectivity
NodeColorMapping Outflow
NodeSizeMapping Power
M FooterPanelDisplaySpec  [ICA ERPenvelope
ICs 1;2;3:4,5,6,7,:8 |a
BackProjectToChans Al; A2; A6; A7; AB;... |y
FooterPanelDisplaySpec
Configure footer panel displayed at the bottom of the -
figure. If 'off', don't render footer. If 'ICA_ERP_Envelope', g
then display the ERP envelope of backprojected v

— Preview BrainMovie
Select a time point to image (click to refresh)
I ) Salol
0.826172 -0.00585338 1.06055
[ Help J [ Cancel J [ Make Movie! J

/4
S
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Causal BrainMovie3D

Visualization:

File
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Simulation I
v Pre-processing Load Config 5L
Model fitting and validation » Save Config S
v Con.ne.ctlwty ConnectivityMethod dDTFO8
Statistics > MovieTimeRange [-0.826171875 1.0...
Visualization > Time-Frequency Crid FrequenciesToCollapse 1:15
| Help I BrainMovie3D FreqCollapseMethod max
; TimeResamplingFactor 0
SubtractConditions =
- ie Confia File Baseline (]
— . ¥ DisplayProperties
() Data > a / v ShowNodelabels 4
Nodelabels 12345678
— NodesToExclude
SESPRTONg_F QVieLontyg ! EdgeColorMapping PeakFreq
RespCorrect.set 6/13/12 EdgeSizeMapping Connectivity
RespCorrect.fat 6/13/12 NodeColorMapping Outflow
RespWrong.set 6/13/12 NodeSizeMapping Power
RespWrong.fdt 6/13/12 M FooterPanelDisplaySpec |ICA ERPenvelope |
ICs 1;2;3,4,5:6;7.8 |a
BackProjectToChans Al; A2; A6; A7; A8;... |y
FooterPanelDisplaySpec
Configure footer panel displayed at the bottom of the -
figure. If 'off', don't render footer. If 'ICA_ERP_Envelope', g
then display the ERP envelope of backprojected v
3 — Preview BrainMovie
3 Select a time point to imaqe (click to refresh)
I g e
0.826172 -0.00585938 1.06055
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Visualization:

Causal BrainMovie3D

Statistics

Simulation
v Pre-processing
Model fitting and validation »
v Connectivity

Visualization

S

Time-Frequency Grid

OO0 BrainMovie3D Control Panel

DisplaylLegendPanel
DisplaylLegendUmitText
Showlatency
DisplayRTProbability
BackgroundColor

v GraphColorAndScaling

NodeSizeLimits
NodeColorLimits
EdgeSizeLimits
EdgeColorLimits
NodeSizeDataRange
NodeColorDataRange
EdgeSizeDataRange
tEdgeColorDataRange
CenterDataRange
EdgeColorMap
NodeColorMap
DiskScalingFactor
MagnificationFactor

¥ OutputFormat

ImageOutputDirectory
ImageOutputFormat
MovieOutputFilename
MovieOpts

ImageSize

mni
ShowMRISlices
DipoleCoordinateFormat
DipplotOptions
BrainMovieSuppOptions
¥ Thresholding
UseStatistics
PercentleThreshold
AbsoluteThreshold

Jet(64)
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0
standard_BEM_mri.mat

-
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FooterPanelDisplaySpec
Configure footer panel displayed at the bottom of the
figure. If 'off', don't render footer. If 'ICA_ERP_Envelope',
then display the ERP envelope of backprojected
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¥ DataProcessing ~
ConnectivityMethod dDTFO8
MovieTimeRange (-0.826171875 1.0...
FrequenciesToCollapse 1:15
FreqCollapseMethod max
TimeResamplingFactor 0
SubtractConditions O
Baseline ]
¥ DisplayProperties
v ShowNodelabels 4
Nodelabels 12345678
NodesToExclude
EdgeColorMapping PeakFreq
EdgeSizeMapping Connectivity "/
NodeColorMapping Outflow
NodeSizeMapping Power
v FooterPanelDisplaySpec ICA_ERPenvelope
ICs 1;2,3,4,5,6,7,8
BackProjectToChans Al; A2; AG; A7, AB,...
PlotMode all; envelope
EnvelopeColor (100)
¥ BrainMovieOptions
ImageSize (800 800]
Visibility on
ShowCameraMenu O
» RotationPath3D ™
InitialView (122 36)
MakeCompass 54
ProjectGraphOnMRI off
¥ Theme
theme classic
v Layers
» Scalp 8 A
Skull ()
FooterPanelDisplaySpec -
Configure footer panel displayed at the bottom of the
figure. If 'off', don't render footer. If 'ICA_ERP_Envelope’, E
then display the ERP envelope of backprojected v
— Proview BranMovie
Select a ime point 10 mage (Cick 1o refresh)
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DataProcessing »
ConnectivityMethod dDTFO8
MovieTimeRange (-0.826171875 1.0
FrequenciesToCollapse 1:15
FreqCollapseMethod max
TimeResamplingFactor
SubtractConditions
Baseline
DisplayProperties
ShowNodelLabels 4

Nodelabels 12345678
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|0 Additional Exercises

1. Explore changing some of the Time-Frequency Grid parameters. Try plotting the TF-Grid with
logarithmic frequency spacing (option: FrequencyScale). Change the SourceMarginPlot to “topoplot” to
see your ICA topographic plots.

2. Explore different parameters for the BrainMovie3D. What is different between delta (1-3 Hz) and theta
(3-7 Hz) band connectivity?

3. Recompute connectivity for the RespWrong condition, selecting the Coherence (Coh) and Partial
Coherence (pCoh) methods in addition to the original nPDC, nDTF, dDTF08, and S methods. Create a
Time-Frequency Grid laying out Coherence (Coh) on the UpperTriangle, Partial Coherence (pCoh), on the
LowerTriangle and the ERSP (S) on the diagonal. Use a baseline of [-1 -0.25]. What is different between
coherence and partial coherence? Create another Time-Frequency Grid with dDTF08 on the Upper and
Lower Triangles. What is different between coherence and dDTF (Granger-Causality)?

4.Redo the entire pipeline (Steps 1-9) for the RespCorrect condition (located in same /Data folder as
RespWrong). Select both conditions in EEGLAB (Datasets-->Select Multiple Datasets). Create a Time-
Frequency Grid. Choose to the plot the difference RespWrong-RespCorrect (option:
PlotConditionDifference->ConditionOrder) with the dDTF08 on the Upper and Lower Triangle and ERSP
on the diagonal.

5. Advanced Users: Try executing the previous pipeline entirely from the command line. Consult
{sift_root>/scripts/ScriptingExample.m for guidance.
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Visualization of

condition differences

Select RespWrong and RespCorrect datasets

- J LU
e e AN N AT I AT A

Tools Plot Study EBEICHIE m

Edit

File

__Datasets 1,2 v Dataset 1:RespCorrect
v Dataset 2:RespWrong
Groupname: -(soon)- Select multiple datasets

Number of datasets

Dataset type
Epech ceonsistency ves
Channels per frame 152
Channel consistency ves
Channel locatioens ves
Events (total) 2083
Sampling rate (Hz) 256
ICA weights ves
Identical ICa no
Total size (Mb) 624.3
/
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Visualization of

condition differences B =
¥ DisplayProperties
¥ PlotConditionDifference 4
Pre-processing ¥ MatrixLayout Partial
Locate dipoles using DIPFIT 2.x » g::;'ef:‘:::s SERSGion UpperTr.iangle dDTFO8
Peak detection using EEG toolbox Statistics > LowerTriangle dDTFO8
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¥ DataProcessing
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eSNO Figure 10: Subj eb79. Cond (RespWrong) - (RespCorr).
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eNO Figure 10: Subj eb79. Cond (RespWrong) - (RespCorr).
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Figure 3: Subj eb79. Cond (RespWrong) - (RespCorr).
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ANO Figure 6
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eNOo Figure 3: Subj eb79. Cond (RespWrong) - (RespCorr).
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eNO Figure 10: Subj eb79. Cond (RespWrong) - (RespCorr).
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Figure 8: Subj eb79. Cond (RespWrong) - (RespCorr).
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