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Part 3b: Event Related Coherence

* Goal: How similar is the
event-related response
of two signals? - T
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TWO SIMULATED THETA PROCESSES

Event-related
Coherence
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Cross coherence between IC 1 and IC 3

\'. @ Figure 4
| File Edit View Insert Tools Desktop Window Help

Coherence

DEde h CAODEW- 3 08 nO

50
] |1 g
b | )
N
T 1
g . ! %
i ‘ J ¥ ' _
10 ‘x ; : ‘-- “ : .
o - 1 T v T 1
coh. )
A
- 0 500

041
03
02

01

04 _ 0
8
Q7
of- ]
90

a = 0.01

\'. @ Figure 5
File Edit View Insert Tools Desktop Window Help

NEade h RKL99EH- 2 08 0O

041

& 8
-

031

02

404

Freq. (Hz)
a 8 8
o= === == -
?f 1
J
.',. i ‘
-

1000 1500

®

-]
o
coh.
o © -O Q (=]
o 3 -

Freq. (Hz)
&
o
o

F " :,.1 o

1000 1500

10

500 500
Time (ms)

Significant event-related coherence (as well as tonic
coherence) in alpha/beta bands

IC 1 tonically leads IC 3 (negative phase), but phase
relationships are changed post-stimulus

Directional measures of effective connectivity are present in the SIFT toolbox.
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EEGLAB Toolset
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Source Information Flow Toolbox

Mullen, et al, Journal of Neuroscience Methods (in prep, 2012)
Mullen, et al, Society for Neuroscience, 2010
Delorme, Mullen, Kothe et al, Computational Intelligence and Neuroscience, vol 12,201 |
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- 1: Button press epochs .

PESDPDHDE

* Atoolbox for (source-space) electrophysiological information flow and causality
analysis (single- or multi-subject) integrated into the EEGLAB software environment.

* Emphasis on vector autoregression and time-frequency domain approaches

« Standard and novel interactive visualization methods for exploratory analysis of
connectivity across time, frequency, and spatial location
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The Dynamic Brain

x A key goal: To model temporal changes in neural dynamics
and information flow that index and predict task-relevant
changes in cognitive state and behavior

= Open Challenges:

= Non-invasive measures
(source inference)

» Robustness and Validity
(constraints & statistics)

= Scalability (multivariate)

» Temporal Specificity / Non-
stationarity / Single-trial
(dynamics)

» Multi-subject Inference

» Usability and Data
Visualization (software)

Mullen, 2011
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Large-scale brain connectivity

(Bullmore and Sporns, Nature, 2009)

Structural Functional Effective

state-invariant, dynamic, state-dependent dynamic, state-dependent,’
anatomical correlative, symmetric asymmetric, causal,
information flow

Hours-Years illiseconds-seconds

Temporal Scale



Functional connectivity

Non-directed Directed
- |
3
(]
Q.
o}
; Mutua_l Cross-correlation, Transfer g
informationd Granger causality entropy A=Y
Coherence, L
Phase Locking Value _8
Pairwise Phase Consistency [
Phase Slope Index g
Parametric and Nonparametric Q
Granger Causality o
o
=,
Q.
-

Bastos AM, Schoffelen J-M: A Tutorial Review of Functional Connectivity Analysis
Methods and Their Interpretational Pitfalls. Front Sys Neurosci 2016, 9:413.
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The problem of spurious connectivity

Kus, 2004

>
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(Bendat and Piersol, 1986)

Bivariate measures, such as coherence (but also original GC),
find spurious connections between nodes if they share a
common input.



Ground Truth
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A deeper problem - unobserved nodes

With EEG, it's unavoidable that there will be contributing
network nodes (e.g. thalamus) that we cannot observe.

We also can't be sure ICA will identify all important sources...



Granger-causality

* A measure of statistical causality
based on prediction.

* Widely used in time-series econometrics.
* Nobel Prize in economics, 2003.

If a signal A causes a signal B, then knowledge of the
past of both A and B should improve the predictability of
B, as compared to knowledge of B alone.



AR Models (prediction of future of a signal by its past)

VAR Models (prediction of future of a signal by its past + the other signal's past)

Incorporating information about X, improves the prediction of X, !
We say "X, granger-causes X,"



Calculation of GC

time series data

Spectral estimation using
Fourier decomposition and
multitapering

Autoregressive model
estimation

model coefficients
and residuals

Cross-spectral
density matrix

non-parametric approach

Fourier transformation
of model coefficients

Factorization of spectral
density matrix

noise covariance matrix
spectral transfer function

Estimation of Granger causality

Granger causality
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Vector Autoregressive
(VAR / MAR / MVAR) Modeling
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VAR|[p] model

The Linear Vector Auto-
regresswe (VAR) Model

; Ordinary Least-Squares
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model order
p (k) random noise process
X(t)=), APOX(t-k)+E(r)
M-channel data vector M x M matrix of (possibly time-varying) multichannel data k
at current time t model coefficients indicating variable samples in the past
dependencies at lag k
) . i) \
1" S Y,
A®@)= w0 E(t)=N(0,V)
|0 - a0




Selecting a VAR Model Order

» Model order is typically determined by minimizing information criteria
such as Akaike Information Criterion (AlC) for varying model order (p):

AIC(p) = 2log(det(V)) + M?2p/N ~ Penalizes high model orders (parsimony)

entropy rate (amount of prediction error)

AIC (bits)

optimal order W ETYEIE
model order



Selecting a VAR Model Order

= QOther considerations:

» A M-dimensional VAR model of order p has at
most Mp/2 spectral peaks distributed
amongst the M variables. This means we can
observe at most p/2 peaks in each variables’
spectrum (or in the causal spectrum between
each pair of variables)

» Optimal model order depends on sampling rate (higher
sampling rate often requires higher model orders)



Granger Causality

Does X4 granger-cause X1? prediction error for X

. (variance of residuals E1)
(conditioned on Xz, Xs)
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Granger Causality

B Granger (1969) quantified this definition for bivariate processes in the
form of an F-ratio: reduced model

- =m(var(ﬁl))_m( var(X,(t)| X,() )
var(E) )\ var(X,(0] X,0, X, )

X1 <—X2

full model

B Alternately, for a multivariate interpretation we can fit a single MVAR
model to all channels and apply the following definition:

Definition 1
Xj granger-causes Xi conditioned on all other variables in X
ifand only if A (k)>>0 forsomelag k€ {l, ..., p}




Granger Causality — Frequency Domain

X(H)=Y' APX(t-k)+E@)
k=1 Likewise, X(f) and E(f) correspond to

Fourier-transforming A% we obtain the fourier transforms of the data
and residuals, respectively

__N\'? (k) ,—i2mfle. A (0) _
A(f)=-),, AP A0 =]
We can then define the spectral matrix X(f) as follows:

X(f)=A(f)"E(f)=H(/)E(f)

Where H(f) is the transfer matrix of the system.

Definition 2
X; granger-causes X; conditioned on all other variables in X ‘eapgscm

if and only if |A(f)] >> O for some frequency f




e UE YOVICL N OR  Ground Thh
2: i A(f, t) = _z:g . A(k)(t) e—ﬂxﬁ; A(o) =]

0 ) WA s | XCf) = AL ECS )= BUAOEC)

ooooooo Spurious

S | e indirect true flow

‘g S(f) = X(f)X(f) g ’/\\ e— direct true flow

%) = H(f)ZH(f)’ | AN

(Brillinger, 2001) Frequency (Hz) v NOTE: time index (t) dropped for convenience
' Functional Effective \
)
L = S.(f) U
© &) _ ij O X = 2 2
. e C. — .= I ZNIH (NI
: JS.(NS (/) D2 F(pH=—t T 2D A
ﬁj 8 . 4 Q o 4] Sn'(f )
(Bendat and Piersol, 1986) ORCN! (Geweke, 1982; Bressler et al., 2007)
= [ : @
5 EXInE S, 95 (/)= | 4,(N)F
s ssim E8s WGy, ¢
= &) : ? .50 Zk=l|A’€i(f)|
(Bendat and Piersol, 1986; Dalhaus, 2000) O (Bacoaié s Bameshina, 2001)

EEGLAB Workshop XXIll, Jan 16-19, 2016, India—John Iversen— Connectivity 27



Time-Frequency GC

= Brain network dynamics often change rapidly with time
x gvent-related responses

x transient network changes during sequential information
processing

= Electrophysiological processes often exhibit oscillatory
phenomena, making them well-suited for frequency-
domain analysis



Adapting to Non-Stationarity

x The brain is a dynamic system and measured brain activity
and coupling can change rapidly with time (non-stationarity)

» event-related perturbations (ERSP, ERP, etc)

= structural changes due to learning/feedback

= How can we adapt to non-stationarity?

+

mV

time



Adapting to Non-Stationarity

= Many ways to do adaptive VAR estimation
®x Segmentation-based adaptive VAR estimation

» Factorization of time-varying spectral density matrices
(e.g. from STFTs, Wavelets, etc)

» State-Space Modeling



Segmentation-based VAR

(Jansen et al., 1981; Florian and Pfurtscheller, 1995; Ding et al, 2000)
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Important Choices

e Model Order

— Determines complexity of spectrum you can model
— Larger orders need more data

* Window Length

— Window must be long enough to contain sufficient
data for your chosen model order

— Must be long enough to encompass the time-scale of
interactions

— Yet not too long as to smear temporal dynamics or
include non-stationary data




Consideration: Local Stationarity

1 point window —
10 point window
20 point window —

Too-large windows may not be
locally-stationary
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Consideration: Sufficient data

M = number of variables

p = model order

Ntr = number of trials

W = length of each window (sample points)

We have M?p model coefficients to estimate. This requires a
minimum of M2p independent samples.

So we have the constraint M?p <= Nt W.

In practice, however, a better heuristic is M?p <= (1/10)N¢ W.

: s 2
Or: W >= 10(M“p/Nv) 10x more data points than
parameters to estimate

SIFT will let you know if your window length is not optimal



Network causal information flow during motor
planning and execution

John R. Ilversen, Alejandro Ojeda, Tim Mullen, Markus Plank, Joseph Snider,
Gert Cauwenberghs, Howard Poizner

Institute for Neural Computation
Swartz Center for Computational Neuroscience
University of California, San Diego
EMBC 2014

PhaseSpace EyeLink 1000

72-channel EEG
—=—_ (Bi i)
o 0 o

Center for
Computational
Neuroscience




How does brain plan visually guided movements?

Pointing Task (Park, et al. 2014, IEEE Trans Neural Syst Rehabil Eng)

TARGETHIT  5¢ . upper right PhaseSpace EyeLink 1000

TARGET MISS O¢ ~.  target motion capture
N ELO touchscreen p— 72-channel EEG

(Biosemi)

&, center

radius=12.5mm

lower left M .
target

HAND +”
SACCADE y
" vs.
HAND t t t t /hand arrival
arget onse center P eye/hana arrival,
LIFT{;!@ hold hold offset eye/hand initiation feedback
500-700| 500-700 < time window (e.g., 450 ms)
N=10 (right-handed, mean age=21) Planning | Execution < Analysis Window
70 channel EEG (Biosemi) = 0c 7

512 Hz; 128Hz for connectivity Time (s)



ICA source space analysis

Independent Component Analysis Cortical ROIs

Decompose single-subject data with AMICA

Channels

Estimate IC equivalent dipole locations

Identify & remove non-brain artifact ICs

SISIDIE,

Blink

Time

IC1

Saccade

f@xw."]lm
xww/w--- IC2

le\f\,/w\!l\M ‘ IC3

IC2 IC3

L Pre-auric R Pre-auric

A e s Group SIFT: Project ICs onto cortical

surface using LORETA; extract ROI time series.
Advantage: Same ROls for all subjects enables
statistical comparison. (Use BCILAB srcpot)
EEGLAB Workshop XXIll, Jan ¥6=15; - ' t




Core Analysis Methods |

eSegmentation—based
MVAR

X()=), AP@OX(-k)+E@)

A(f)==),, AP M A0 =]
A(f)"=H(f)

smoothness (L2)

prediction error (preserves spectrum)

4 ; ( A\
)= |y -2 254
\ J

N

regularization



Core Analysis Methods I

eTime-varying SADTF ("short-time
direct directed transfer function")

eDirected measure of direct
(unmediated) causal flow between
ROls

eCombines DTF and partial
coherence; windowed (0.5s, 30ms).

i () = > ki Hi(f, 7)?| P (f, 7)[2

(Korzeniewska, et al. 2008)



dDTF

Partial Coherence

[H;; (f,1)]*|Pij (f, 1)
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&) OB O
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Frequency (Hz)

SIFT Analysis

ACC

—h
w 3

w

eTime-varying SADTF

Directed measure of
direct causal flow
between ROIls

Averaged across
subjects



dDTF during reaching

FROM L Mot R Mot L Occ R Occ ACC L Par R Par
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Changed causal flow during reaching
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Planning Execution

50
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L 15
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Occipital 2 ACC
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Greater causal flow during movement planning

P Reach > Lift

B Reach < Lift




Discussion ——

R Par B Reach < Lift
{ )

SIFT is a capable toolkit for causal
dynamical analysis at source level
Parietal network expected for visually

guided action (e.g. Heider, et al., 2010)

ACC more strongly driven by Occipital & Motor. Locus for
translation of intention into action (Paus, 2001:; Srinivasan, et
al. 2013). ACC drives SMA (not shown).

Causal network results depend on the number of nodes

— E.g. Occipital 2 ACC could be mediated by region not included in
model

— There will always be a tradeoff between network size and amount of
data needed to fit the model.

— Regularization



Source Information Flow Toolbox

Mullen, et al, Journal of Neuroscience Methods (in prep, 2012)
Mullen, et al, Society for Neuroscience, 2010
Delorme, Mullen, Kothe et al, Computational Intelligence and Neuroscience, vol 12,201 |
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- 1: Button press epochs .

PESDPDHDE

* Atoolbox for (source-space) electrophysiological information flow and causality
analysis (single- or multi-subject) integrated into the EEGLAB software environment.

* Emphasis on vector autoregression and time-frequency domain approaches

« Standard and novel interactive visualization methods for exploratory analysis of
connectivity across time, frequency, and spatial location



SIFT Workflow

Simulation >
Pre-processing

Model fitting and validation »
Connectivity

Statistics >
Locate dipoles using DIPFIT 2.x  » | Visualization >
Peak detection using EEG toolbox Help >
FMRIB Tools - T STy
Locate dipoles using LORETA b AN VAAA N AA A Smr g f A o
®SNO v12.0.0.0 WI‘WJ"“M
File Edit Imu Plot Study Datasets Help
——No current dataset

Pre-processing

- Create & new or load an existing

Use "File > Import data®™

- I:tne:flle > Load existing dataset” MOdeI Fit_ting
Import evoch info" (data and Va”dation

Import event info* (continucus
Dataset info"™ (add/edit

"File >
“rile >
"Edit >
>

“File Save dataset™ (save dataset!

- Prune data: “Edit > Select data” COnneCtiVity

- Reject data: "Tools > Reject

BulepolN

- Evoch data: "Tools > Extract evochs”
~ Remove baseline: "Toocls > Remove

- Run ICA: “Tools > Run ICA"

Statistics

Group Analysis Visualization




Help

Change sampling rate
Filter the data 13
Re-reference

Interpolate electrodes

Reject continuous data by eye

Extract epochs
Remove baseline

Run ICA
Remove components

Automatic channel rejection
Automatic epoch rejection

Reject data epochs (2
Reject data using ICA >
Cleanline

SIFT 3

Locate dipoles using DIPFIT 2.x >
Peak detection using EEG toolbox

FMRIB Tools >
Locate dipoles using LORETA

v

Component(s) to remove from data:

(_Hop

Component(s) to retain (overwrtes "Component(s) to remove"”)

| Cancel JI| Ok |

8, 11,13, 19, 20, 23, 38, 39

W

Flaase confiem. A you Sure you want 10 nenows These comporents?

[ Cecel ] [P EFey Pict s traiq
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Preprocessing: SIFT

A6 AB v1s.0.0.0D
File Edit Plot Study
Change sampling rate
Filter the data
Re-reference

Interpolate electrodes
Reject continuous data by eye

Extract epochs
Remove baseline

Run ICA
Remove components

Automatic channel rejection
Automatic epoch rejection
Reject data epochs

Reject data using ICA

CleanlLine

Locate dipoles using DIPFIT 2.x
Peak detection using EECG toolbox

FMRIB Tools
Locate dipoles using LORETA

Data;ets

>

v

¥

v

Help

Simulation
Pre-processing
Model fitting and validation
Connectivity

Statistics

Visualization

Help

1)
2 R

e
B -i=

¥ Miscellaneous
VerbosityLevel 2
VariableNames
ResetConfigs
¥ Filtering
DifferenceData
¥ Detrend
DetrendingMethod
¥ Piecewise
SegmentLength
StepSize
Plot -
AmplitudeErwvelope =
™

=

linear

® @

0.33
0.082

¥ Normalization
¥ NormalizeData
Method

time; ensemble

SignalType

Type of signal to analyze. If 'Components’, data in EEC.icaact will
be processed. If 'Channels' EEC.data will be processed. If "Sources'
EEC.srcpot will be processed.

. Help | . Cancel ‘IOK'I
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M O‘d el O rd e r ¥ Modeling Parameters
4 ¥ ModelingApproach Segmentation VAR
Se I eCti on
: WindowlLength 0.35
WindowStepSize 0.03
TaperFunction rectwin
NormalizeData 0
¥ Detrend v
DetrendingMethod constant
SetArgDirectMode e
ModelOrderRange [130]
Help Downdate e
InformationCriteria sbe; aic; fpe; hg
#1: 1 Change sampling rate | ¥ Miscellaneous -
[ Filter the data » | :;'g"’ﬁf;snﬂ g'
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Fi1 Re-reference OptimalMode|SelectionMethod min
Interpolate electrodes R 30
s Reject continuous data by eye VerbosityLeve! 2
: ¥ Data Selection
FPeERE | Extract epochs WindowSamplePercent 80
e Remove baseline
Sampl Algorithm -
Epoch REnICA B B i
Epoch & Remove components Vieira-Maorf
Bef e o o e e o s i U
Automatic channel rejection Algorithm: Vieira-Morf
SCR Automatic epoch rejection o ot
sarasez| Reject data epochs > Description: L2 |
Reject data using ICA (2
CleanLine

Simulation
v Pre-processing

Locate dipoles using DIPFIT 2.x

_ ’ Model fitting and validation Model Order Selection
Peak detection using EEGC toolbox | Connectivity Fit AMVAR Model
EMRIB Tools p  Statistics »  Validate model
Locate dipoles using LORETA »  Visualization >

\ Help >
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5 Model Fitting

4 & =i |\
¥ Modeling Parameters ‘
Algorithim igira-Mort )
‘ I
| WindowLength 0.35
Wind owStepSize 0.03
A MO TaperFunction rectwin
o : : EpochTimeLimits 1
File Help WindowSamplePercent 100
:R( Change sampling rate e =
Filter the data > ¥ Detrend E
ciieseea Re-reference DetrendingMethod constant
| Interpolate electrodes ¥ Miscellaneous -
I Reject continuous data by eye Timer =
n:u_u SetArgDirectMode a
Aochs Extract epochs VerbosityLevel 2
e Remove baseline
Sampl ModelOrder
Run ICA VAR model order.
Remove components
Automatic channel rejection :
. N Help Cancel ‘ oK |
Automatic epoch rejection e - —
Reject data epochs - . 4
Reject data using ICA »
CleanLine
Simulation [

v Pre-processing

Locate dipoles using DIPFIT 2.x Model fitting and validation

v Model Order Selection
Peak detection using EEC toolbox

Connectivity Fit AMVAR Model
EMRIB Tools p  Statistics »  Validate model
Locate dipoles using LORETA »  Visualization -1
{  Help >
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5 Model Fitting
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Simulation =
v Pre-processing
Model fitting and validation

Model

> Model Order Selection
+ Fit AMVAR Model

1 Ta Connectivity

val I d atl on Statistics [ Validate model
Visualization >
Help >

B4 @ =
¥ Validation Methods
¥ CheckResidualWhiteness
SignificancelLeve|
MultipleComparisonsCorrection
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History of group-level SIFT

* Approaches

— Tim Mullen & Wes Thompson (since 2010)
‘Hierarchical Bayesian Modeling’ that interpolate
missing values (i.e. inconsistency in dipole locations
across subjects).

* ROI-based approaches

— Iversen, et al, 2014: project IC activation onto cortical
surface and define activity in anatomically defined
cortical ROls.

— Nima Bigdely-Shamlo (in his PhD dissertation in
2014) ‘Network Projection’ that uses dipole density
and anatomical ROI. (Makoto's talk)



