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modeling tools

EEGLAB Workshop XXVI
Ben-Gurion University, Be'er-Sheva, Israel
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Part 3b: Event Related Coherence

* Goal: How similar is the
event-related response
of two signals? - T

___#2:faces_41 Channellocations >
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Channel spectra and maps
Channels per framl  Channel properties
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Events

ERP map series >
d Sampling rate (Hz| Sum/Compare ERPs
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TWO SIMULATED THETA PROCESSES

Event-related
Coherence
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Cross coherence between IC 1 and IC 3

\' 00 Figure 4
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Significant event-related coherence (as well as tonic
coherence) in alpha/beta bands

IC 1 tonically leads IC 3 (negative phase), but phase
relationships are changed post-stimulus

Directional measures of effective connectivity are present in the SIFT toolbox.



Source Information Flow Toolbox

Mullen, et al, Journal of Neuroscience Methods (in prep, 2012)
Mullen, et al, Society for Neuroscience, 2010
Delorme, Mullen, Kothe et al, Computational Intelligence and Neuroscience, vol 12,201 |
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PESDPDHDE

* Atoolbox for (source-space) electrophysiological information flow and causality
analysis (single- or multi-subject) integrated into the EEGLAB software environment.

* Emphasis on vector autoregression and time-frequency domain approaches

« Standard and novel interactive visualization methods for exploratory analysis of
connectivity across time, frequency, and spatial location



Tim Mullen
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The Dynamic Brain

x A key goal: To model temporal changes in neural dynamics
and information flow that index and predict task-relevant
changes in cognitive state and behavior

= Open Challenges:

= Non-invasive measures
(source inference)

» Robustness and Validity
(constraints & statistics)

= Scalability (multivariate)

» Temporal Specificity / Non-
stationarity / Single-trial
(dynamics)

» Multi-subject Inference

» Usability and Data
Visualization (software)

Mullen, 2011
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Large-scale brain connectivity

(Bullmore and Sporns, Nature, 2009)

Structural Functional Effective

state-invariant, dynamic, state-dependent dynamic, state-dependent,’
anatomical correlative, symmetric asymmetric, causal,
information flow

Hours-Years illiseconds-seconds

Temporal Scale



A taxonomy of connectivity measures

Functional connectivity

Non-directed Directed

Mutual

4 1 Cross-correlation, Transfer
information

Granger causality entropy

urewop awi|

Coherence,
Phase Locking Value
Pairwise Phase Consistency
Phase Slope Index
Parametric and Nonparametric
Granger Causality

urewop A>uanbai4

Bastos AM, Schoffelen J-M: A Tutorial Review of Functional Connectivity Analysis Methods and
Their Interpretational Pitfalls. Front Sys Neurosci 2016, 9:413.
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The problem of spurious connectivity

Kus, 2004

>

O ‘ .

@ C ( f) _ Slj(f) . s isnpc;:::strue flow
) ij o m— (firect true flow
£ JS(NS, ()

@)

(Bendat and Piersol, 1986)

Bivariate measures, such as coherence (but also original GC),
find spurious connections between nodes if they share a
common input.



Calculation of GC

time series data

Autoregressive model
estimation

Spectral estimation using
Fourier decomposition and
multitapering

model coefficients
and residuals

Cross-spectral
density matrix

non-parametric approach

Fourier transformation
of model coefficients

Factorization of spectral
density matrix

noise covariance matrix
spectral transfer function

Estimation of Granger causality

Granger causality

EEGLAB Workshop XXVI, Oct 15-18, 2017, Israel — Connectivity 14



Granger Causality

* A measure of statistical causality
based on prediction.

* Widely used in time-series econometrics.
* Nobel Prize in economics, 2003.

If a signal A causes a signal B, then knowledge of the
past of both A and B should improve the predictability of
B, as compared to knowledge of B alone.



Granger Causality

B Granger (1969) quantified this definition for bivariate processes in the
form of an F-ratio: reduced model

- =m(var(ﬁl))_m( var(X,(t)| X,() )
var(E) )\ var(X,(0] X,0, X, )

X1 <—X2

full model

B Alternately, for a multivariate interpretation we can fit a single MVAR
model to all channels and apply the following definition:

Definition 1
Xj granger-causes Xi conditioned on all other variables in X
ifand only if A (k)>>0 forsomelag k€ {l, ..., p}




Autoregressive Models

Goal: Predict future values of a data time series (EEG signal) from its past.

p
x(t) = Z a(t)x(t —1) + e(t)
7=1
weighted error
sum of
Example: order p = 2: past values

x(t) =a(Dx(t—1)+a)x(t—2) + e(t)



p

AR Models (prediction of future of a signal by its past)
Xl A" 1‘111‘ ~' )1’ "Y ‘y“l‘ D ‘H‘u xl(t) = 2 a(T)Xl(t — T) + el(t)
T=1

p
Xy PHATIAPM AN, 00 = D b0t =0+ 0

VAR Models (prediction of future of a signal by its past + the other signal's past)

vare
GC2—>1 - ln ( 1)

var(e; )

p
x1(t) = z c(Dx,(t — 1) + Zd(r)xz(t ~ 1) +eg2(0) ~ In(1)=0
T=1

=1



AR Models (prediction of future of a signal by its past)
4

Xl Aﬂ y*,‘,‘ ~ P "y A “‘ . ‘H‘, x,(t) = z a(t)x,(t —1) +e(t)

=1

p
Xy PATIAPM AN, 00 = D b0+ 60

VAR Models (prediction of future of a signal by its past + the other signal's past)

_ . var(e,)
X5 11X NV"‘/W’W\A/\W\/\J\W e = e

p p ~In(>1)=>1
X0 = ) u@xylt =) + Zv(r)xla — 1) +/ean(®

=1

Incorporating information about X, improves the prediction of X, !
We say "X, granger-causes X,"



Granger Causality

B Granger (1969) quantified this definition for bivariate processes in the
form of an F-ratio: (EE—

- =ln(var(El)]=ln( var(X,()| X,() )
var(E,) var(X ()| X,(-), X,()

full model

Problem: Pairwise GC for multichannel data has
problems of spurious connectivity
due to common inputs

Solution: Multivariate VAR (MVAR)



Vector Autoregressive
(VAR / MAR / MVAR) Modeling

X,() S N

X, ()

EEG

X ) MY




VAR|[p] model

The Linear Vector Auto-
regresswe (VAR) Model

; Ordinary Least-Squares
.xl(t) AN A A r"f‘m”..ﬁv
ST e \
xpy= "¢ ,
Xy ®) "J \f\fv‘ AL MM A A M fﬂ'
model order
p (k) random noise process
X(t)=), APOX(t-k)+E(r)
M-channel data vector M x M matrix of (possibly time-varying) multichannel data k
at current time t model coefficients indicating variable samples in the past
dependencies at lag k
) . i) \
1" S Y,
A®@)= w0 E(t)=N(0,V)
|0 - a0




Granger Causality

Does X4 granger-cause X1? prediction error for X

. (variance of residuals E1)
(conditioned on Xz, Xs)

X,(1)

X, (2) YR b WL \

? 2() A vy -/ \J\'\Nf\d — VAR‘I — Var(E1(t))
X, (1) Y T
X, (1) X(t) = 2:=1A<">X(t —k)+E(®) l

=

X 1 (t ) A \Vl\ \J\{"\’\,f" MAahA 4 ‘,\J\,I"N‘ﬁ‘-k v(“vﬁ' T
X,(t) IRt > V=" —>  var(E(t))
X 3 (t ) ,‘1 A{\ﬁ'f\(& N«Lfﬂﬂv‘v-\q{ ey ﬂ«’v

X, 0)=),  A®X (t-k)+E@)



Granger Causality

B Granger (1969) quantified this definition for bivariate processes in the
form of an F-ratio: reduced model

- =m(var(ﬁl))_m( var(X,(t)| X,() )
var(E) )\ var(X,(0] X,0, X, )

X1 <—X2

full model

B Alternately, for a multivariate interpretation we can fit a single MVAR
model to all channels and apply the following definition:

Definition 1
Xj granger-causes Xi conditioned on all other variables in X
ifand only if A (k)>>0 forsomelag k€ {l, ..., p}




Granger Causality — Frequency Domain

X(H)=Y' APX(t-k)+E@)
k=1 Likewise, X(f) and E(f) correspond to

Fourier-transforming A% we obtain the fourier transforms of the data
and residuals, respectively

__N\'? (k) ,—i2mfle. A (0) _
A(f)=-),, AP A0 =]
We can then define the spectral matrix X(f) as follows:

X(f)=A(f)"E(f)=H(/)E(f)

Where H(f) is the transfer matrix of the system.

Definition 2
X; granger-causes X; conditioned on all other variables in X ‘eapgscm

if and only if |A(f)] >> O for some frequency f




e UE YOVICL N OR  Ground Thh
P . A(f,‘)=-2:= i AP (e, A =]

0 ) WA s | XCf) = AL ECS )= BUAOEC)

ooooooo Spurious
S | e indirect true flow
‘g S(f) = X(f)X(f) g ’/\\ e— direct true flow
%) =H(f)ZH(f) | DA
(Brillinger, 2001) Frequency (Hz) v NOTE: time index (t) dropped for convenience
' Functional Effective \
)
L = S.(f) U
[ o _ ij QX = 2 2
- e C. - .=/ ZNIH (N
: JS.(NS (/) D2 F(pH=—t T 2D A
m 8 . 4 Q @ 3] Sn'(f )
(Bendat and Piersol, 1986) 60O (Geweke, 1982; Bressler et al., 2007)
o 5 S . :
A ' snsi 5§88 V)T, 7 & w6
= O : ﬂ &) O O L a9 Zk=l|A’€i(f)|
(Bendat and Piersol, 1986; Dalhaus, 2000) O (Basosid it Ssmeahiie, 2001) O (s) (e)
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Time-Frequency GC

= Brain network dynamics often change rapidly with time
x gvent-related responses

x transient network changes during sequential information
processing

= Electrophysiological processes often exhibit oscillatory
phenomena, making them well-suited for frequency-
domain analysis



Adapting to Non-Stationarity

x The brain is a dynamic system and measured brain activity
and coupling can change rapidly with time (non-stationarity)

» event-related perturbations (ERSP, ERP, etc)

= structural changes due to learning/feedback

= How can we adapt to non-stationarity?

+

mV

time



Adapting to Non-Stationarity

= Many ways to do adaptive VAR estimation
®x Segmentation-based adaptive VAR estimation

» Factorization of time-varying spectral density matrices
(e.g. from STFTs, Wavelets, etc)

» State-Space Modeling



Segmentation-based VAR

(Jansen et al., 1981; Florian and Pfurtscheller, 1995; Ding et al, 2000)
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SOources

time

Analogous to short-
time fourier transform

ensemble normaﬁzatlon | Q

- < 6

X(O) =), A(K)X(t-k)+E() ‘)
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Important Choices

e Model Order

— Determines complexity of spectrum you can model
— Larger orders need more data

* Window Length

— Window must be long enough to contain sufficient
data for your chosen model order

— Must be long enough to encompass the time-scale of
interactions

— Yet not too long as to smear temporal dynamics or
include non-stationary data




Selecting a VAR Model Order

» Model order is typically determined by minimizing information criteria
such as Akaike Information Criterion (AlC) for varying model order (p):

AIC(p) = 2log(det(V)) + M?2p/N ~ Penalizes high model orders (parsimony)

entropy rate (amount of prediction error)

AIC (bits)

optimal order W ETYEIE
model order



Selecting a VAR Model Order

= QOther considerations:

» A M-dimensional VAR model of order p has at
most Mp/2 spectral peaks distributed
amongst the M variables. This means we can
observe at most p/2 peaks in each variables’
spectrum (or in the causal spectrum between
each pair of variables)

» Optimal model order depends on sampling rate (higher
sampling rate often requires higher model orders)



Order selection in reality

Information Criteria for Sample Subject - Lift Condition
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Consideration: Local Stationarity

1 point window —
10 point window
20 point window —

Too-large windows may not be
locally-stationary

'g
[
=
Q
Q
0
7]
4
o

Time (msec)




Consideration: Sufficient data

M = number of variables

p = model order

Ntr = number of trials

W = length of each window (sample points)

We have M?p model coefficients to estimate. This requires a
minimum of M2p independent samples.

So we have the constraint M?p <= Nt W.

In practice, however, a better heuristic is M?p <= (1/10)N¢ W.

: s 2
Or: W >= 10(M“p/Nv) 10x more data points than
parameters to estimate

SIFT will let you know if your window length is not optimal



Example Application

EEG-Based Quantification of Cortical
Current Density and Dynamic Causal
Connectivity Generalized across
Subjects Performing BCl-Monitored

Cognitive Tasks

Hristos Courellis ?*, Tim Mullen', Howard Poizner?®, Gert Cauwenberghs?? and
John R. Iversen’

Frontiers in Neuroscience | www.frontiersin.org

May 2017 | Volume 11 | Article 180



How does brain plan visually guided movements?

Pointing Task (Park, et al. 2014, IEEE Trans Neural Syst Rehabil Eng)

TARGETHIT  5¢ . upper right PhaseSpace EyeLink 1000

TARGET MISS O¢ ~.  target motion capture
N ELO touchscreen p— 72-channel EEG

(Biosemi)

&, center

radius=12.5mm

lower left M .
target

HAND +”
SACCADE y
" vs.
HAND t t t t /hand arrival
arget onse center P eye/hana arrival,
LIFT{;!@ hold hold offset eye/hand initiation feedback
500-700| 500-700 < time window (e.g., 450 ms)
N=10 (right-handed, mean age=21) Planning | Execution < Analysis Window
70 channel EEG (Biosemi) = 0c 7

512 Hz; 128Hz for connectivity Time (s)



ICA source space analysis

Independent Component Analysis

Decompose single-subject data with AMICA

Channels

Time

f@xw."]lm
xww/w--- IC2

le\f\,/w\!l\M ‘ IC3

Estimate IC equivalent dipole locations

IC1

IC2 IC3

Identify & remove non-brain artifact ICs

SISIDIE,

Blink

Saccade

L Pre-auric R Pre-auric
EMG EMG

Cortical ROIls

Group SIFT: Project ICs onto cortical
surface using LORETA; extract ROI time series.

Advantage: Same ROls for all subjects enables
statistical comparison. (Use BCILAB srcpot)
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Analysis Methods |

eSegmentation—based
MVAR

X()=), AP@OX(-k)+E@)

A(f)==),, AP M A0 =]
A(f)"=H(f)

smoothness (L2)

prediction error (preserves spectrum)

v - ey . %

4 ; ( A\
T (e A
b R J

N

regularization



Analysis Methods I

eTime-varying SADTF ("short-time
direct directed transfer function")

eDirected measure of direct
(unmediated) causal flow between
ROls

eCombines DTF and partial
coherence; windowed (0.5s, 30ms).

i (> 1) = > ki Hi(f, 7)?| P (f, 7)[2

(Korzeniewska, et al. 2008)



dDTF

Partial Coherence

[H;; (f,1)]*|Pij (f, 1)
> kipr Hia(fs 7|2 Pri(f,

g (f,t) = mIE 0

&) OB O

!

DTF* emmp3k dDTF

PR SR



Frequency (Hz)

SIFT Analysis

ACC

—h
w 3

w

eTime-varying SADTF

Directed measure of
direct causal flow
between ROIls

Averaged across
subjects



dDTF during reaching

FROM L Mot R Mot L Occ R Occ ACC L Par R Par

o 8.0 86 880 6

v
L Occ et

R Occ _1‘




Changed causal flow during reaching

FROM L Mot

&

L Par

-3
Pi) s

| Py
:-n-l- - cmy 50
R Par - — E ey 13
d Ll
J i ;l.'--"i1 L™ JlﬂlL_l- 3
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Planning Execution

50
37 |Occ -> ACC
27
~ 20
L 15
8‘ 11
" g
3 = i
0.1 0.2 0.3 0.4 0.5 0.6 0.7 0.8 0.9

Occipital 2 ACC

Time (sec)




Greater causal flow during movement planning

P Reach > Lift

B Reach < Lift




Discussion ——

R Par B Reach < Lift
{ )

SIFT is a capable toolkit for causal
dynamical analysis at source level
Parietal network expected for visually

guided action (e.g. Heider, et al., 2010)

ACC more strongly driven by Occipital & Motor. Locus for
translation of intention into action (Paus, 2001:; Srinivasan, et
al. 2013). ACC drives SMA (not shown).

Causal network results depend on the number of nodes

— E.g. Occipital 2 ACC could be mediated by region not included in
model

— There will always be a tradeoff between network size and amount of
data needed to fit the model.

— Regularization



History of group-level SIFT

* Approaches

— Tim Mullen & Wes Thompson (since 2010)
‘Hierarchical Bayesian Modeling’ that interpolate
missing values (i.e. inconsistency in dipole locations
across subjects).

* ROI-based approaches

— Iversen, et al, 2014; Courellis, et al, 2017: project IC
activation onto cortical surface and define activity in
anatomically defined cortical ROls.

— Nima Bigdely-Shamlo (in his PhD dissertation in
2014) ‘Network Projection’ that uses dipole density
and anatomical ROI. (Makoto Miyakoshi)



Source Information Flow Toolbox

Mullen, et al, Journal of Neuroscience Methods (in prep, 2012)
Mullen, et al, Society for Neuroscience, 2010
Delorme, Mullen, Kothe et al, Computational Intelligence and Neuroscience, vol 12,201 |
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PESDPDHDE

* Atoolbox for (source-space) electrophysiological information flow and causality
analysis (single- or multi-subject) integrated into the EEGLAB software environment.

* Emphasis on vector autoregression and time-frequency domain approaches

« Standard and novel interactive visualization methods for exploratory analysis of
connectivity across time, frequency, and spatial location



SIFT Workflow

Simulation >
Pre-processing

Model fitting and validation »
Connectivity

Statistics >
Locate dipoles using DIPFIT 2.x  » | Visualization >
Peak detection using EEG toolbox Help >
FMRIB Tools - T STy
Locate dipoles using LORETA b AN VAAA N AA A Smr g f A o
®SNO v12.0.0.0 WI‘WJ"“M
File Edit Imu Plot Study Datasets Help
——No current dataset

Pre-processing

- Create & new or load an existing

Use "File > Import data®™

- I:tne:flle > Load existing dataset” MOdeI Fit_ting
Import evoch info" (data and Va”dation

Import event info* (continucus
Dataset info"™ (add/edit

"File >
“rile >
"Edit >
>

“File Save dataset™ (save dataset!

- Prune data: “Edit > Select data” COnneCtiVity

- Reject data: "Tools > Reject

BulepolN

- Evoch data: "Tools > Extract evochs”
~ Remove baseline: "Toocls > Remove

- Run ICA: “Tools > Run ICA"

Statistics

Group Analysis Visualization




Help

Change sampling rate
Filter the data 13
Re-reference

Interpolate electrodes

Reject continuous data by eye

Extract epochs
Remove baseline

Run ICA
Remove components

Automatic channel rejection
Automatic epoch rejection

Reject data epochs (2
Reject data using ICA >
Cleanline

SIFT 3

Locate dipoles using DIPFIT 2.x >
Peak detection using EEG toolbox

FMRIB Tools >
Locate dipoles using LORETA

v

Component(s) to remove from data:

(_Hop

Component(s) to retain (overwrtes "Component(s) to remove"”)

| Cancel JI| Ok |

8, 11,13, 19, 20, 23, 38, 39

W

Flaase confiem. A you Sure you want 10 nenows These comporents?

[ Cecel ] [P EFey Pict s traiq
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Preprocessing: SIFT

A6 AB v1s.0.0.0D
File Edit Plot Study
Change sampling rate
Filter the data
Re-reference

Interpolate electrodes
Reject continuous data by eye

Extract epochs
Remove baseline

Run ICA
Remove components

Automatic channel rejection
Automatic epoch rejection
Reject data epochs

Reject data using ICA

CleanlLine

Locate dipoles using DIPFIT 2.x
Peak detection using EECG toolbox

FMRIB Tools
Locate dipoles using LORETA

Data;ets

>

v

¥

v

Help

Simulation
Pre-processing
Model fitting and validation
Connectivity

Statistics

Visualization

Help

1)
2 R

e
B -i=

¥ Miscellaneous
VerbosityLevel 2
VariableNames
ResetConfigs
¥ Filtering
DifferenceData
¥ Detrend
DetrendingMethod
¥ Piecewise
SegmentLength
StepSize
Plot -
AmplitudeErwvelope =
™

=

linear

® @

0.33
0.082

¥ Normalization
¥ NormalizeData
Method

time; ensemble

SignalType

Type of signal to analyze. If 'Components’, data in EEC.icaact will
be processed. If 'Channels' EEC.data will be processed. If "Sources'
EEC.srcpot will be processed.

. Help | . Cancel ‘IOK'I
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4

Fil

Model Order

Selection

Help

Change sampling rate

Filter the data

Re-reference

Interpolate electrodes

Reject continuous data by eye

Extract epochs
Remove baseline

Run ICA
Remove components

Automatic channel rejection
Automatic epoch rejection
Reject data epochs

Reject data using ICA

CleanLine

Locate dipoles using DIPFIT 2.x

Simulation
v Pre-processing

¥ Modeling Parameters
¥ ModelingApproach
Algorithm
WindowlLength
WindowStepSize
TaperFunction
NormalizeData
¥ Detrend
DetrendingMethod
SetArgDirectMode
ModelOrderRange
Downdate
InformartionCriteria
¥ Miscellaneous
RuninParallel
¥ PlotResults

PercentileLimits
VerbosityLevel
¥ Data Selection
WindowSamplePercent

OptimalMode 5electionMethod

Segmentation VAR
Vieira—Morf

rectwin

constant

[130]

o @ @&

shc; aic; fpe; hg

@]

0.35
0.03

Algorithm

Algorithm: Vieira-Morf

Description:

Model Order Selection

Peak detection using EEG toolbox

Connectivity Fit AMVAR Model
EMRIB Tools p  Statistics »  Validate model
Locate dipoles using LORETA »  Visualization "1
\ Help >

el Dl Ve VYV U INJTITV Y 7NV ) WUl e ) fmTded ) 1D e ) J
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{'File Edit View Wnsert Tools Desktop Window Help
» DaWde b K109 ¢ -2 080

Mean Info, Critenia across sampled windows
Optmal order determmed by mn of mean
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5 Model Fitting

4 & =i |\
¥ Modeling Parameters ‘
Algorithim igira-Mort )
‘ I
| WindowLength 0.35
Wind owStepSize 0.03
A MO TaperFunction rectwin
o : : EpochTimeLimits 1
File Help WindowSamplePercent 100
:R( Change sampling rate e =
Filter the data > ¥ Detrend E
ciieseea Re-reference DetrendingMethod constant
| Interpolate electrodes ¥ Miscellaneous -
I Reject continuous data by eye Timer =
n:u_u SetArgDirectMode a
Aochs Extract epochs VerbosityLevel 2
e Remove baseline
Sampl ModelOrder
Run ICA VAR model order.
Remove components
Automatic channel rejection :
. N Help Cancel ‘ oK |
Automatic epoch rejection e - —
Reject data epochs - . 4
Reject data using ICA »
CleanLine
Simulation [

v Pre-processing

Locate dipoles using DIPFIT 2.x Model fitting and validation

v Model Order Selection
Peak detection using EEC toolbox

Connectivity Fit AMVAR Model
EMRIB Tools p  Statistics »  Validate model
Locate dipoles using LORETA »  Visualization -1
{  Help >
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Simulation =
v Pre-processing
Model fitting and validation

Model

> Model Order Selection
+ Fit AMVAR Model

1 Ta Connectivity

val I d atl on Statistics [ Validate model
Visualization >
Help >

B4 @ =
¥ Validation Methods
¥ CheckResidualWhiteness
SignificancelLeve|
MultipleComparisonsCorrection
NumberOfAutocorrelationLags

| WhitenessCriteria __________[Ljung-Box; ACF; Box-... [l RET R0
¥ CheckResidualVariance v M AcF
NumberOfAutocorrelationLags 30

| CheckConsistency | M Li-McLeod
CheckStability E
v : n ; -Caﬂcel @
WindowSamplePercent 70
¥ Miscellaneous -
VerbosityLevel 2
PlotResults o)

WhitenessCriteria
Whiteness criteria. These are the statistical tests used to test for

uncorrelated residuals

~ Help | | Cancel [ OK |

EEGLAB Workshop XXVI, Oct 15-18, 2017, Israel — Connectivity 59




Model

Validation

R.NO igure 2: RespWrong - Model Validation Results
File Edit View Insert Tools Desktop Window Help o R
» DEde bk R 092d-4 08 =D ACEF statistic should be above this line

//
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/  Connectivity

Simulation »
v Pre-processing
Model fitting and validation »

Statistics »
Visualization [
Help [

- - - - - - - - -

Connectivity estimation will require 2.7344 MB of memory (P
Make sure you have snough memory available.

-

ffDTF: Full-frequency DTF
+ PARTIAL DIRECTED COHERENCE MEASURES
POC: Partial Directed Coherence
nPDC: Normalized PDC
CPDC: Generalized Partial Directed Coherence
PDCF: Partial Directed Coherence Factor
RPDC: Renormalized Partial Directed Coherence
+ CRANCER-CEWEKE CAUSALITY MEASURES
CCC: Cranger-Ceweke Causality
+ SPECTRAL COHERENCE MEASURES
Coh: Complex Coherence
iCoh: Imaginary Coherence
pCoh: Partial Coherence
mCoh: Multiple Coherence
+ SPECTRAL DENSITY MEASURES
5 Complex Spectral Density

@ @ -«
v Connectivity Estimation E— s
ConnectivityMeasures ADTF. dDTFOS. nPDC. S R 2
¥ Options nDTF
squaredModulus o ,g dDTE
ConvertSpectrumToDecibels ot R
Frequencies 1:40 Q dDTFO8
¥ Miscellaneous ':- fOTF
VerbosityLevel 2 L PDC
r = nPDC
ConnectivityMeasures T cpPoc
Select measures to estimate. E e
Measures are categorized as follows: ! RPDC
+ DIRECTED TRANSFER FUNCTION MEASURES | GGC
DTF: Directed Tranfer Function [ ] Coh
nDTF: Normalized DTF ] iCoh
dDTFO8: Direct DTF (with full causal normalization) ) mcoh

‘

i
I
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g Visualization: B @ - -
Time-Frequency Grid

Simulation
v Pre-processing

Model fitting and validation
v Connectivity

Statistics

Visualization
Help

@

¥ DisplayProperties
¥ |[MatrixLayout Partial

UpperTriangle dDTFO8
UT_ColorLimits 100
LowerTriangle dDTFO8
LT_ColorLimits 100
Hagonal 5
D_ColorLimits 100
AllColorLimits 99.7
TimesToPlot [-0.826171875 1.060... |
FrequenciesToPlot [1:40) B
PlotContour H
. — PlottingOrder |
Time-Frequency Grid | SourceMarginPlot dipole
BrainMovie3D Nodelabels 0
EventMarkers {0, 'r."". 21
Frequencyscale linear
Colormap [000.50666666666...
¥|Thresholding
¥ |Thresholding Simple
PercentileThreshoid [97.5 3]
AbsoluteThreshold |

¥ Miscellaneous
DipolePlomngOptms
"lirequencvlularkers

FrequencyMarkers [3 7 15]
FrequencyMarkerColor [0.7 0.7 0.7) p
¥ TextAndFont I

Tl B TE -t o

Baseline
Time range of baseline [Min Max] (sec). Will subtract baseline from
each point. Leave blank for no baseline.

| Help Cancel oK
O —
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ERSP on diagonal
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following the event

Figure §.
File Ect View Mnsert Toolk Deskop Window Help
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Baseline Time-varying net Granger causality
(integrated over frequency)
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K Figure 3: Subj eb79. Cond (RespWrong).
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MO BrainMovie3D Control Panel

Visualization:
Causal BrainMovie3D

File

4.

FooterPanelDisplaySpec

A

DataProcessing

ConnectvityMethod

MovieTimeRange

FrequenciesToCollapse
FreqCollapseMethod
TimeResamplingFactor
subtractConditions

Baseline

Y — .
LisplayProperties

ShowiNodelabels
NodelLabels
NodesToExclude

EdgeColorMapping

EdgeSizeMapping

NodeColerMapping
NodeszeMapping

BackProjectToChans

v B8 v, T

dDTFO8

[-0.826171875 1.0

1:15
max

PeakFreq
Connectivity
Outriow
Power

I

!

0

ICA ERPenvelope |

1;2; 34,5, 6. 7
Al; A2; AG; A7 AB

Configure footer panel displayed at the bottom of the

figure

If 'off', don't render footer. If 1CA_ERP_Envelope’,

then display the ERP envelope of backprojected

Preview BranMovie
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