EEG Preprocessing

Importing data, rejecting data, and performing ICA decomposition

EEGLAB Workshop XXVI
Ben-Gurion University, Be'er-Sheva, Israel
Day 1

John lversen
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Installing EEGLAB and data folder

4 » \
o
Cente

Computational
Neuroscience

Start Matlab
* Add only the top-level EEGLAB folder to your Matlab path:

[ 4\ MATLAB R2013b .. (==
@ "Lﬁ A '_{:; ; s@ @ E @I Search Documentation ,OB
t{}[‘ EB] _\:i o rdfies &] Ejﬁ u'j; New Variable [j Analyze Code i @ (*% Community
= £ Open Variable v {57 Run and Time : 'S} Request Support
New New Open | | |Compare Import Save ~ = Layout glsapam Help
Seript v v Data Workspace (/) Clear Workspace v [ Clear Commands v v ¥ GPAddOns ¥
FILE VARIABLE CODE ENVIRONMENT RESOURCES ,
@ 5% L » C » Users » marissa » Documents » MATLAB v
Command Window (O Command History ®
(2_5 New to MATLAB? Watch this Video, see Examples, or read Getting Started. X é_ %_:u;.j. .:;;‘;;:; 5:45 =
I f& >> addpath('C:\Program Files\MATLAB\R2013b\eeglablil 0 5 4b'); eeglab
--EEG
+EEG.history
?'eeg_eventtypes

r~eeg_eventtypes (EE
~-geglab redraw

3-%$---11/15/2013 8

134

}'eeglab
:~EEG.history

m

i~ EEG.comments
:EEG.history
“-EEG

|| Ready
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The EEGLAB Matlab software
e 3
-

Cente
Computational
Neuroscience

main graphic interface

4\ MATLAB R2013b

- - a (=)
HOME PLOTS APPS @ &ﬂ 0 ij;j ' 9 @_ E @J‘iearch Documentation Pq
Lﬂ EE? \_j o ries & ‘[:TE& Lfz, New Variable ]j Analyze Code e @ (*% Community
E_j Open Variable v éf Run and Time 3 _‘? Reguest Support
Nev_u New Open =) Compare Import Save = 5 Layout @ Set Path Help
Script v v Data Workspace [/, Clear Workspace v |77 Clear Commands v v v O JAdd-Ons v
FILE VARIABLE CODE ENVIRONMENT RESQURCES »
& 5 5 ﬁ , » C: » Users » marissa » Documents » MATLAB v RO
Name » @) New to MATLAB? Watch this Video, see Examples, or read Getting Start] EEGL-AB VILO‘S,Q - i"?%!
%) pathdef.m fx >> eeglag; File Edit Tools Plot Study Datasets Help N
I ___No current dataset
| - Create a new or load an existing
Use "File = Import data" (new)
Or "File = Load existing dataset" (old)
. - If new.
"File = Import epoch info" (data
| "File = Import event info" (continuous
"Edit > Dataset info" (add/edit dataset
"File > Save dataset" (save dataset)
- Prune data: "Edit > Select data"
- Reject data: "Tools > Reject
' - Epoch data: "Tools = Extract epochs"
- Remove baseline: "Tools > Remove
-RunICA: "Tools = Run ICA"
_!"— 11719 4w Ye3w L ‘—' —
Details A I < | (TTe— » '
L Ready
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The Goal of Preprocessing

Create a complete EEGLAB data set with
— EEG

— Channel Locations

— Events

Preprocess the EEG data to yield optimal ICA
decompositions

— Rereferencing

— High Pass Filtering

— Remove bad channels, noisy segments of data
Run ICA decomposition

— See the next two lectures...
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N ——

“Secrets” to a good ICA decomposition

"

» Garbage in... garbage out (it's not magic)

» Remove large, non-stereotyped artifacts

» Do you have enough data? (based mostly on time, not frames)

» High-pass filter to remove slow drifts (no low-pass filter needed)

» Remove bad channels

» Data must be in double precision (not single)
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| Many Preprocessing Options
-

<~ Resources
— EEGLAB wiki “Quick Tutorial on Rejection”

* http://sccn.ucsd.edu/wiki/Quick Rejection _Tutorial

— Makoto’s Preprocessing Pipeline (Day 3, 12:30)

e http://sccn.ucsd.edu/wiki/Makoto%27s preprocessing _pipeline

— EEGLAB Plugins:
* Miyakoshi’'s trimOutlier plugin
* Mullen's cleanline plugin
« Kothe’s clean_ rawdata plugin (ASR)

— Bigdely-Shamlo et al (2015): PREP Pipeline
* PREP plugin
« http://dx.doi.org/10.3389/fninf.2015.00016
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Pre-processing pipeline

Collect high-density N\ ) | Import event markers —
; . Import into EEGLAB “ )
EEG data (>30 chan) ﬁ/ port! ‘1/ and channel locations /

e I | Vo

N

Re-reference/ \ ngh pass filter "\, , .

:> down-sample ﬁ/ (~.5 -1 Hz) ﬁ/ Examine raw data . /

(if necessary)

\:

—> Identify/reject Reject large artifact N

bad channels ﬁ/ time points j/ Run ICA
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Importing a dataset

Import epoch info
Import event info

Export

B EEGLAB v1105.4b
File | Edit Tools Plot Study Datasets Help N
Import data ) Using EEGLAB functions and plugins

Computational
Neuroscience

From ASCII/float file or Matlab array

Using the FILE-IO interface
Using the BIOSIG interface

Troubleshooting data formats...

Load existing dataset =l

Save current dataset(s) h info" (data

Save current dataset as info" (COﬂtlﬂUOUS

Clear dataset(s) 0" (addled!t dataset

Create study > (save dat?m)
= > Select data

Load existing study > Reject

Save current study > Extract epochs"

Save current study as v "Tools > Remove

Clear study 3 > Run ICA" ,/

Memory and other options |

History scripts »

Quit

From Netstation .mff (FILE-IO toolbox)
From Netstation binary simple file
From Multiple seg. Netstation files
From Netstation Matlab files

From BCI2000 ASCI file

From Snapmaster .SMA file

From Neuroscan .CNT file

From Neuroscan .EEG file

From Biosemi BDF fi SIG toolbox)
From Bicsemi BDF and EDF files (BDF plugin)
From EDF/EDF+/GDF files (BIOSIG toolbox)

From ANT EEProbe .CNT file
From ANT EEProbe .AVR file

Tip for Biosemi users:
Use the ‘BDF plugin’ version
of the Biosemi BDF/EDF importer

From BCI2000 .DAT file

From BIOPAC MATLAB files

From Brain Vis. Rec. .vhdr file

From Brain Vis. Anal. Matlab file

From CTF folder (MEG)

From ERPSS .RAW or .RDF file

From INStep .ASC file

From 4D .mdd pdf file

From Procom Infinity Text File
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Sample data: basic P300 paradigm
-

-

File
SimpleOddball.set

Data
68 channel EEG, 256 Hz sampling rate, Biosemi
system, re-referenced during import to averaged left
and right mastoid electrodes

Task
speeded button press response to star shape (no
response to circle shape), 100 ms presentation
duration, 200 trials
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Load a dataset
(B ecatze vizos 0 )

Center for
File | Edit Tools Plot Study Daf Cﬁmputaﬂ?nal
Import data )
Import epoch info !
Import event info !
Export ¢
\\Load existing dataset)

Save current dataset(s)

Save current dataset as

Clear dataset(s)

Create study

Load "SimpleOddball.set"

Load existing study

Save current study
Save current study as

Clear study

Memory and other options

History scripts
Quit
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Imported EEG data

1 Ar I A n vy ' | ol [V VAR
| Auf M LA \ VMLA A Vi 1 . P

N “." |
W ‘ v Center for
Compulan’onal

Neuroscience
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‘ EEG structure

EEGLAB Workshop XXVI, Oct 15-18, 2017, Israel
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— VAKIABLE ¥
= = 51 &[4/ » Users » jri » Documents » matlab » matlab > -
A
>> EEG i) ;
EEG - s 3
Neuroscience
struct with fields:
setname: 'Simple Oddball'
filename: 'SimpleOddball.set'
filepath: '/Users/jri/Documents/ Research/Presentations/EEGLAB/2017 EEGLAB Israel/E..'
subject: ''
group: "'
condition: ''
session: []
comments: [19x53 char]
nbchan: 66
trials: 1
pnts: 85504
srate: 256
xmin: @
xmax: 334
times: [1x85504 double]
data: [66x85504 double]
icaact: []
icawinv: []
icasphere: []
icaweights: []|
icachansind: []
chanlocs: [1x66 struct]
urchanlocs: []
chaninfo: [1x1 struct]
ref: 'common'
event: [1x260 struct]
urevent: [1x261 struct]
eventdescription: {'* '' ''}
epoch: []
epochdescription: {}
reject: [1x1 struct]
stats: [1x1 struct]
specdata: []
specicaact: []
splinefile: "'
icasplinefile: ''
dipfit: []
history: '..'
saved: 'yes'
etc: [1x1 struct]
datfile: 'SimpleOddball.fdt'
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Comments and dataset history

A% Swartz £/
g C “
3 *- '4 é:(me::umlonal
' Neuroscience
Bl EEGLAB v11.0.5.4b =] - B Read/Enter comments -- pop_comments()
File | Edit | Tools Plot Study Datasets Help Ny .
About this dataset

Dataset info

Event fields Data recorded by Marissa Westerfield -

Erentuakies Recording date: Oct. 14, 2011

About this dataset | Paradigm:

Channel locations -Participant looked at fixation box in center of

screen
Select data -Two types of stimuli (outline of a circle, outline

of a star) were presented in the fixation box in

Select data using events
9 random order

Select epochs or events -Participant pressed a button in response to the star
i Copy current dataset S s codaan
Append datasets 1 = circle
2 = star
Delete dataset(s) S —
Visually edit events and identify bad channels ! Recording information:
Ddasel SIZE (IU) 2O -reference electrodes were placed on right and left
) mastoids (data has already been referenced and the
i mastoid channels have been removed)

@ 1
Processing steps:

AISO: | high-pass filter - 0.5 Hz
Cleanline applied to 60, 120 Hz

>> EEG.comments i

>> EEG.history
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Pre-processing pipeline

Collect high-density N\ ) | Import event markers —
; . Import into EEGLAB “ )
EEG data (>30 chan) ﬁ/ port! ‘1/ and channel locations /

e I | Vo

N

Re-reference/ N High pass filter Remove line noise N ——

- down-sample _
\ > (if necessary) ﬁ/ (~-5-1Hz) ﬁ/ (if necessary) — /

\:

—> Identify/reject Reject large artifact N

bad channels ﬁ/ time points j/ Run ICA
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Import data events

<

\3_ | —— c&::v;;uutknal
‘%:‘? Neuroscience
EEGLAB v11.0.5.4b Lo S
File | Edit Tools Plot GStudy Datasets Help > [ "
| —  Import events from Matlab array or ASCII file
Import data 1l
Import epoch info d I °
Import event info ) From Matlab array or ASCII file 3 / L 1K) I m por‘t from Presenta“on eve nt f||e
/
Export ) From data channel . .
— | : :  Import events from E-Prime event file
Load existing dataset From Presentation .LOG file d .
Save current dataset(s) From E-Prime ASCI (text) file L* Import events from Neuroscan event file
Save current dataset as ‘ From Neuroscan .ev2 file p - S
Clear dataset(s) ' L(;UOOO Extract event from channel(s) - pop_chanevent() -y l&l_@_J&J
! Create study » | 333996
s et sty b Event channel(s) 73
Save current study No (labels only)
Save current study as No Preprocessing transform (data="x) Optional. Ex: X=3
Clear study | 25.7 Transitions to extract? (up|down) ' 0 + | (click to select)
Memory and other options | Transition length (1=perfect edges) 0 ‘
—_———
History scripts > Assign duration to each events? ] (set=yes)
Quit
Delete event channel(s)? V] (set = yes) y
Delete old events if any? V] '
(Often imported automatically All events of same type? ] '
during data import) I‘ Help | Cancl | ok |
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Figure Display Settings Help

Scroll activity — eegplot()

Scale
50

3 B 7 ]

Chan. Time YValue

=
CLOSE Event types
ypes| ==l =l [ 4 | =l == 1 g1gts a1as7 | 50 |
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Imported data events

| L aM AL A AT YVAT) ' AN N i\ / Yo | A P
\ f L A NI Y AN TYTNAY, WA RV, LAY N A i . o / AN )
I\ ) [V W WWV Al v VAL ) VoIV PR W Vi, WA 1wl o (A | AW oo AN Mo /1wy | L\ ’ N\
f - .Y VWA LA gl WA N

| File Edit Tools Plot Study Datasets Help

wA WM MY T

\ | v b VA I Swartz

W ‘ 1 Center for

Compulational
Neuroscience

If event import was
successful,
you will see an

appropriate

number here
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Import channel locations

Opt. head center
Rotate axis

-17.926
0.51499
80.7684
26.133
-4.0011
17.926
-2.698
85

Transform axes

Dataset info
Event fields
Event values
About this dataset
Channel locations
Select data
Select data using events
Select epochs or events
Copy current dataset
Append datasets C = 7]
Delete dataset(s)

Visually edit events and identify bad channels

Xyz -> polar & sph.
Sph. -> polar & xyz
Polar -» sph. & xyz

Set head radius
Set channel types
Set reference

. -
_nsetchan |5 <« |8 < [ 1 || > [1 > | Appendchan |

| Nosealong+x  v| _Plot3D(xy2)
Read locs help Look up locs Save (other types)| |

7 file formats supported
(Polhemus, BESA, ...)

use BESA file for 4-shell dipfit spherical model -

use BESA file for 4-shell dipfit spherical model

use MNI coordinate file for BEM dipfit model

Use spherical file with eye channels

P— — .
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Import channel locations

| \ i M A M \
A AN A n VW, M A TS T
| \ Ma . N LANYVA! . A A \ A /A | [
N “'.« YA b . N My M L \ ) ) f TALRATY / \

Center for
Compu(a!ional
Neuroscience

LEYE
-45.1543
0.54374
0.79487
0.79917
-0.15585
45.1543
-7.8725

Opt. head center ]
==

Xyz -> polar & sph. |

Sph. -> polar & xyz

Palar -> sph. & xyz

Set head radius
‘Set channel types
Set reference

W

Delete chan

BN [y ETETON
BT

Insert chan

| Heb | Cancel] ok |
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B Edit channel info -- pop_chanedit()

HEOG
42
0.65556
56.7734
50.2186
-39.9051
42
-28
85

Opt. head center
Rotate axis

Transform axes

Center for
Compulational
Neuroscience

Xyz -> polar & sph.
Sph. > polar & xyz
Polar -> sph. & xyz

Set head radius
Set channel types
Set reference

_nsetchan | <«< || < || & | > | > | Appendchan |

file fdt View Insett Tools Deskiop Window Help
NDEde | M RAOPEL- 08| e

NEde | M AAONDRL- 2|08 ad

Channel locations

IR
B ¢
PR4
RS oF 9

66 of 72 electrode locations shown
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Imported channel locations

B J 1 AR 2 no IV M N MY A

" | ame Mt N Won o M | | [ \ \

n A Ma A A ATV . ' \ A A M vy - U L A , 0 f /

(- /\rA f\ L fn A A AN YN VY ey My \ P\ ,‘1‘ I Mg Y || Y| A il T LT AT AT 1 l M| \‘l‘fr A ) TR
UM Nl W VW v V L/ vV Wh | Wi v VUM o 2 WA, P N LA 7 AN N b o v NN A MW W
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Pre-processing pipeline

Collect high-density N\ ) | Import event markers —
; . Import into EEGLAB “ )
EEG data (>30 chan) ﬁ/ port! ‘1/ and channel locations /

e I | Vo

N

Re-reference/ N High pass filter Remove line noise N ——

- down-sample _
\ > (if necessary) ﬁ/ (~-5-1Hz) ﬁ/ (if necessary) — /

\:

—> Identify/reject Reject large artifact N

bad channels ﬁ/ time points j/ Run ICA
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Re-reference data (if necessary/desired)

f M MUY AL L AL AT T T PR VI Rl ." L A\, N1 ) m | "*"»‘ [ | )
\ ‘,/‘\‘f"“‘ “H"“‘ ‘\L“' N ,“"'\ { \WJ VO ,“‘,“ VW ““'- AU VRV ‘«“ A Vv VLY w,-“’ _j‘\ vy WA v \ r “"Hl ‘v"y“v‘ (3"“3 “‘ 1 ""i‘:ll""‘_“‘ ,“_.._.‘ "w“ J“.‘ l‘\‘“ | v Il ! "",‘:“.‘";u‘."“- r,x‘v“”\' N ‘,“l“ ‘\.Cl 7,“ \“4‘ W rw‘"w,\ j‘”‘,“ 1\ ,“:-‘f‘?‘"‘\ /\ J
\ PAILATR A P : Y W U W A S "“ f \~ LA UL ‘ I Swartz
‘ W ‘ .'g‘ Center for
Compulational
Neuroscience

| EEGLAB v10

Change sampling rate
Filter the data

: Re-reference frpmw—

Interpolate electrodes

Re-reference to

(e.g.) 'linked mastoids’

Extract epochs

Remove baseline
Run ICA

Remove compone

Automatic channe

Automatic epoch i

Reject data epochs

Reject data using I
NFT plugin

SIFT
: . Cancel 5 - RMAS
Locate dipoles usir - LMAS

Peak detection usi/™

FMRIB Tools
Locate dipoles using LORETA




Re-reference data (if necessary/desired)

| A M Aa M
I A\ AL AT A L VAT

Plot Study Datasets Help

Change sampling rate
Filter the data 4

‘ Re-reference 1 opt

Interpolate electrodes

Reject continuous ¢

Extract epochs
Remove baseline
Run ICA

Remove compone

Automatic channel

Automatic epoch rf

Reject data epochs

I
-]

VEOG HEOG
|

_ Cancel | Ok |

Reject data using I
NFT plugin
SIFT

Locate dipoles usin

Peak detection using

FMRIB Tools
Locate dipoles using LORETA




On Average Referencing

In theory, positive and negative
current across entire head
should balance—no net current
source or sink: Average
referencing enforces this.

In practice, depends on
distribution of electrodes.
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Save new dataset, keep old one

Swartz

Center for
Compulational
Neuroscience

SimpleOddball continuous reref Edit description
= Browse

C:\Users\marissa\Desktop\EEGLABwork mm
. Ok

@ 0@ EE LAB /19.X \s:,_
File Edit Tools Plot Study Datasets Help

Savein: | ), MATLAB

x| «BEerEr

= | Name i Date modified Type
S & external 11/10/20095:54 AM  File folder
| functions 11/10/2009 5:50 AM  File folder
|| B e 11/10/2009 552 AM  File folder
Desktop | sample_data 11/10/2009 5:52 AM  File folder
ﬂ sample_locs 11/10/2009 5:52 AM  File folder
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A NI VW n 4 [ A T A M
| Bon ™M NP W AN N WA U W A ;| Il [ A Lo
U WAL Al AV

W, o \ WA AW AN TWIN W N Yy M VA’ (I myi MY YWA A 2 WA M ah | A VA “""r M\ AN AN | \
A TUAN \ N ILIWaWA VW 4 v viel YW - VAR AN v VAN A W VYT PN LI AWt Viaa /L 7 Lalln A\ Al 2 |
W AN A A A YV | V e \[© O Ly y AV g WS ey Y Wk AW WV N W M Ao

Multiple active datasets (ALLEEG

Dataset 1:Simple Oddball
v/ Dataset 2:Simple Oddball continuous reref

Select multiple datasets
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Resample data (if desired)

Reason: Reduce space, time. But keep nyquist and

Computational
Neurosclence

ICA data length requirements in mind...

B CE0LAS 110540 " — -

File Edit | Tools | Plot Study Datasets Help N
#2: Change sampling rate F reref
Filter the data »

- =
Re-reference Resample curr... | ) [

NN N S e
Interpolate electrodes

Reject continuous data by eye New sampling rate
Extract epochs b ‘ 256| |
Remove baseline I

Run ICA Help| Cancel| Ok I

Remove components

e _ 4

Automatic channel rejection

Automatic epoch rejection

Reject data epochs ’ l
Reject data using ICA »
Locate dipoles using DIPFIT 2.x » ’

EEGLAB Workshop XXVI, Oct 15-18, 2017, Israel — John Iversen — Preprocessing

28



Remove unwanted channels

|\ M Aa IV
A M AN A\ n Vi, 1"‘ A W Il A
o AMa NV VY W e, PTVAY | I N TA TN | B I I AN p W | | ) y N ™M
A MGV TN Yy A wy MM VANYSW /AT W VWA N, A ML an ] N LR AT N\ \ | M
N WtV Al v VPEYL Y VA W i M P T L Y R T Y Y PP YA N 1| Y
W | V A wh N AV S WS T S LA 7 AN N T A \

' nN VL I N ) “ V LAY v
1| N A T V " \W \ | Y\ o v V JN Y WY WA Y
W v W ! VNN W VoY | T |

(tional
icience

Dataset info
Event fields
Event values
About this dataset
Channel locations
Select data
Select data using events
Select epochs of )

Copy current da
Append dataset|

EXG5 EXG6 EXG7 EXGS8
Scroll dataset

Cancel || Ok |

- —
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Pre-processing pipeline

Collect high-density "\ i " |Import event markers
| rt into EEGLAB
EEG data (>30 chan) / mport into — / and channel locations /

| p.
_ - | <
N / \ )

STOP!

Re-reference/ | Saveyourcontinuous N R y :
> down-sample dataset here ‘ e’_‘:°"e ine noise
g (if necessary) * ﬁ/ (if necessary) — /

(at least!) r
| \ y, )
—> Identify/reject Reject large artifact ‘
—y bad channels —1/ time points _,/ Run ICA
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‘\ EEG.history

EEG = pop_readbdf('C:\Users\...\tb stars 199.bdf', [1 334] ,73,[65 66] );
EEG.setname="'Simple Oddball';

EEG = pop_select( EEG, 'nochannel’', {'EXG1"' 'EXG2' 'EXG5' "EXG6' 'EXG7' '"EXG8'});
EEG = pop_chanedit(EEG, 'lookup',..

EEG=pop loadset('filename','SimpleOddball.set', 'filepath', 'C:\\Users\\marissa\\D
esktop\\EEGLABworkshop\\Data\\");

EEG.comments = pop_comments('', '', strvcat('Data recorded by Marissa
Westerfield'..

EEG = pop_selectevent( EEG, 'type',[1l 2 201] , 'deleteevents',6 'on');

Today

EEG = pop_loadset('filename', 'SimpleOddball.set’',
'filepath', '/Users/jri/Documents/ Research/Presentations/EEGLAB/2017 EEGLAB
Israel/EEG _data/"');
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Pre-processing pipeline

Collect high-density N\ ) | Import event markers —
; . Import into EEGLAB “ )
EEG data (>30 chan) ﬁ/ port! ‘1/ and channel locations /

e I | Vo

N

Re-reference/ N High pass filter Remove line noise N ——

- down-sample _
\ > (if necessary) ﬁ/ (~-5-1Hz) ﬁ/ (if necessary) — /

\:

—> Identify/reject Reject large artifact N

bad channels ﬁ/ time points j/ Run ICA
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High-Pass Filter the data

) M Ko, v I '
o [N A n vy ' | At v N | f\ . \
A /Ma (LM I AAY 1\ 'Y \MA N ALY . | | N \ [ ) A NYW N A
ol N WA WA TN T Y ANy N 7 \/ Wi ,‘1 VIR LR AL MU WA BV (T | A Ao AN M ) e AN A BN | ‘»‘,’c“_ “‘, M e

AN, oV e iy v Mo e \ | vV AV P WS sy WA LA WA N o Ml N "\" | m A g W

LA Y , Vo ! VW VAW W) Y U <. arte
! 1/ W

A ‘ 1 Center for

Computational

Neuroscience

Reason: remove slow, possibly large amplitude, drift

PP —== — - I ¥ i
3 ': V} 0.5.4b — __':'._A._El_';—«wx 2 1 ilte data '_‘_-‘{o_‘:\inﬁug\é'

Change sampﬁng rate
Filter the data ) ’ Basic FIR filter

Re-reference ERPLAB Butterwort]
Interpolate electrodes ERPLAB Polynomia

i

| File  Edit

High-pass

Reject continuous data by eye Short non-linear IR} :
Extract epochs ‘
: needed
Remove baseline 1
Run ICA ‘
o for ICA
Remove components ‘
Automatic channel rejection | ( :
Cancel || Ok
Automatic epoch rejection | | _ :
Reject data epochs e _ info -- pop_newset() , y : ‘_ X0
Reject data using ICA » i g -

Locate dipoles using DIPFIT 2.x dl
Peak detection using EEG toolbox
FMRIB Teools

Locate dipoles using LORETA »

SimpleOddball hipass0.5 Edit description 1
file Browse

v

CleanLine

[ ok .



Pre-processing pipeline

Collect high-density N\ ) | Import event markers —
; . Import into EEGLAB “ )
EEG data (>30 chan) ﬁ/ port! ‘1/ and channel locations /

e I | Vo

N

Re-reference/ N High pass filter Remove line noise N ——

- down-sample _
\ > (if necessary) ﬁ/ (~-5-1Hz) ﬁ/ (if necessary) — /

\:

—> Identify/reject Reject large artifact N

bad channels ﬁ/ time points j/ Run ICA
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Edit Tools Plot Study Datasets Help

Import data
Import epoch info
Import event info
Export

Load existing dataset
Save current dataset(s)

Save current dataset as
Clear dataset(s)

Create study

Load existing study
Save current study
Save current study as
Clear study

Manage plugins i i |
anage deactivated plugins

Memory and other options

History scripts
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Remove line noise (Cleanline)

\ “, Swartz
Center for
Compulational
Neuroscience

0546 .
Change sampling rate

Filter the data >
Re-reference

Interpolate electrodes

Reject continuous data by eye
Extract egchs P o ot s Channels
Remove baseline 1dices of C als/Cc one 1e "1-66'

Run ICA L ength (sec) L C4 D
Remove components i i AR AR D

Automatic channel rejection “
Automatic epoch rejection
Reject data epochs 4 ‘
Reject data using ICA 4 S€
Locate dipoles using DIPFIT 2x V(s
SE

Peak detection using EEG toolbox
FMRIB Tools »
Locate dipoles using LORETA »

CleanLine
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Plot channel spectra

| ( Il Swartz

\ ‘ 1 Center for

Computational
Neuroscience

| File Edit Tools [Plot| Study Datasets Help

Channel locations

Channel data (scroll)
Channel spectra and maps

Channel properties

Channel ERP image
Channel ERPs »
ERP map series L
Sum/Compare ERPs

Component activations (scroll)

‘freqrangel[2 9] )
_Cancel | Ok |

Compoenent spectra and maps
Component maps 4
Component properties
Component ERP image

Component ERPs »

Sum/Compare comp. ERPs

Data statistics 4

Time-frequency transforms »
Cluster dataset ICs

EEGLAB Workshop XXVI, Oct 15-18, 2017, Israel — John Iversen — Preprocessing 38



.

N
«

0.5 Hz high-pass filter

Filter comparisons

0.5 Hz high-pass filter
50 Hz low-pass filter

AL
T
Swartz 750/
CEI‘I(!I'

Computational
Neuroscle"ce

0.5 Hz high-pass filter
Cleanline

r — - — r=— 5 E = —1,
n pop_prop() - Channel 31 properties - LEM i pop_prop() - Channel 31 properties E@[ﬂ - pop_prop() - Channg! 31 properties LEIM
File Edit View Inset Tools Desktop Window Help > File Edit View Inset Tools Desktop Window Help ~ File Edit View Inset Tools Desktop Window Help Y
= D @ | | = S @ | 1 Y 5 ® & LlE
NDEdde | M| AKOOLR L -2 |0E | D DEHe | M ARRIQDLL-2|0E | =D DEdde | b|RKROVE,L- 2|08 aDd
Channel 31 Continous data Channel 31 Continous data Channel 31 Continous data
5 . 394 - - 37.8 EAE e 386
! i = | W7 - ~ | s P ~o | M3
%) e Cvaltiy T I b 1] w P e R 0 e --*:-‘-_
| 100 SRS = 0 = 100f- - . 0 2 100~ B T 0
= g o 2 = = R s o
x 197 \ e = 189 | = e 193
[t s B b 394 e e 378 P15 B R S 386
100 200 300 400 100 200 300 400 100 200 300 400
Frames Frames Frames
||
< Activity power spectrum < Activity power spectrum < Activity power spectrum
l ; L ; 20 I~ [ ;
o o o
> 10 > > 10
- \_j; o I —
| & < &
(o)) 0 - ()] [} 0 -
2 S -20+ o
o (=) =
et o
s -10f = 40 = -10F
% | | | | g 1 | 1 1 % | | | |
il o 20 40 60 80 a 20 40 60 80 o 20 40 60 80
Frequency (Hz) Frequency (Hz) Frequency (Hz)
= S = —

EEGLAB Workshop XXVI, Oct 15-18, 2017, Israel — John Iversen — Preprocessing

39




~\‘nd

<

B ecGLas V110,540 " —

Scroll channel data

Computational
Nel’roscle"ce

File Edit Tools

Plot] Study  Datase

_ #3: Simg

Filename: n
Channels p¢
Frames per
Epochs
Events
Sampling ra
Epoch start
Epoch end {
Reference
Channel loc
ICA weights
Dataset siz¢

Channel locations

Channel data (scr
Channel spectra 3
Channel propertig
Channel ERP ima(
Channel ERPs

ERP map series

Sum/Compare ER

Component activ
Component speciy
Component mapy
Component prop|
Component ERP ii
Component ERPs
Sum/Compare cg
Data statistics

Time-frequency t
Cluster dataset IC

L

u Scroll channel activities -- eegplot()

Figure Display Settings Help

1
1

EESEDENSESRELEEERFEN] !i’S!( ISEEELSEERSERDS
’5

,}%
E

bt A A ety i P Scale

CANCELI Event typesl == =l 0 | = ==

Chan. Time Value
Fp1 93.5349 -1.2558

45

EEGLAB Workshop XXVI, Oct 15-18, 2017, Israel — John Iversen — Preprocessing

40



Scroll channel data
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Collect high-density
EEG data (>30 chan)

Pre-processing pipeline

N

_T// Import into EEGLAB //

Import event markers
and channel locations

Re-reference/
| _\/ down-sample
(if necessary)

High pass filter

‘—v/ (~5 -1 Hz) r—v/
\

_( STOP!

Save your dataset

N

—\, Identify/reject
bad channels

here; if you epoch

Remove line noise
(if necessary)

before ICA you can
import ICA weights to
\ this dataset later

—W/ time points —,/

Run ICA
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Data Cleaning for ICA

Variant 1: Continuous Data
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Pre-processing pipeline

Collect high-density N\ ) | Import event markers —
; . Import into EEGLAB “ )
EEG data (>30 chan) ﬁ/ port! ‘1/ and channel locations /

e I | Vo

N

Re-reference/ N High pass filter Remove line noise N ——

- down-sample _
\ > (if necessary) ﬁ/ (~-5-1Hz) ﬁ/ (if necessary) — /

\:

—> Identify/reject Reject large artifact N

bad channels ﬁ/ time points j/ Run ICA
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Retrieve or reload continuous EEG dataset

B EEGLAB V11054 : (SRR

| File Edit Tools Plot Study ||

Dataset 1:SimpleOddball hipass0.5 CL

| Dataset 2:5impleOddball nontargets rej
| vV Dataset 3:SimpleOddball targets rej

Select multiple datasets

Import data
Import epoch info
Import event info
Export

Load existing dataset

Save current dataset(s)
Save current dataset as

Clear dataset(s)

Create study

Load existing study
Save current study
Save current study as
Clear study

Memory and other options

History scripts

Quit

I Swartz
Center for
Computational
Neuroscience
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B Manually identifying bad channels

u Scroll channel activities --
Figure Display Settings Help
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Manually identifying bad channels

Channel spectra and maps -- pgg_spectopoo

o | B |3

Epoch time range to analyze [min_ms max_ms]:
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Manually identifying bad channels
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Auto-detection of noisy channels
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Plot Study Datasets Help
Change sampling rate

Filter the data

Re-reference

Interpolate electrodes

Reject continuous data by eye
Extract epochs
Remove baseline
Run ICA
Remove components

Automatic channel rejection
Automatic epoch rejection
Reject data epochs 14
Reject data using ICA »
Locate dipoles using DIPFIT 2x P |
Peak detection using EEG toolbox

FMRIE Tools 4
Locate dipoles using LORETA P

- WA Il Swartz

Center for
Compulational
Neuroscience
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Auto-detected noisy channel
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u Scroll component activities -- eegploti
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Removing channel(s)
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Event fields
Event values

About this dataset [
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Channel locations

Select data Selectdatain:  Inputdesivedrange | enremovett |f not checked, will result

Select data using e
Select epochs or e

in dataset with one channel
o

<P TN

Copy current datas
Append datasets
Delete dataset(s)

Visually edit events|

=)

SimpleOddball hipass0.5 CL - F6 'Edit description
Browse

__Help | _Cancel | ok |||
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Removing channel(s)

You may want to interpolate bad channels rather than
remove them altogether. Don't do this!

The loss in dimensionality will affect the ICA
decomposition

Preferred solution:

— Delete the bad channels before running ICA
— STUDY tools will interpolate missing channels automatically
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Pre-processing pipeline

Collect high-density N\ ) | Import event markers —
; . Import into EEGLAB “ )
EEG data (>30 chan) ﬁ/ port! ‘1/ and channel locations /

e I | Vo

N

Re-reference/ N High pass filter Remove line noise N ——

- down-sample _
\ > (if necessary) ﬁ/ (~-5-1Hz) ﬁ/ (if necessary) — /

\:

—> Identify/reject Reject large artifact N

bad channels ﬁ/ time points j/ Run ICA
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Reject continuous data
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Change sampling rate

Filter the data

Re-reference

Interpolate electrodes

Reject continuous data by eye
Extract epochs

Remove baseline

Sum/Compare ERPs

Component activations (scroll)

Run ICA

Remove components

Component spectra and maps

Component maps 4
Component properties

Compaonent ERP image

Automatic channel rejection

Automatic epoch rejection

Reject data epochs
Reject data using ICA

Componzant ERPs 4

Sum/Compare comp, ERPs

Data statistics

Time-frequency transforms
Cluster datasetICs

Locate dipoles using DIPFIT 2.x
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Reject continuous data
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Rejecting data for ICA

To prepare data for ICA:
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Figre Diplay Setings Hep

Computational
N euroscienc

Reject large muscle or
otherwise strange events...

Keep

127 Bsmmm e gt

P trema e A

A MA
pesmanedqn N

e e Ny

At AN,

r T
Foosmar: N-\'V.N\/WV\

... but keep stereotyped

artifacts (like eye blinks) +——

i
4493 A

wwmmw».»w%

AN AA i W‘wm

“"MWWM'\M'“WWW
e W o TR
WM»*‘%
IR N e

|

EEGLAB Workshop XXVI, Oct 15-18, 2017, Israel

I mE - EE -

et

1 1 1 1
44 495 4%

Chan. Tare Viahoe

5023519 87

L P AN it TN | W R H t
90 g P ___{Rejec
G VL s WO SRV st SN U S S g A

e e AL A AT N L e piseni o

T L S U v oy PO e

PR W(“'?\: ot : -y

W
s LA R ) ,»\./“w’ﬂ\\m

N R U PNV e e A R

T aari e e A F h‘

Mo A AN A SN g, L AP i

oA PP A i NN A h ~

AL TN L A p P

Lo oAy A -~h~M/’""\~““"‘\\ﬂ,ww

et A i e TG L (gt "y
AT b NN —v'\./\- W e ey

e Ao e SRS o ’\ /‘w ~
I S :‘:««.f'—w-, MmN

MWWWMWNW/NMWNWMQ

R A PN I b AN A, el ‘\,;MWWM"W

W"va.ﬁ”

Ao ,.,MMMW*“\M
O hitariin s T SRV LR Ponay
1 N e e W 4 \ T
S
S it ST, S "‘\»M“IWW
g e L RIS

At |

[w | =il
=

‘é%
g
D)

)

Scale

O G aaa W PIRECTE R
e e e B W

e
AL W RSP SRR “',
e 1)

)

)

23

z
)

L 11
499 500 L

— John lversen — Preprocessing

e

56



Fast (but sloppy) artifact rejection

Scroll channel activities -- eegplot()

R

iter:
ymputational
leuroscience

Figure Display [Settingﬂ Help

Zoom off/on

Events

i

Time range to display

Channel labels

Number of channels to display

> —

Change windo.:L‘:’ (= lﬁl

New window length (s):
30

Help] Cancel| Ok |

Scale
I - 1
o8 . ; . . -+
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Chan. Time Value =1
CANCELl Eventtypes| <= &| o |z 35| i - REJECT
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Fast (but sloppy) artifact rejection
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Data Cleaning for ICA

Variant 2: Epoched Data
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Extract epochs
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Filter the data »
Re-reference
Interpolate electrodes
AT Reject continuous data by eye
EPOC ™ Edractepochs |

Remove baseline

RunICA

Remove components

Automatic channel rejection

Automatic epoch rejection

Reject data epochs 4

Reject data using ICA 4 |

Locate dipoles using DIPFIT 2x ~ » B Extract data epochs - pop_epoch()
Peak detection using EEG toolbox
FMRIB Tools 4

Locate dipoles using LORETA 4

CleanLine

T —

Computational
Neuroscience
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Extract epochs

Center for
Compu(a!ional
Neuroscience

SimpleOddball nontargets Edit description
Browse

g Epoch baseline removal - pop_rmbase()
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Select a subset of epochs
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Select data
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ame i SimpleOddball target epochs Edit description e ot b
Vo >ave as file Browse ‘ SC:,:::' for

Compulational
Neuroscience

‘Do not overwrite Save it as fe:
current dataset’ [ Cancdl W Ok |
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REC X
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Scroll (epoched) channel data
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Reject epochs with artifact

) Scroll channel activities —— eegplot()

Figure Display Settings Help
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Reject data epochs

File  Edit

—#1: 1

Filenz
Chan
Fram:
Epoct
Event
Samp
Epoch
Epock
Avera
Chan
[CA w
Datas

Plot Datasets

Help

Change sampling rate

Filter the data

Re-reference

Reject continuous data by eye

Extract epochs
Remove haseline

Run ICA
Remowve components

Automatic epoch rejection
Reject data epochs

Reject data using ICA 4
Locate dipoles using BESA »
Locate dipoles using DIPFIT 2.x  »
Laplacian 4
FMRIE Tools »
Grand average datasets »
Locate dipoles using LORET A 4
PCA plugin »

Reject data (all methods)

Reject by inspection

Reject extreme values

Reject by linear trendfvariance
Reject by probability

Reject by kurtosis

Reject by spectra

Export marks to ICA reject

Reject marked epochs

Computational
Neurosclence
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Reject data epochs

Center for

ALY W I(,\j ‘\‘\,,‘;AJ' Py MY

Computational
Neuroscience

“\a W ’Vh 1“.‘ 1
\ UM AV
Vi ‘.J“” W Y

Reject trials using data statistics - pop_rejmenu()

Scroll Data

visual | G

inspection | e

5
1:31

Calculate | Scroll Data
L ] L ]

Calculate |

Calc { Plot |

Show all trials marked for rejection by the measure selected above or checked below
W Abnormal trends

W Abnormal appearance M Abnormal values
M Improbable epochs W Abnormal distributions

Close (keep marks) | Clear all marks | Reject marked trials

WM Abnormal spectra




Reject data epochs
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Reject data epochs

Computational
Neurosclence

File  Edit Plot Datasets Help N
e Change sampling rate L
—#1: , N

Filter the data »

Eilen Re-reference d

Chan Reject continuous data by eye

Frams  Extract epochs

qucl’ Remove baseline

Event

Samp Run ICA

EPOCP Remove components

Egocl‘ Automatic epoch rejection

Avera

Chan Reject data epochs Reject data (all methods)

ICAW  Reject data using ICA »|  Reject by inspection

Datas Locate dipoles using BESA 13 Reject extreme walues
Locate dipoles using DIPFIT 2.x » Reject by linear trend/variance
Laplacian » Reject by probability
FMRIB Tools » Reject by kurtosis
Grand average datasets > Reject by spectra
Locate dipoles using LORETA > Export marks to ICA reject
PCA plugin 3 Reject marked epochs
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Visualize ERP in rectangular array

N s@i
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Channels pe Channel properties : : ‘ :
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Plot title SimpleOddball nontargets rej ' 4 1
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Visualize ERP in topographic array

-\ - o/
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Cente

Computational

Neuroscience

EEGLAB v11.0.5.4b EEER
File Edit Tools [Plot| Study Datasets Help ~ Figure 2: plottopo()
__ #5: Simg Channel locations > 8 ‘ File Edit View Inset Tools Desktop Window Help ~
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Visualize ERP scalp distribution

ERP data and scalp maps -- pop_timtopo()

=aa=l X"

Plotting time range (ms):
Scalp map latencies (ms, NaN -> max-RMS)
Plot title:
Scalp map options (see >> help topoplot):

ERP data and scalp map:
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NaN
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Computational
Neuroscience

Help | : &
Figure 2: timtopo() - = |6
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Channel data (scroll)
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Epoch end ( Component activations (scroll)
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Visualize channel ERPs in 2D

EEGLAB v11.0.5.4b

File Edit Tools

__#4: Simp

Filename: n
Channels pe
Frames per
Epochs
Events
Sampling ra
Epoch start
Epoch end (
Reference
Channel loc
ICA weights
Dataset siz¢

Plot ERP scalp maps in 2-D -- pop_topm);o_ - ‘_ ~r Lﬂm
Plotting ERP scalp maps at these latencies 25:25:300 ol
(range: -102 to 996 ms, NaN -> empty): S
Plot title  p———
Plot] Study  Datd Hi de s .2 R — .
s - File Edit View Inset Tools Desktop Window Help N
Channel locatigf S S Addiional ) S W & | K (AR ODE L£-E|0EH | O
Channel data (3
Channel spectr|
Channel prope( Help
Channel ERP in|
Channel ERPs 4 \,
ERP map series ;
Sum/Compare ERPs
Component activations (scroll) I
Component spectra and maps
Component maps »
Component properties
Component ERP image
Component ERPs > AN
Sum/Compare comp. ERPs
Data statistics » 16.2
Time-frequency transforms » 8.1
Cluster dataset ICs 0
-8.1
-16.2
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Visualize channel ERPs in 3D

- Figure 2 — —

File Edit View Inset Tools Desktop Window Help N
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B EEGLAB v11.0.5.4b =B
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e Channel data (scroll) Odde ’ I ‘ QK {ﬂ?@ s - ' = [ 0 Ed ‘ o0 et I
Filename n Channel spectra and maps 130 ms ‘“y
Channels p¢ Channel properties _
Channel ERP image il . g -
Channel ERPs .

ERP map series

Sum/Compare ERPs

Component activations (sv:roII| '
Component spectra and maps

Component maps

219
10.9

Component properties

| Component ERP image i
t I Component ERPs

-10.9
-21.9

Sum/Compare comp. ERPs

Data statistics

Time-frequency transforms ‘bts
Cluster dataset ICs Ll
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Pre-processing pipeline

Collect high-density N\ ) | Import event markers —
; . Import into EEGLAB “ )
EEG data (>30 chan) ﬁ/ port! ‘1/ and channel locations /

e I | Vo

N

Re-reference/ N High pass filter Remove line noise N ——

- down-sample _
\ > (if necessary) ﬁ/ (~-5-1Hz) ﬁ/ (if necessary) — /

\:

—> Identify/reject Reject large artifact N

bad channels ﬁ/ time points j/ Run ICA
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Exercises (optional homework)

* Preprocess data of your choice or load a
previously filtered dataset e.g. faces 4.set

* |dentify bad channel(s) using auto-detection tool;
plot channel properties of flagged channels

* |dentify and remove non-task portions of
continuous data; see if the previously flagged
channels are still identified as bad

« Epoch on event of interest. Scroll the epoched
data and perform visual rejection of epochs

* Explore the automated artifact rejection tools
* Run ICA
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