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The EEGLAB Matlab software

."v-t

:"5‘,

)

Computational
Neuroscience

main graphic interface

EEGLARE Shell - Konsole

Session Edit View Bookmarks Settings Help

|| @

Jhome/arno> matlab -nodesktop
< MATLAEB >
Copyright 1984-2002 The MathWorks, Inc.
Version 6.5.0.180913a Release 13
Jun 18 2002

Using Toolbox Path Cache. Type "help toolbox_path_cache" for

For product information, wvisit www.mathworks.com.

>> eeglabl]

To get started, type one of these: helpwin, helpdesk, or demo.

.

File Edit Tools Plot Study Datasets  Help

—MNo current dataset

- Create a new or load an existing dataset:

Usze "File > Impeort data” (e
Or "File > Load existing dataset” (old)
- If new,

"File = Import epoch info" (data epochs) else
"File = Impert event infe" (continueus data)
"Edit > Dataset info" (addfedit dataset info)
"File = Save datazet" (save dataset)
- Prune data: "Edit > Select data”
- Reject data: "Tools > Reject continuaus
- Epoch data: "Tools > Extract epochs”
- FBemowe baseline: "Tools > Remowve
- Fun ICa:  "Toaols > Run [CA"

e

60 menus, more than 300 Matlab functions and more than 50,000 lines of code
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Importing a dataset

Swarz 5
Center for

Campul.ubnal
Neuroscience

-Edit Toaols  Flot Studs Datasets  Help |

_ From ASCIffloat file or Matlab array \

IFOTREHLL NI - Fraom continuaows or seg. EGl . EAW file
Itnport event info “ From Multiple seq. EGI . RAW files
Export -

Frorn BCIZ2 000 ASCH file

Load existing dataset
SAwE CUFFent datasetis)

Fram Snapmaster SkA file

From Meuroscan .CHT file
Sawe clrrent dataset as
From Meuroscan (EEG file

Fraom ERPSS EAMW or .EDF file

Zlear dataset(s)

Create study - F Bi i .BDF fil ing BIOSIG
rom Biosemi . ile usin
Load existing study Heing EEGLAB supports many
Save Current stud From other formats using BIOSIG
’ From ANT EEProbe .CNT file different raw data formats
Sawe CUFrent studsy as

From AMT EEFrobe AYE file

. From Brain %is. Fec. whdr file
Memary options
- From Brain %is. Anal. Matlab file

Sawe histom =
- From CTF folder (MES)
Lt
From IMatep  A5C file
Fram b awa MEF files
From 40 .mdd pdf file
Troubhleshooting, other data formats. .. }

Clear sty
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Imported EEG data

nce

EEGLAB v5.03

File Edit Tools Plot Siudy  Datasets  Help
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| The example data: faces vs. objects
-

File
../data/faces_3.set
Data

33 channel EEG, nose-tip reference, 250 Hz
sampling rate, 0.5-100 Hz, 16 bit, BrainAmps

Task
speeded discrimination between objects and faces,

500 ms presentation duration, I1SI 500-1900 ms,
362 trials
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Comments

Read/Enter comments - pop_comments()

About this dataset

Data acquirad by, Stefan Debener
Data acquired on: Oct 15, 15974

Data:

33 channel EEC
nose-tip reference
sampling rate: 250 Hz
filtared: .5 - 100 Hz
1& bit, BrainAmps

Task:

speedead discrimination betwean objects and faces
500 s prasantation duration

[5] 500-1300 ms

362 trials

CAMNCEL

SANE

)

File

)

Computational
Neuroscience

EEGLAB v5.03 -

Edit  Tools Plot Siuchy Datasets  Help

Dataset info
Ewent fields
Ewvent walues
About this dataset
Channel locations

linuous

choplEffaces _3.5at
33
133735

Select data
Select epochsfevents

1
F3Z

Copy CUrrent dataset
Append datasets
Delete dataset(s)

250

0,000
534,936
M

Channel locations

|CA weights
Dataset size (Mb)

feas

fag
3E.&

R
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Re-reference data

Center for-
Computational

Neuroscience

L
..%)’:

) EEGLAB v5.03 - x

File Edit [ Tools Plot Datasets  Help
#1 I Change sampling rate

L Filter the data - . .

S — Specify the reference scheme of imported data

Filenz Feject continuous data by eve =8t
Chan tial ref f
Frarm. Extrarct Initial reference - pop_reref()
Epoct
Evant THIS SCREEM |15 USED TO EMTER CURREMT REFEREMCE AMD WILL QMUY APPEAR OMCE
SAMp RUM ICA | _lUata are in average raterance |
Epoct OFR
Epoct Femowe

W Diata ara referenced to one site (default)

B Relect g Feferance channel numberis), if present in data (default: O |

Chan  |ocate g

A w
Locate q .
Datas 21| R a2ty e Radius
Locate g .
_|Includea current refarenca channel in data | | |
Laplaciz Maote: by including a reference channel in your data (abowve), its potential may be computed when
FMEIE Tl wol re-refarence the data. If wou hawve polar coordinates of the reference channel, enter them abowe;
If the dataset has no channel locations wet, wou may leave the label and location fields empty;
Grand If wou have 3-0 location coordinates only, then Cancel and create a new channel 34
Locate q in Edit = Channeal locations, Then return to Tools > Re-rafarance,
PCA plu
Cancel | Healp | Ok
- .
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Rereferencing, cont'd

~

Computational
Neuroscience

) pop_reref - average reference or re-reference data - 00X

Currant data reference state is: commaon
¥ Compute average reference | Two re-reference choices:
_|Re-referanca data to channeal number(sh:
N | 1) Average reference
[Hetar tan inelude eurrent refErenee h mew reference, inelwde chanhel S8 akeys 2) NeW Channel (S)
_| ) pop_reref - average reference or re-reference data - 0O/X
R |
\“ Cancal Current data referance state is: commaon
\ _ICompute average reference
‘\ R Fe-raferance data to channel number(s: | 1&
\‘ _|Retain reference channels in data {if more than onea)
1 [ater te helude s urrami refErenee in mevw eferanee, inelude chanmnel 4 aboys
\

Must specify in
first re-ref GUI

> _|

Cancel Help Ok

EEG = pop_reref( EEG, 16, "refstate”,0);
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1

I Save dataset with .set extension — pop_saveset() X

Filter

Save new dataset, keep old one

Dataset info — pop_newset() -

What do you want to do with the new dataset?

Mame it | facas_3_continucus rereferanced Edit description |
W Saveitas fila: | Browse |

Some changes have not been saved. What do you want to do with the old dataset?
_ | Owerwrite it in memory (set=yes; unset=create a new dataset)

fila: | Jhome/julie/workshoplb/faces_3.sat |

el | Help | Ok |

fhumefjuIieMurkshopDEf“.se{

[ALLEEG EEG CURRENTSET] = pop newset(ALLEEG,..
"setname”, "rereferenced data");

EEG, 1,

DliEctonies Files : File Edit Tools Plat Datasets  Help |
Fhomerdjulied shopOEs faces_d.set [—
‘homedjuliesworkshop OB faces_d4.set . .
thomedjulievorkshapiBampfigs —#2: faces_2?_continuous rereferen... -
Filenamz: none
Chantels par frame 32
L Frames per epoch 133735
Epochs 1
-] | I i
Events f32
Save as type *set sampling rate (Hz) 250
Epoch start (sec) 0,000
selection Epoch end (sec) 534,936
— | Awarage referance s
fhomedjulieryarkshop N6/faces_2_rereferenced.set Ehemmal leczidens Yas
[CA weights fas
’7 Cataset size (Mb 35
Save Filter Cancel ( j

Con

Neuroscience
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'\{'g—_"-:

)
File

Multiple active datasets (ALLEEG)

EEGLAB v5.03

Edit Toaols Plat

Datasets  Help

EEGLAB v5.03 - X

Edit Tools FPlot

B e |

——+#1: faces_3_continuous

Filename: ..uliefworkshopO&/faces_3.set

Channels par frame
Frarmes par apoch
Epochs

Ewvents

sampling rate (Hz)
Epoch start (seg)
Epoch end (sac)
Avarage referance
Channel locations
[CA waights
Cataset size (Mb)

33
133735
1

732

250
0,000

534,936

M

fas

fas

35.6

——#2: faces_3_contil

Filename: none
Channels par frams
Frames per apoch
Epochs

Events

sampling rate (Hz)
Epoch start (sag)
Epoch end (sec)
Avarage refarance
Channel locations
[CA waights
Cataset size (MMb)

Dataset 1.faces_2Z _continuous

Neuroscience

v Dataset 2:.faces_3_continuous rereferenced

3 Select multiple datasets

133735
1

732

250
0,000

534,936

M

fas

ez

35
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Scroll data

Cnmpulalhnal
Neuroscience

el ar tnities — ecuphit)

Figure Display Semings  Hein

' EEGLAB v5.03 -

File Edit ngls-Stucjv Datazets  Help B B

Channel locations - ] S S S S

B02 T M W e, de AT ST o P

- 3
- - - A
B R s R

e £ e N el P

—#1: face |
- b| Chanrnel data (scrolly - L e VAN VSN U NNV NP YIS SISV
TN e s o NN et s BT N S --""'\/rv-\""\/‘--._/'.;“’”" e W
_ Channel spectra and maps w05 x---\wjj_,w--«k._V/\.,vwm.mu N e P AR S oV R P At L
Filename: ... T i B B T e e T T s A

Channel properties B Y VAP S

I e W NI o R T

Channels pe

: 808 MV M A s ot T st s, T o o o Ee
Frames per Channel ERF dagi=te]= B P ey e A wﬂ‘v\nﬂ\‘,w"-r::—-_--\ T N i Bt s oms EL

BRI A S e P e e ] e e S
L Vs SN
ey

L e S A S e

Epochs Channel ERFs =

N N Y i o D B R PN N NP o e A e
™, N
i

Events
Sampling ra

ERR mafp series
sSumiCompare ERES

Epoch start
Epoch end
Avarage ref:
Channel loc
ICA weights
Datasat size

Component activations {scrall)
Companent spectra and maps
Campaonent maps

Component properties
Component ERRE image
Compaonent ERES
SuUmiCompare comp. ERFs

"t .r‘—-,\.\,\._,\..m_,%ﬂvf\/\“f \r-\'_m.\_,.-y../\r._f‘iaJu_.1lw’\v_,ﬁM/\/\\
NI --—f“w\v-"\._r"‘\f\“‘m-\,.\,.n_/‘u"‘u"""ﬂ""“"\-“‘\m BT P
L e it W g Vs N ‘“ﬁﬁf\-\m""“’"\“‘“\v»—«m-%m i Y
15 A \'/\.-\-\’\-mm/—MN-—.W\MWM-ﬁM—AM e T v R
18N A i o P P gt B E NN AW S P i
P T S W e S
N i e e s U SPRUERUT Y ST
13 ﬂ*“‘*v-,»\.wn'M~4ﬁ\r~«/wwvr~r”“’”'rwm\J—WWH.,w-,w“ru-
020 e e ST g O I b o
021 -‘*'““\,\,\!A—mv‘\‘,w\,\f\\/"\f"\f\f“\d-w\/ﬁr\ﬁ“}“” { P AV
o "h-'"'\u‘\u"""‘"“»f'h\\_.lﬂ\‘;/\‘« _ "NV‘\_,_,WN,"\J"J\A"J‘N“ﬂ"’"’\m—m-"’*ﬂv\ﬂ\r“/\l—""
R e N A VAV s S UV YRS
28 i A TN s i gt oo Nt TN 8t

BES et e n b

ETIRRT PP P - ey E e e

wr
B e

BB P s e A sl

Data statistics

Time-frequency transforms

Awerage time-fraguency’

Mew Time-freg. transforms

U S S e e
BZB [ e i A A e i P Kt T
829 [ vl e N N AP v i e
\,n—---.*’\._.—\_‘,-\/’\/"-""\*\\ﬁu—wxz-\m"‘“\‘"'mf‘*"‘"m-hm-d,u‘v-r“v”'v-
o v"‘*“—\,-\,——»,.e““ij\\/"‘\ﬂ«"\v\_,vw'\(\/'-v"n&..mw«- trmm st A

B i s e LSRN

L L S P WS

PN A'r\_,,,__.\,\wJ\mnv.- .
i WA A oy g e
e A e N P

e A,

.

e T PN P
B s, BT Uy SV DRI .

e e N e L A
L il e W
'\\/."‘,"’\-u"m“rx’\\’\’\..,,-\ﬂ.r\-""""“"""\/"""""’(\'
n.__J\,.f\_w___J.»!\»—..‘-.\w,\;nw,,._\ S
Il N N A et gt
I Ve

s e oo, T i A o i, b i,

s i,

T e
o NSt e By et i 8

P D P

T B NP
T e
Y g

i

1 L

b e o et e e e e e

e

T T e L IRV S

i o Al s

Pt et J”"‘"\.::"—
gt
B s Gt
PSR
SRURVRVEVEV N
B e SR NE
R
Rt T
R “M’NJ‘\"L-:_
J-‘Mﬂ.‘\m/"*»\_vu_
MR N
e bt
o & s e O
e s & W
PSP
S PP P
A e A A
A AN ]

e AR ]

L "

9 ] ur

Chan.

o | [ EE -

0234

g El

Time Value

iC.]

-115 [T i REJECT

>> pop_eegplot(EEG,1,1,1);
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Scroll channel data

4 &
S———

j‘&
|

) scrll changél sctviis —esgpiotg

Figure Displa; Settings elp

L R Y PO (O N | b e et e e ]
) | | | . Lo e e
J e T L L e B R e
channels o4 IR R B A ISR S
’ 51 = ~ e
. B Pt - s e e e e m
tl m e o e T B R R e e ¥ UV CERRRIPNY o W s T R SRR
) B I P R o e T e | i I PRI W e, L SR L e
oo et e TtV e e e A T e e e A e P e A A P gy
EVe ntS 10 44 ™ I R e B i B e i PR NS
B T T e S B Ml e e e T N I e L e NI SR
12 —UMMWNWMWWMWMW e e et T e e e e
L e B o B B e T T P P L L g B R
T i e b g e e e S I e e e R i Mg
T B e e o Lo R e L e L M e Bt e
1B et e et E T i e s B s e
17 fﬂmn - D EI i s Rt e e e B B B L ST
Sec/epoch 18 M R O TR S AR | DU O PN A
19 e o e i i I U NPT S, Y VP R STV SO P AV DR Ve
20 pH A grs Tt BTNt o et M ALttt 25 ot s st st g
21 et i e L e e M B
22 Rl e T T i e e e e i
23R Rl I R T Al L e o R, B s LA,
24 H e R R LY R B N Maauw e SOV
S K At MWW A R R T P S, o
t 26 = MWWMMW B P B AL Wl Lo SN PRRe
eve n S 27 MWW\WWM R P N Sy U I, L S S IR SR
28 H MWWMM i R R e R i Le i, W S
29 b I IR i e e [, T B L T
a0 ke It e B R al |l aaana LN N WL SRR e o SRS
| 31 H R E I ket i L I Tty e S
J 32 [ B R e AN AR peler b la o, by e P AR ot s g 1,,~“,..u-~wwm~f*«m
o3 na Caua d "y Lusa M bk A . FPRPUPITE N TP by " Lt bt ot | s L a1 Y bk ool
298 216 217 218 219 2200 221 222 223 224 225
) Chan. Time Walug
CAMCEL Event types l 22 | = | I 5 j == 1 223 5405 20925 I 100 jl REJECT
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Data importing and channel analysis

Task 2
Import channel location file

Exercise...
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Import channel locations

Edit channel info — pop_chanedit()

& Channel information ("field_name™):
Channel lakal ("lakal™

Opt. head center |

Polar angle ("theta")

Rotate axis |

Polar radius ("radius")

Transform axes |

Cartesian X ("4")
Cartesian ¥ (")

¥yz —» polar & sph. |

Cartazian Z{"2")

Sph. —> polar & xyz |

Spherical horiz, angle ("sph _theta")

Polar —> sph. &xyz |

Spherical azimuth angle ("sph _phi")
Spherical radius ("sph_radius")

Set head radius |

Channel type

Set channel types |

Indesx in backup 'urchanlocs' structura

Delets chan | Channel number {of 1)
Insert chan | << | < | 1 > | x| Append chan |
Flot 2-0 | Flot radius (0.2-1, [=auta) Mose along +X | ,l Flot 3-D (xvyz) |

Read locations | Read locs help | Look up locs | Save (as .ced)

| Sawve (other types) |

i ._
S oo

Canter for-
Computational

Neuroscience

Cancel | Healp | Ok |
L x|
File | Edit Tools Plot Dataszts  Help ‘
" Datasetinfo
[ Event fields rinuaus
Ewvent values
« Use channel names and automatically sbou s dataser_ |0 /EES 5
annel locations
. . Select data | 133735
assign channel location select epochs events | 732
) . Copy current dataszet 205300
 Import channel location file sopero omasass e
| . Channel locations fes
 Modify/stretch/rotate channel locations Chweignis Yo
EEGLAB Workshop VII, Apr. 20-22, 2009, Bloomington, IN: Julie Or




Edit channel info — pop_chanedit()

Opt, head center
Rotate axis |

Transform axes

Hyz —» polar & sph, |
Sph. —» polar &xyz |

Polar = sph. & xyz

Set head radius |

Set channel types

Delete chan |

insert chan o> | Appendchan_|
Flot 2-D | Nosealong +X / Plot 3-D (soy2)
Fead locations Fead locs help Look up locs Save (as .coad) Jave (other types)

Load a channel location file

Read electrode file

aut ract

Polhemus native alp fila
BESA sphearical .elp file
Matlak =z file

BESA or EGI 3-D cartesian |

EECLAE polar loc file

7 file formats supported
(Polhemus, BESA, ...)
16




Channel information {"field_name™):
Channel lakel ("lakel")

Polar angle (“theta")

h Polar radius (Mradius")

L Cartasian ¥ ("<")

Cartasian Y ("Y")

Cartesian £ ("Z")

Spherical horiz. angle ("sph_theta")
spherical azimuth angle ("sph_phi")
Spherical radius ("sph_radius")
Channel typa

Index in backup 'urchanlocs' structure

Edit channel info — pop_chanedit()

ell

Opt. head center

a0

Fotate axis

0

Transform axes

3.7494e-33

-&,12322-17

¥yz —> polar & sph

1

Sph. = polar % Xy Channel indicas

=40

T .. EEG
Paolar —= sph. & sz ipelEg )

0

Cancel | Halp

1

Set head radius

EEG

Channel number {of 33)

< M1

) Figure 3

File Edit “iew Insert Toals Deskiop MWindow Help

Deleta chan |
Insert chan | << |
Plat 2-0 Plat radius (0.2-1, [[=auta)

Read/locations Fead locs help

= x|

Set channel types |

Append chan |

Mose along +3

Flot 3-D (eyz) |

| 7|

Look up locs |

Help

Save (as .ced)

DeWd2|( k|0 || 0E|=50

Sawa (other types)

jure 4

File Edit Yiew [nsert Tools Deskiop  Window  Help

o Channel locations

-

«230

33 of 33 electrode locations shown

Click on electrodes to toggle name/number

2009, Bloomington, IN
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Import channel locations

EEGLAB v5.03

File Edit Tools Plot Siucy  Datasets  Help

EEGLAB Workshop VII, Apr. 20-22, 2009, Bloomington, IN: Julie Onton — Data import
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Data importing and channel analysis

Task 3
Import data events

Exercise...

EEGLAB Workshop VII, Apr. 20-22, 2009, Bloomington, IN: Julie Onton — Data import
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Import data events

Neuroscience

) EEGLAB v5.03 = |/
File. Edit Tools Plot Datasets  Help .
[ Import data |  Import events from Matlab array or ASCII file
22 -
P 1tinuous | °
gt eventinfo. L from Matiab array or ASCH e ) / * Import from Presentation event file
Export ~  From data channel .
Load existing cataset Fram Presentation .LOG file J
Save current dataset(s) 1
Sawe current dataset as /32
ol 250
ear datasetis)
0,000
Create studhy - c24 936
Load existing studky Mo Extract event from channels) - pop_chanevent()
Save CUFFent study Tes
Save current study as ;;56 Event channel(s) | 34 |
Clear stuchy '
Mernary options Preprocessing transform (data="x") | Opticnal, Bo X=3
. Transitions to axtract? (up|down) M (click to salect)
Sawve history - _ -
: Transition length (1=parfact edges) | 0l
LU Assign duration to each events? ] (set=yes)
Delete event channealis)? ~4 st = yas)
Delete old avants if any? ~4
All evants of same typar N
Cancel | Help Ok |

=

EEGLAB Workshop VII, Apr. 20-22, 2009, Bloomington, IN: Julie Onton — Data import
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Scroll activity — eegplot()

Figure Display Seftings Help

CQmpul.uhnal
Neuroscience

Scale
a0

Chan. Time YWalue

E— ]
Eventtypes|™ =l B [ 4 | B Bl 1 gagis siasy [ 50 |

CLOSE |

- 0O X

— 31453929

3145743
— 3145742
— 3145741

EEGLAB| —3145733 r. 20-22, 2009, Bloomington, IN: Julie Onton — Data import 21




File

Import data events

Ediit

Tools

EEGLAB v5.03

Plot  =tucdhy  Datasets

Help

If event import was
successful,

you will see an
appropriate number

here

EEGLAB Workshop VII, Apr. 20-22, 2009, Bloomington, IN: Julie Onton — Data import
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Review event values

Cente

Ciﬁm

y S
.\Q:Q_‘_".; Neuroscience
’ EEGLAB v5.03 |
File | Edit  Tools Plot Datasets  Help |
Dataset info :
[ Event fields tinuous Delete
Ewvent wvalues
; shopOEffaces 2 sat Append event CURRENT
About this dataset 29 Event 'type' and '|atency' PP event
Channel locations 123735 ized field AFTER
Select data 1 are recognlze I€1aS current event
Select epochs/events 732
Copy CUrrent dataset
0,000
iiiﬁiiﬁ:ﬁ? 5‘134'936 Edit event field values {currently 732 events) Dialata avant |
o
Channel locations Yas Latency (sec) || 4'9_64
[CA weaights Yas Type (8 object
Cataset size (Mhb) 356 E -
vent Num
Insertevent | << | < | 2 [ > | > | Appendevent |

Insert event
BEFORE
current event

To resort: first
select Main
sorting field

Re-order events {for review only)
Main sorting fiald:
secondary sorting field:

_IClick for decreasing arder
_IClick for decreasing order

Re-sort |

Cancel | Help | Ok |
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L’:‘%:‘?

Review event values

Computational
Neuroscience

EEGLAE v5.03 - X
File | Edit Tools FPlot Datasets |
Dataset info :
[ Event fields finuous
Ewent walues
: shoploffaces 3 sat . . \ .
?E'DWT:S djfaﬂet 33 Event 'type' and 'latency
annel locations . .
133735
cotoct ot . are recognized fields
Select epochs/events 732
2ED Edit event values - pop_editeventvals()
Copy CUrrent dataset 0.000
Append datasets 534,936 Edit event field values {currently 732 events) Dalete evant |
Delete dataset(s) 1]
Channel lecations Yag Latency (sec) | | 4'9_64
[CA weaights Yas e | | object
Cataset size (Mhb) 356
Event Num
Insertevent | << | < | 2 | = | s> | Append event

Re-order events {for review only)
Main sorting fiald: latancy
secondary sorting fisld:

Re-sart |

Cancel | Help | Ok

|| _|Click for decreasing order
_|Click for decreasing order

EEGLAB Workshop VII, Apr. 20-22, 2009, Bloomington, IN: Julie Onton — Data import
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Renaming events

2 s@
& Ce

s
J

Compiafional

- Neuroscience
File | Eclit  Tools Plaot Datasets  Help |
Dataset info :
[ Event fields linuous
Ewvent wvalues I Tal ! !
Eeent vl P 1) input original 'type' code
out this dataset 23
Channel locations .
133735 ! !
S 1 2) iInput new 'type' code
Select epochsfevents 732
250
Copy current caraset | 200 3) Keep/delete all other events
Append datasets 534 936
Delete dataset(s) fl o
Channel lecations Mes
Select events — pop_selectevent() - 0O
Selection Field Descriptions Selection {value, list or real range "min==max"} If set, select
Field To edit: Edit > BEvent fields B« "Target" or 214,55 or 4.5 <= 13 all BUT these
Evant indices | 1l
latency (s) Mo description | _
Type Mo description [ bpl _
_|Salact all events MOT salectad abowve Sat this button (1o left)and "all BUT" buttons (abowe) for logical OR
Fename salacted avant typels)as type: | button 1

Fetain old avont teps fanes i aiaws hiold namead: |

|_|Kesp only selectad evants and remaove all other events |

Cancel | Help | Ok




Renaming events

- v o =
‘Q.(_:‘,_’, Neuroscience
} EEGLAB v5.03 - x
File | Edit  Tools Plot Datasets  Help |
Dataset info :
[ Event fields finuous
Ewent walues
About this dataset SZOEPDEHHCES-S'SH
Channel locations 133735
Select data
L Edit event values — pop_editeventvals()
Select epochs/events 732
250 ) )
Copy current dataset | gm0 Edit event field values (currently 732 events) Delaie =van
Append datasets 534,936 Latency (sec) | | S 724
Delete dataset(s) M Type | [ ( buttonl
Channel locations Yas
[CA weaights Yas Event Num
Prizasgs 5= (i) S Insert event | << | < | 3 [ > | > | Appendevent |

Re-order events {for review only)
Main sorting field: Fi _IClick for decreasing order

_IClick for decreasing order

Secondary sorting field:
Re-sort |

Cancel | Help | Ok |
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Alternative method for importing events:
Import events from event file

\ _— e :
N Neuroscience
) EEGLAB v5.03 - x
File . Edit Tools Plot Datasets  Help |
" Impor data P
- EEG Data Check alignment between pre-existing (old) and loaded event latencies:
| Import event info [ From Matlab array or A5CI file Old event latencies (10 first): 10789 21315 31375 41902 51962 62489 ...
Export ) .
— = Pl BEie ERine] New event latencies (10 first): 10789 21315 31376 41902 51963 62489 ...
Load existing dataset From Presentation .LOG file
Save current dataset(s) 1 Best sampling rate ratio found is 0.9999895. Below latencies after adjustment
Save current dataset as 154 Old event latencies (10 first): 10789 21315 31376 41902 51963 62488 ...
128
Clear dataset(s) 0.000 New event latencies (10 first): 10789 21315 31375 41902 51962 62489 ...
Filtar
fhomesnd eeglabfdnwnlnadf"z L Import presentation file - pop_importpres()
Directaries Filz fizld containing event types Trial =
ersieedlabidownload;. (S IDSEVES LOG Code -
wirsieeglabidawnloads’. DSEYES SMA Time
Iigigﬁl Fila fizld containing event latencies -lE—\zeZ'l; Type j
TESTEDF Time
IR GaE eeatita s File field containing evant durations _5
L Event Type
= Code
A (—( = T :
Files of type : # — MNote: scroll lists then click to select fiald
Selection
| fhomessiniresglab/download/DSEYES LOG Cancel ‘ Help ‘ Ok
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Scroll data with events

Center for
Cumpulalhnal
Neuroscience

Figure  Dizplay Setrings  Help

’ EEGLAB v5.03
File Edit Taols [ Sucly Datasets Help

Channel locations s T T N g s (R ATS LN
02 T M e e N e 2 B T

— - ] 5] o RSP P D \,I_rm e Pt
#1: faces_l Channel data (scroll) l RPNV A

N, A i et P o
o - . .,
s iy A o gttt gt

05 b g o e PN ‘/\.\“)w"/\w)ﬁ'! o A e R T N
Channel spectra and maps e T e B R (R Tt s M
F| | anarme: C a7 -"%«_«-MN-MQ,-»W»M_M ,,,,,, P L, . B L (e o S

T A L L Y
D R N

R e S

Channel properties
Channeals pa e

K e ﬁJ_rfv«y_\/ﬁ__h At

. AN N VRN
Framas per ¢ Channel ERFimage B o AN e N ST NN PN A A NNV o
Charrel ERFs 2 P NN VN A A NN TN A A e S
EF'C'ChS - PLE S \.\.\,rﬂ— “v—..\__,"\/\( i LY ,.4\,.\“_\_‘”\%/?_““_\(
Event ERP - Y ARSI AS AR AV S N gt A8
W TS A SEFeS 18 b g et gt e
5 li r H - e V/:',\,MW_«,TWMCM': - A,WM/.\_ ..... N
- mp o g s Sum’rcnmpare ERPs BT R bttt gttt o ot e

BB A g o e s e r‘*'\a‘ﬁ'\#—*“\"mwvm PRSI SR
T iie I e PWPRT w“""‘"'\f“*”‘\"""' g P et o e T ittty

Irafrenti Ao
P ,w-?(\-)m\h\_,\.‘w:

Epoch start {

Component activations (scroll o e n A P T o gl T N NN S - AP
Epoch end (s T \«,:;f\ PV NN NN Ay wy v.\;\fw_v,-:f\,':j:;\‘/f_ N Ny
Bora rage rafa Component spectra and magps [ T e \/“ AP ::"‘- N Y i i Aol gl
b g™ ,\_\‘r\/\\‘_.f\_ e f‘\_/"\,hf e N Y A et Sy L
Channel lac:  Component maps = AT AT A SN Y (DU g
B2 [ T At b T, S P fern o™=
i i [ e e S _— WP
ICAweights  component properties o A O OO et T
Dataset size . N ANV S oS VAN Ry NN
Component ERF image B A AN N N NS P A P RSP N _
o, L S L P e L IR LY RSP p|
e R i e U et o P
Companent EREs - : ~ —«ww«/ AR AN "“*M___‘MW ' T

e

SumfCompare comp. ERFs ™ T

100

Data statistics - - __ object

Time-frequency transforms .- e s ‘ aE = m.
S J

Awerage time-fregquency ~

. ~ —— bpa
Bew Time-freq. transfarms - ~

~ — bpt

~ — houndary
~
~
~
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Event durations

Figure Display Settings Helg

=

e01
ez
en3
en4
805
208
807
e08
ik}
el
el
elz
e13
eld
e1s
e16
el7
e1g

e20
ezl
ezz
e23
e24
825
8ZB
8z7
8z8
823
e3n
edl
edz
e33

Chan, Time Yalue

CAMNCEL Evant types ‘ << < o 5 >y a33 £1,7242 -13.3 70 REJECT

Scroll channel activities — eegplot) CO | O r d e n O t eS

/ event duration

7o
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Data importing and channel analysis

Task 4
Extract data epochs
Select epochs/events

EEGLAB Workshop VII, Apr. 20-22, 2009, Bloomington, IN: Julie Onton — Data import
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—#2: f

Filena
Chanr
Frame
Epoch
Eveants
sampl
Epoch
Epoch
Aveara
Chanr
A
Cratase

EEGLAB v5.03

File Edit - Plot =tuchy Datasets Help

Change sampling rate

Filter the data

Fe-reference

Feject continuaus data by eye

Extract epochs

>> eeqg_eventtypes(EEG)

Extract epochs
FEemove baseline

Feject data epochs

Fun 1CA

Remowe camponents

Feject data using 1CA

Locate dipoles using BESA
Locate dipoles using DIFFIT 1.x%
Locate dipoles using DIPFIT 2.x
Laplacian

boundary 1

bpl 183
bp4 184
face 182
object 182

FMEIE Tools

Crand average datasets
Locate dipales using LOREET A
FCA plugin

EEGLAB Workshop VII, Apr. 20-22, 2009, Bloomington, IN: Julie Onton — Data import

Extract data epochs - pop_epochi)

CQmpulalbml

Neuroscience

(use shift|ctrl to
select sevearal)

boundary

Ok ‘

Time—locki'ng avant typels ) i[=all} |

Epoch limits [start, end] in seconds |

-1%2

Mamea for the new datasert |

facas_3 epochs |

Out—of-bounds EEC limits if anvy [min max] |

Cancal | Halp

Ok |

31



Dataset info — pop_newset()

What do you want to do with the new dataset?

Extract epochs

Mame it |

faces _3 epochs

] Save it as file: |

What do you want to do with the ol
| Owerwrite it in mamory (sar=1yeas

Cancel |

>>

>>

>>

EEG = pop_epoch(EEG,{"face® "object"},[-1 2], --.
"newname” , "faces_3 epochs”, ...

"epochinfo®,"yes");

EEG = pop_rmbase(EEG, [-100 0]);

Baseline latency range (min_ms max_ny

=100 0

lowvarwritten by latency range abowe),

Elze, baseline points wector (ex: 156 (] File

Edit Tools FPlot

EEGLAB v5.03

Stucly  Datasets

Computational
Neuroscience

Help

Cancel Help

—#3: faces_3_chans removed epochs

Filenarme: nane
Channels per frame
Frames par anoch
Epochs

Events

sampling rate (Hz)
Epoch start (sag)
Epoch end (sec)
Avarage refarance
Channel lecations
[CA waights
Cataset size (MMb)

31
750
34
1500
250
-1.000
1,99
M
feas
fas
0.6

[ALLEEG EEG CURRENTSET] = pop_newset(ALLEEG,EEG,
CURRENTSET, "setname*®, "faces_3 epochs®);
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&

|
_.‘%:‘-'\:

File

Create new event field

EEGLAB v5.03

Edit | Tools  Plot
Crataset info
Ewvent fields
Ewvent walues
About this dataset
Channel locations

Datasets  Help

linuous

shoploffaces 3 sat
33
133735

Select data
Select epochs/events

1
732

Copy CUrrent dataset
Append datasets

250
0,000
>34.356

Event indices to modify

EEG = pop_editeventfield( EEG,..

Computational
Neuroscience

"indices”","1:732", "latencyinfo”", ..
[1. typeinfo”,[], "duration®,"0");
[ALLEEG EEG] = eeg store(ALLEEG,..
EEG, CURRENTSET);

Edit event field(s) -- pop_editeventfield()

Delete old events {else modify existing event indices) ?

| 11500 |Yes f MO ME: (unchecked) —» modify selectad event indices

Edit fields: Field description Values file|array Delete field

latencyis) | | Browsa | L]

typea | Browse | |

epach | Browse | _

| Response_Times | |RTs | Erowse L~ Matlab variable
Event field name | e | (Click on fiald name to salact it!)

Cancel Halp | Ok

EEGLAB Workshop VII, Apr. 20-22, 2009, Bloomington, IN:

Julie Onton — Data import
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Select epochs

) EEGLAB v5.03 - x
File | Edit = Toaols  Plat Datasets  Help |
Dataset info Centerfor
- Computational
[ Event fields finuous Neuroscience
Ewvent values
About this dataset SP-'EOEPDEHECES-E'SH
Channel locations 133735 / Confirmation
Select data 1 Warning: delete 37 (out of 3643 un-referenced epochs ¢
Select epochs,/events || 32 | Cancel | Ok
Copy current dataset st
0,000
Append datasets A

Dele | ) Select events — pop_selectevent() :Ilﬁ]wl

E:T:.fr; Selection Field Descriptions Selection (value, list or real range "min=<=max"} If set, select
Datasa Field To edit: Edit = Ewent fields Ex: "Target" or 2:4,5 or 4.5 <= 13 all BUT these
Evant indices | O]
latency (ms] Mo description || _
— Ty Mo description | face | 1
epach Mo description | _
_|Selact all events MOT selectad above Set this button (to left)and "all BUT" buttons (abowve) for logical OR

Fename selected avent typels)as type: |

Retain old event type name(s)in (new) field named: |

_|Keep only selected events and remowe all other events
M Remove epochs not referenced by any selected event

Cancel | Halp | Ok

>> EEG = pop_ selectevent(EEG, "type",{"face"}, ...
"deleteevents”, "off", "deleteepochs”,"on");
>> [ALLEEG EEG CURRENTSET] = pop newset(ALLEEG,EEG,4, ...
"setname”, "faces only epochs");



4 &
—_——

.‘.H‘.;ér-:‘)'.'

) Dataset info — pop_newset()

What do you want to do with the new dataset?

Mame it: face epochs Edit description |

W Saveitas file: | Browsa

What do you want to do with the old dataset {not modified since last savedl)?
] Crvarwrite it in memory (set=yas; unsat=create a new dataser)

“Do not overwrite

current dataset”

Cancal | Healp | Ok

Ce

Compiafional

Neuroscience

e

Save dataset (optional)

Filter
| — |3 7
- BELAE 450 |fhnmefjuliefwnrkshupﬂﬁf".seg
File Edit Tools FPlot Datasets  Help |
" Import data M Directories Files
Irmoart enoch info 5 — i Suliedwarkshop0es. faces_3.set |—
Imzun EEEnt info g Or save Iater from menu fhomesduliefwarkshop0gs.. faces_d4 set
-
fhomesduliefwarkshop06ampmigs

Export -

33
Load existing dataset 7L
Sawve current catasetis) 267
Sawe current daraset as 1103 | |

250
Clear dataset(s

&) =-1.000 ] [ [ [ i

Create stuchy - 1.998
Load existing study Mo Save as type set
Save current study Tes _

fas Selection
Sawve CUrrent studsy as 53 ¢
Clear stuchy ' fhomesdjuliefworkshopl6face_epochs.set
Memary options )
Sawe history - Save Filter Cancel
it
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File

Ediit

Tools

Flot

5t

| Datasets| Help

Dataset 1:.faces_2 _continuous
v Dataset 2:face epochs

Select multiple datasets

New dataset
created
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Data importing and channel analysis

Task 4
Channel analysis
Exercise...

EEGLAB Workshop VII, Apr. 20-22, 2009, Bloomington, IN: Julie Onton — Data import
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File Edit Tools

—#2: face-

Filename: n¢
Channels pe
Frames per ¢
Epochs

Events

Sampling rat
Epoch start (
Epoch end (s
Average refe
Channel locs
ICA weights
Dataset size

Analysis of ERPs

ERP data and scalp maps -- pop_timtopo()

Plotting time range (msh

scalp map latencies (ms, Mah -> max-REMS)
Flot title:

scalp map options (see » > help topoplot)

—-200 7396

165 |

ERP data and scalp maps of f

>> pop_timtopo(EEG,[-200 796],[165], "ERP data and scalp maps”®);

Datasets Help »
Chensel locations N Cancel | Halp | Ok, |
Channel data (seroly |
Channgl specira and maps
Channel properties 165 ms
Channgl BRF image 1]
ERF map saries | I sCalpreth. array
sumfCrmpare ERFS I FEdt. arFas
Component activations (scroly
Component spedira and maps
Component maps 4 10
Component properties
Componsnt ERF imags - 5
Compensnt BRFs e
Sum/Compare comp. ERPs 3
Data statistics »|s O
Time-fracuency transforms » §
AVRFA0R UMMR=TrEcueEncy L .5
Chpstar clatasst ICs

_10 L




Analysis of ERPs

] EEGLAE vE.0b
File Edit Tools B D=ztasets Help k]
Chaningl 1pgaipns 2
—3#2: face
Channgl daia (2ol
Channels pe.  Chanigl propeies
Frames per Channgl ERP 1maag
Epochs —
Events -
Sampling rat  ERP ma sevies v
Epoch start FumfComparg ERPy I Pl SV
Epoch end ( )
Average ref Compengnt gtationg (eovell
Channel loc COMPpEngT FREtE at Wb
ICA weights COmponent s k
Component ERP imane =
Componen ERPs L
FumfCompare comp, ERPg
Dtz sratighics k
Time=fregquenty wansforms [
Ayerans ime=frenguents
Chagter darapes 108

Center for
Cumpulalhnal
Neuroscience

eO? o 92?

el? h*hghﬂ Hfﬁﬁ%ﬁ
KA

els 1
whbc | 606 03l
624 -\.A,DW 01 -Hﬁ\—,( g2
e14

&fig

673 913
% 12 % 'H&T“
el2
e31 % -—H{ﬁv e29

-12.1

928

5

-200 796
Tirne (ms)
39
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EEGLAB v 0

Analysis of ERPs

File

Edit Tools

—#2: face -

Filename: nc
Channels pe
Frames per ¢
Epochs
Events

Datasets Help

Sampling ra
Epoch start
Epoch end (
Average ref:
Channel loc
ICA weaights
Dataset size

Channel data Sonll
Channel spedua and maps
Channel propesiies
Channel EEF mnaoe

EREF map series
S fCompane ERPs

Channel ERPs 3

[ ]

Campul.ubnal
Neuroscience

Cosmgrosnerit cihaions (ool
Coinpoanent spedira and maps
COTPONer maps

CORTI OGRS [ Deriies
Component ERP image
Companesn ERPs
SumfCompane cong. ERPs

Tiith =calp maps
In scalpfiedt. anvay

In rect. array

Daia siatisiics

Time-frequenty ansiormns

Axverage dme-ireguency
Chesier dataset ICs

EEGLAB Workshop VII, Apr. 20-22, 2009, Bloomington, |

el

el2

el3

el

els

elf

ey

elsg

el

e10

11

212

el13

e14d

els

el6

543

face ERP
I 618 —me—pmn
et == 019 sttt
. 820 —
I e21 e O
I ell o
t~ e el3 =
A — 024 bt o gy
P e25 e S
e 626 o
pome e 037 + T e
e 028 i
1 e29 -
== 030 2y
e 831 ——f—41; "
e Y L b AR
s — 633 J R
I A -200 Time {(ms) TH6




~

File Edit Tools

Filename: ne¢
Channels pe
Frames per ¢
Epochs

Events

Sampling rat
Epoch start (

Average refe
Channel lecs
ICA weights
Dataset size

—#2: face—

Epoch end (g

Datasets Help

Analysis of

Channel lpcations

Channel data (scroll)
Channel spectra and maps
Channel properties
Channel EFP imq,gq
Channel ERFg

sumfCompare ERPs
Component activations (scroll)
Component spectra and maps
Component maps
Component properties
Companent ERP imq,gq
C‘,qmnqnqnt ERPi
sumfCompare (omp, ERP;
Drata statistics
Time=fregueandy transforms
Average time=Treguengy

Clustes elatazet [Cs

»

ERPs

Flot ERP scalp mapsin 2-0 -- pop_topoplot()

Plotting ERP scalp maps at these latencies 025200

frange: —200 to 796 m=, MNahl -=> ampty):

Flot ti Oms 25 ms 50 ms
Flot g

-z Ad

In §=D

‘

200 ms

face

>>pop_ topoplot(EEG,1,[0:25:200], "face",[3 3],0,"electrodes”, "off");
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-~

.': ‘U—"‘_f
Y

File

—#2: face—

Edit Tools

Filename: ng
Channels pe
Frames pear ¢
Epochs

Events

Sampling rat
Epoch start |
Epoch end (¢
Average refe
Channel loc:
ICa weights
Dataset size

Analysis of ERPs

Datasets  Help

Channel locations 3

Channel data (scroll)

Channel spectra and maps
Channel properties

Channel EEF image

Channel ERPs b

sumjiCompare ERPs

In 2-D

Component activations (scroll)
Component spectra and magps
Companent maps ]
Component properties

Component ERF image
Component ERPs ¥

SumyCompare comp. ERPs

[Crata statistics 3

Time-frequency transforms 3

Ayerage time-fregquency
Cluster dataset [Cxs

>> pop_headplot(EEG,1,[0:25:200], "ERP scalp maps”®,[3
"electrodes”™, "off");

-10] x|
File Edit ‘“iew Insert Tools Desktop Window Help &
Ded&E yaaNe e 0a sa
125 ms
Plotting ERP s -t
{range: 200t
Oms
...‘. v’i
TSms
B Az 19E: 7
)
150 mw: 175 ms 200 ms
= :
4
:
A0 gt C
P / -4
ey :
-8
[RP scalp maps of face
3], - ..
42
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Compare ERPs across conditions

—C
.

EEGLAB v5.03

B o |

File Edit Tools Plaot

Select 'object’

Filename: none

epochs and e
create new et
sampling rate (Hz
dataset Epocph StQart lizel:cj j

Epoch end (sac)
Avarage refarance
Channel [ocations
[CA waights
Cataseat size (M)

—#4: faces only epc

Daraset 1:faces_Z _continuous

Dataset 2:faces_3 _chans remowed
Dataszet 2:faces_2_chans removed epachs
Dataset 4:faces anly epochs

a
7 v Dataset 5.objects onky epochs

2 Select multiple datasets
10&3

250 1 '
~ o0 How do 'face’ and

1.996 ‘object’ ERPs differ?
N
‘r':;z
fes
49.9

>> [EEG,ALLEEG,CURRENTSET] =

"retrieve”,3, "study”,0);

pop newset(ALLEEG,EEG,4, ...

>> EEG = pop_ selectevent(EEG, "type”,{"object"}, ...
"deleteevents”, "off","deleteepochs™,"on");

>> [ALLEEG EEG CURRENTSET] =

pop newset(ALLEEG,EEG,5, ...

"setname”, "object only epochs*®);
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Compare ERPs across conditions

Centerfor
Computational

Neuroscience

EEGLABR va.0b

File Edit Tools B Datasets  Help
8 T COmPare RS Y
—#1:
from two conditions

Filena avy. std.  all EEPs

Chant Datasats to avarage (ex: 1 3 41 | 4,5 B B N

Frarme Datasats to avarage and subtract (ex: 56 7 | n n ]

Epoch Plot differance N N N

Ewants

Samp Channels subset (J=alll |

Epoch Highlight significant regions (.01 -> p=.01) |

Epoch Lse RM3 instead of average (check): B

g:farnar Lo pass (Hzd (for display anly) | 20

ICA w Plottopo options (key!, al' Help I dir', —1

Catas

Cancel | Help Ok
LOMmpPonent ERFL F

SumjfCompare comp. ERPs

Drata statistics [

Time-frequency transforms b

>>pop_ comperp(ALLEEG,1,[4 5],[]1, "addavg", "off","addstd", "off"
"addall","on","diffavg”, "off","diffstd”, "off", "lowpass”, 20,
"tplotopt” ,{"ydir",-1});
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Compare ERPs across conditions

——
T3 e T e e T

e16 e0d
%Wav@m

e e02 %Wy

015 »—}e@“ﬁ“ W 809
~*}@ﬁxzwﬂv eOB“*%EﬁEzfgg e03 “{ﬁ%ﬁ;g?ﬁ’
e24 e01 e19

T N
et s T

e14 e10
! e05 e04 e
o ﬂ& ; ﬁ"g =y
| #4 abject (n=182) |
213 W\q. Q iy a1 A0
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Analysis of ERP differences

Center
Computational
Neuroscience

N
-!‘Q%:‘:':

Plotdifference NI

between two conditions o st all ERPs

Datasats to avarage (ex: 1 3 41 | 4 B B ]
Datasets to avarage and subtract {ex 56 7 | g n n ]
Plot difference ¥4 N N
Channels subset (J=alll |
Highlight significant regions (01 -» p=.01) |
Use EM3 instead of average (check) N
Lo pass (Hz) (for display anly) | 20
Plottopo options (key', wal' Help I dir!, -1

Cancsal Halp Ol

>> pop_ comperp(ALLEEG,1, 4, 5,"addavg”,"off",..
"addstd”", "off", "diffavg","on","diffstd", "off"
"lowpass”,20, "tplotopt”,{"ydir",-1});
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Analysis of ERP differences

x\, i Figure 2 - O =

File  Edit “iew |nsert Tools Deskiop  window  Help o

NeE& hRAMD|(E| 08| =8O

(= el
s . %Fﬁ‘ eng{’ﬁ% %ﬁﬁq 8 o ERP
%w %""‘ m%”f"‘* ED%&\ ED%’-?" %’W ;1% difference

between

el ed
EE% %Enﬁ*ﬂ" en%& EDW‘ %& 81% 2 conditions
91#‘% en% ED%@ Eﬂ%e‘
ez% 91% 91% 91%‘5‘! EE% EE%DN
SRR s

200 796
Tire {ms)

L
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e

.‘.%:‘t:

)} EEGLAB v4.512

File Edit Tools Flot Datasets Help

& SpeedProject's SpeedEdit - [faces]

Export EEG data

=101 x|

Neuroscience

Import data 3 X
Import epoch info , }CDDI' Qatei Bearbeiten  Format  Ansicht  Fensker  Hilfe _|E|X|
Import event info 3 D@E|%Eﬂ|ﬁ|§|%gm|?
Expart | o Ol e01 e02 e03 e04 e05 e06 07 =08 e09 eol0 ell el2 e13
Load existing dataset by Exd -0.7021 -0.6395 -0.5491 -0.3844 -0.4730 -0.5075 -0.
Save current dataset In - -0.7116 -0.7245 -0.4236 -0.2221 -0.4850 -0.71&65 -0,
Cave datasats -0.5483 -0.6298 -0.2757 -0.0396 -0.3252 -0.7949 -0,
Clear dataset(s) Tral —0.4038 -0.4629 -0.1161 -0.1454 -0.3393 -0.7880  -0.
— Eql —0.3721 -0.3333 -0.1556 -0.3324 -0.4109 -0.7188 -0.
MELIFAIEE TTETEry -] -0.2317 -0.1290 -0.2646 -0.2754 -0.2334 -0.4372 -0,
Save history » N 0.ooez 0.2113 -0.0913 -0.1361 0.0039 0.0085 0.1
Quit Mutl 0, 5633 0.6851 0.3850 0.0617 0.2508 0.4841 0.5
o SR RTE Apd 0.7554 0.9445 0.70%0 0.2071 0.3589 0.6747 0.4
Dataset size (Mb) 0.3744 0.5905 0.2864 -0.1259 0.0329 0.3895 0.3
-0.0672  0.1176 -0.2224 -0.4370 -0.1789 0.0444 -0.
_ | -o.0826  -0.001%  -0.1886 -0.2928 -0.0028 -0.1215 -0.
-0.0582 -0.0889 -0.1299 -0.1322 0.1167 -0.2183 -0,
-0.1189 -0.2618 -0.2840 -0.1262 0.1378 -0.2262 -0,
-0.0765 -0.2820 -0.4683 -0.0749 0.2594 -0.1621 -0,
0.1603 -0.0609  -0.3273  0.1355 0.4519 0.0595 -0.
0.3770 0.2577 0.0617 0.3868 0.5652 0.3752 -0.
>> pop_export(EEG, "D:\tmp\faces.dat", "erp","on", ...
"transpose®,"on","time","off");
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Exercise

ALL
-Load faces_3.set
-Do not save your changes under the same filename!

Novice
-Rereference the data to Cz.
-Scroll data and explore plotting options under 'Settings'.

Intermediate

-Load channel locations from .locs file in ‘data’ folder, explore
options to transform axes.

-Review events in Edit->Event values, rename an event in Select
epochs/events.

-Create a new event field in Edit->Event fields.

Advanced

-Epoch the data on faces and objects separately, then use
pop_comperp to compare ERPs between conditions.

-Explore other menu options.
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