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The EEGLAB Matlab software

S

<%

Center’
Computational
Neuroscience

7

!

main graphic interface

EEGLAE Shell - Konsole

Session Edit View Bookmarks Settings Help
_L ||!|| ] [ EEGLABv5.03
/home/arno> matlab -nodesktop File Edit Tools Plot Study Datasets  Help
<«<MATLAEB>»
Copyright 1984-2002 The MathWorks, Inc. No current dataset
Version 6.5.0.180913a Release 13
Jun 18 2002 - Create a new or load an existing dataset:
Lse "File > lmport data” (rew )
Using Toolbox Path Cache. Type "help toolbox_path_cache" for ﬁ:r “File > Load existing dataset” (old)
- If naw,
To get started, type one of these: helpwin, helpdesk, or demo. ‘File > Import epoch infe” (data epochs) else
For product information, visit www.mathworks.com. "File > Import event info” {continuous data)
"Edit > Dataset info" (add/fedit dataset info)
>> eeglablf] "File > Save dataset” (save dataset)
- Prune data: "Edit > Select data”
- Reject data: "Tools » Reject continueous
- Epoch data: "Tools > Extract epochs”
- Pernowve baseline: "Tools > Remowve
- Run ICA: "Tools = Bun [CA"

60 menus, more than 300 Matlab functions and more than 50,000 lines of code
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Importing a dataset

-Edit Taols  Plot

Impor epoch); info -

Impar event info P
Expart -

Stuchy Darasets  Help |

From ASCllffloat file or Matlab arraw

From continuous or seq. EGI . FEAW file
From Multiple seg. EGI .EAW files

Load existing dataset
Sawve CUrrent datasetis)
Sawe current dataset as
Zlear datasetis)

From BCIZ000 ASCH file

From Snapmaster A file

From Meuroscan .CHT file
From Meuroscan EEG file

Create stLchy -

Fraom ERPSS EAMW or .REDF file

Computational
Neuroscience

Load existing stuchy
SEwE CURFEnT sTUdy
SAwE CUFPERT STUdk s
Zlear sty

From Biosemi .BDF file using BIO%1G
From other formats using BIOSIG

From AMT EEProbe (CRT file
From AMT EEFrobe AYE file

EEGLAB supports many

different raw data formats

Memaory options

Sawe history k-

CIuit

From Brain ¥is. Rec. .whdr file
From Brain %is. Anal. Matlab file

From CTF folder (MEC)

From IMatep AT file

From mMawo MEF files

From 40 .m4d pdf file

Troubleshooting, other data formats. ..
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Imported EEG data
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Center for

Cmmputational

Neuroscience

EEGLAB v5.03

File Edit Tools Plot Siuchy Datasets  Help
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The example data: faces vs. objects
-

&

File
../data/faces_3.set
Data

33 channel EEG, nose-tip reference, 250 Hz
sampling rate, 0.5-100 Hz, 16 bit, BrainAmps

Task
speeded discrimination between objects and faces,

500 ms presentation duration, ISI 500-1900 ms,
362 trials
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!

Comments

Read/Enter comments — pop_comments()

Ahout this dataset

Data acquirad by, Stefan Debener
Data acquired on: Oct 15, 1374

Data:

33 channel EEQ
nosa—tip refarence
sampling rate: 250 Hz
filtared: .5 - 100 Hz
16 bit, BrainAmps

Task:

speeded discrimination between ohjects and faces
500 ms presentation duration

[5] 500-1300 ms

362 trials

CAMCEL

AN E

I

) EEGLAB v5.03

\ o R £
Center
Computational
Neuroscience

File | Edit Tools Plot Siucy  Datasets  Help

.,

Dataset info
Ewent fields
Ewvent walues
Abaut this dataset
Channel locations

linuous

chopOEffaces _3.s5at
33
133735

Select data
Select epochsfevents

1
732

oy current dataset
Append datasets
Delete datasetis)

250
0,000
2 5l Sl

M

Channel locations
[CA waights
Dataset size (Mb)

feas
fasg
356

EEGLAB Workshop VIII , Jun. 7-10, 2009, Aspet: Filipa Campos Viola — Data import and preprocessing




Re-reference data

i
Ay e |
Center for
Compulational
Neurosc ience
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Re-reference data

AR
Swartz 85|

Center for
Computational
Neuroscience

) Fpz-TP10
" Fp1-TR10

-__.l'

- -

.-. "'_. ‘__.-'"..-l. .-l_-'-..l. _.--'HF:I'TF”]IJ
P - A T - . ~
-~ [ A S Fa-TP1C

-
| B |— ) -_.__.-' P
] Fpz J. ey .
J: e F

)
: e "-. -.'-I - .
=~ [wn] (=) (o) o) () (o (o | —_ 1. Average Heference assumption

! 15 .:r:,-;.".-r1|- LT 3 R
P WL L W .

IO OO NAIOAY Fpz + Fpl + AF3+ FE+ FT2+ . + TP10=0

A e U N ES TS T ) 2 ) o e S W

r'. "I'.:. -:.I - . -"_.:. s~ .-[. .-I' -, "- y .':II 4 ".I;x:-- el

.' L — —=| Fia y —|a . :._."l -1 :_.:'“G :._ Fica :_l.: ] :I .\__Flh _:_ . 5

( J T I 7T 1T 1T 1T 1 1} -I 2. First recalculate the activity at reference TF10
f o e oo e o) { —

T T T T T T TTT Sum of all electrode activity =

A, '-I:.:- S e LY f._:__:— . '.__-'.ﬁ'- |
L (e A g Fpz + Fp1 + AF3 + F&+ .. - 64TP10

o {m HF A P D . ~ L TR0 minus Fpz + Fpl1 + AF3+ FS8+ .+ TF10 =10
. bl -y ~ ) TF12 = - (Sum of all electrede activity )85

' ~@_ T 3. Add up the activity of TF1C to all channels
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Re-reference data

el s 1 55
By : - Neuroscience
) EEGLAB v5.03 - %
File Edit | Toals Plot Stocy  Datasets  Help
Change sampling rate
—#1: Filter the data - itv th f h fi
e Specify the reference scheme of imported data
Filenz:
(F::-Iaerl'zn Eviraci Initial reference - pop_reref()
EPOCP
Event roiort THIS SCREEM |5 USED TO EMTER CURREMT REFEREMCE AMD WILL ORMLY APPEAR QOMCE
samp Eun ICA |JData ara in average rafaerance |
Epoct OR
Epoct Femove

W DCata are referenced to one site {(default)

Avera Reject g Feferance channel numberis), if presant in data (default: [0 |

Chan  |ocate

[CA w
Locate ;
B oem =i PalE e RS
AEnl _|Includea current refaranca channel in data | | |
Laplacig Mote: by including a reference channal in your data (abowa), its potential may be computed when
N —— e ] o
FMEIE T wou re-refarance the data. If you have polar coordinates of the reference channel, entar them abows;
If the dataset has no channel locations yet, wou may leave the labeal and location fields empty,;
Grand g If wou have 3-D location coordinates only, then Cancel and create a new channel 34
Locate in Edit > Channel locaticons, Then return to Tools = Be-refarance,
PCa iy
Cancel | Help | Ok
e A
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Rereferencing, cont'd

Computational
Neuroscience

pop_reref - average reference or re-reference data

= ||

Current data reference state is: common

W Compute average refarence | 2 re-reference
_|Re-raferancea data to channel numkber(s): |

_[Retain reference chann fata (if more than on choices
[detar ta inelud e Suirent reiEranee h) new referenee; inelvde ehammel S atess

pop_reref - average reference or re-reference data

Cancal Currant data referance state is: common

_ICompute avarage referance

R Fa-rafarence data to channel numbear(s | 1&
_|Retain reference channels in data {if more than onea)
[Hetar ta inelud e Suirent rEiEranee h) new referenee inelvde ehammel S atess

]

Cancel Healp k.

EEG = pop_reref( EEG, 16, 'refstate',60);
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Save new dataset, keep old one

|~y ) info — = i
‘\q,_*v 4 Dataset info — pop_newset() O X ﬁ::zscleﬂ:c'e
What do you want to do with the new dataset?
Mame it: | faces_3_continuous rerefaranced Edit description |
W Gaveitas file: | Browsa |

£ome changes have not been saved. What do you want to do with the old dataset?
] Crvarwrite it in memory (set=yes; unsat=create a new dataset)

avaitac file: | fhome/julie/workshopOE/faces_3.sat |
Il save dataset with .set extension — pop_saveset(}) X

Filtar el | Help | Ok |
| thomedjulisdworkshopl6s sef
Bl . Bl File Edit Tools Plot “'u#0 Datasets Help ‘
‘hiomesdjuliedvarkshoplss 5 |faces_d.set |—
fhomedjuliedwarkshopOs,.. faces_4.set L =
el B s o BNIATGS —#2: faces_3_continuous rereferen...-
Filenam«z: nene
Chantiels par frame 32
| || Frames per epach 133735
. e cpochs 1
o [fefi 13
Events 732
Save as type : S = sampling rate (Hz} 250
Epoch start (sec) 0,000
Salection Epoch end (sec) =34.336
— | Avarage referance Mo
fhnmeﬂuhe;’workshn;,l‘lﬁﬁaces_2_rereferenced.set_l Channel locations Vasg
ICA weaights fas
Dataset size (Mhb 35
_save | _Fier | Cancel o

[ALLEEG EEG CURRENTSET] = pop_newset (ALLEEG,..

EEG, 1, 'setname', 'rereferenced data'); 12
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File

Multiple active datasets (ALLEEG)

EEGLAB v5.03

im,ge‘ "
Computational
Neuroscience

EEGLAB v5.03

Edit Toals Plat

Datasets

Help

Filemame: ...uliefworkshopO&ffaces 3,58t

Channels per frame
Frarmeas pear epach
Epaochs

Ewvents

sampling rate (Hz)
Epoch start (sec)
Epoch end (sac)
Avarage referance
Channel locations
[CA waights
Dataset size (Mhb)

——+#1: faces_3_continuous

a3
133735
1

732

250
0,000

£34.936

I

ez

as

356

File Edit Tools Plot

Filenarmes: none
Channels par frame
Frarmes per eapoch
Epochs

Evants

sampling rate (Hz)
Epoch start (sac)
Epoch end (sac)
Avarage refarence
Channel locations
[CA weaights
Cataset siza (M)

——#2: faces_3_contil

Dataset 1.faces_2 _continuous

v Dataset 2:faces_2 _continuous rereferenced

= Select multiple datasets

133735
1

732

250
0,000

£34.936

I

ez

fas

35
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Scroll data

: S G
& Center for
\ Computational
S/ Neuroscience

Figure Display Settings Help

File Edit Toals Datasets

bpl
bpd
obje
bt
abje.
bt

o e Ty .

) EEGLAB v5.03 o[
i Help
Channel locations = SOV U DR NNV NPV PNV SR
Channel data {scroll) B e VI T I R O i U P A
ED4%MWWMWWWWW
il Channel spectra and maps EUSMWMW%MWW«W\HWW
ilename: ... : 508 [ o sl i gt Wb ] e T A
Ch | Channel properties W%MWMWWMWW
annels pE - 08 P A A e T e S e e N e s
Frames per e B i [ e T e (e N
S T S e e Y (RS SO NI o T e e
Epachs - T I I A O VY A e ey
= B NMWWWMW [y m Appeinorm oAV N ™
Ewe nts. E S e - HSM\AM\/\/\MWMVW M/\W"’“"J\MW
Sl i e R B e e A e N e
UM Compare ERes 815 | A A R e it gy N p et v e~ I e
Epoch start MMWNWWWMW
Epoch and { Component activations (scrally B S PRSI WEPRPIIPNY, VNI s T DA PRI SRR
EWBWWWMWWWMMWWWWW
Avearage refe  Component spectra and maps 18 P i e P s TN NI S e il A S A g i et
gquMW F N bt A A NI N Nl PTNIN prmtein st PN
Channel loc Companent maps - & %M/WW WW
5 . e WW WW
ICA weldhts o nonem properties ZW [
Dataset size - B Sy o e S R T e T SN ISRRVEVSE AP
> ] A VU SV SOV SO P S IPVIS PRVAIRVOSI FPS SNSRI ARRV I
B PV VTP e BT I WAy Wi e e AP S R RN
= B S e e
. ERFS :i: U N ¥ e P B WUV AIENVERH SV WA VPRV b e A
e B Y IR R TP S TR VAN AP
Data statistics - e e S RS (M tregr e riad Wi
- ESZNWWWM”%MWWWMW
Time-fregquency transfarms - €3 i e ia L eV e I

NN

Ayerage time-fregquency

Mew Time-freq. transforms - Chan Time Value

P
CANCEL Event types ‘ << < a5 > 01 98,0234 -1L5 60 REJECT

>> pop_eegplot (EEG,1,1,1);
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Scroll channel data

Chn,ge‘ -
Computational
Neuroscience

; - <

T —— =8l

Figure Displas  Settings elp e

= e ] ] S N 0 O | G O O ]
2 ] I i oo o]
3 frp—rer e 1 e e R P I
71| AES AP e Fer szl paenslee s gnlasap b el apenend
channels, - N —— " — O | o O I —
. T e - e
‘tl m e Pl o B SV NERRE WVAE, DR SNSRI STt I S S PR P e e S AR P R RV SR |l et I S W i R e
bJ o T S e I U B Rl LA L S e W SRS DTN o i R e o IO RUTURT F IPP e LV STRRTRR R
Lo F Y P T B T Tt (L A ST PEV PR NPl P (PSS I S (RIS R TR PSR SERYES RIF VRS SR s o
events S T T e o owad e Scroll
L T e e L sl o Rl et o g P I Y I A e R e e I W ere
o e e T R o e T P < i e i il B Lo
L B e A e e B B e T P I P il L g e e E b u tto n S
14 et e e ] I Tt ¥ T2 o L T it s Ty il (e
B et A e A ] R e I B e R e e T i o e
16 ] e S [ty O e aaies e
/ h 17 fﬂmwm“ - I DIEI WWHWMMWWW WWMMMWW e A mgin]
18 Frm i e i T Mg e L e et e et ]
S e C e po C 19 T e —ars ww%mmw‘ﬂmmmmw* vt o] S C al i n
D0 q hustep WWWW!WW. A et s Ve g
21 Pt g att — 211 A T R i S Tt ST L
22 Pt b R T T N ot it ML NPT SRS UGS, B I P
| e e . S _H:I Wwwmwwm i i, [N S
24 Hmrram e o PR R A e WY, L S g SRS Nl e e
26 pl e T o e W-WT::MMMWMWA
26 [y g, T M«M-w - PR S o
eve ntS 27 : g WWMMM%M ot pprarnt™, Wﬁwwmm
L WWMWWMM i e R R L
B B R R e B B i [P Al it G EE V| Scale
A0 et e i B B R i T e S ML SRS P I S 100
| 31 M WMW»WWWW RO AN A # Al |y s Py v
J 52 . :‘W‘“ iR WMWWMWWWW T
=] e i i T ATV PETIN Y ! A aok bbb LR b 'Y " I} T T PO RN R W | 4. b, bk ity

25 216 21% 218 219

]
—

221 222 224 224 225

Chan. Tirme alue

‘ =
s | = I 215 >| == 1 2235905 2.0928 100 | REJECT |

CAMCEL | Everit types
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Data import and preprocessing

Task 1 Task 5
Import raw data Analysis of ERPs
Re-reference data Export EEG data
Scroll channel data Task 6

Task 2 Reject badchannels
Import channel location file  Task 7

Task 3 Reject continous data
Import data events Task 8

Task 4 Reject data epochs
Extract data epochs
Select epochs/events Exercise...
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Import channel locations

Edit channel info - pop_chanedit(} = || e

& Channel information ("field_name™): ter for

1 Computational

Channel labeal ("lakeal™

Folar angle ("thata")

Folar radius ("radius")

Cartesian X ("4")

Cartesian Y ("Y")

Cartesian £0"2")

Spherical hotiz, angla ("sph _theta")
Spherical azimuth angle ("sph_phi")
Spherical radius ("sph_radius")
Channel type

Indesx in backup ‘'urchanlocs' structura

Neuroscience

Opt, head center |
Rotate axis |
Transform axes |

¥z —» polar & sph. |
Sph. -»> polar & xyz |
Polar > sph. &syz |

Set head radius |
Set channel types |

Delete chan | Channel number {of 1}
Insert chan | << | < | 1 = e Append chan |
Flat 2-0 | Flot radius (0.2-1, [J=auta) Mose along +X | ,| Flot 3-0 (xyz) |

Read locations | Read locs halp | Look up locs | Sawelas .ced) | Save(other types) |

Cancal | Help | Ok |
) EEGLAB v5.03 e
File | Edit | Tools  Plot Datasets Help
" Datasetinfo
[ Event fields tinuous
Ewent walues
» Use channel names and automatically Aot tis cataser  OPOSIFaces Siset
. . Channel locations
assign channel location —— e
» Import channel location file e e | D
- Modify/stretch/rotate channel locations Append caiasels | 534636
Delete dataset(s) [
¢ Set Channel typeS - Channel locations Yas
[CA weaights fes
Dataset size (Mb) 35.6
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Edit channel info - pop_chanedit()

Opt. head center
Rotate axis

Transform axes

Swartz

Center for
Cmmputational
Neuroscience

Hyz —> polar & sph.
sph. —> polar & xyz
Polar —» sph. z

Set head radius
Set channel types

Insert chan > |
Plot 2-D | Nosealong +X /| _Plot 3-D(xy2) |
Fead locs halp _ Saveias .ced) | save [other typas)

Dealete chan

Load a channel location file

Read electrode file

Al 4

Polhemuz native .alp file
EESA spherical .elp fila
Matlak xyz file

BESA or ECI 2-D cartesian .
EECLAE palar o fila =

7 file formats supported
(Polhemus, BESA, ...)
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i Channel information {"field_name™k
T Channel lakel ("label™)
! Folar angle ("theta")
) Paolar radius ("radius™)

N o Cartesian A (A"

) = Cartesian (™"
Cartesian £("2")
Spherical horiz, angle ("sph_theta")
Spherical azimuth angle ("sph_phi"
Spherical radius ("sph _radius")
Channel type
Index in backup 'urchanlocs' structure

Edit channel info — pop_chanedit()

aell

Opt. head center |

a0

Rotate axis |

0

Transform axes |

3.7494e-33

-6.1232e-17

¥z —> polar & sph, |

1

Sph. —» polar &xyz |

-30

Polar —» sph. &syz |

30

1

Set head radius |

Channel numhber {of 33)

< T

Fead/locations

File Edit ¥iew Insert Tools Desktop Wincow Help

Delete chan |
Insert chan | << |
Plot 2-0 Flot radius (0.2-1, [J=auto)

Fead locs help

> | x|

Set channel types |

Append chan |

Mose along +X | .r'|

Plot 3-D (xvz) |

Look up locs |

Save(as .ced) | Saveiother types) |

Halp

DaWd3| s|RaQMe|E|0B| =10

gure 4

File Edit Yiew |nsert Tools Desktog Window Help

S

Center
Computational
Neuroscience

o Channel locations

~

«230

33 of 33 electrode locations shown

Click on electrodes to togale name/number

spet: Filipa Campos V

DEES| LRaN®|E 02|50




Import channel locations

| \ M 1
| ‘ . ) o M | A

1 A N A A VW\ A i .y il \ I ALY
\ A J\,\W‘)\J\ W/ “v\wf \‘VW‘V ﬁd¢~\j~\m-yMﬁA/JA/UN ) \vf W \\ f’u‘ M “\\',«M W, | " A W

‘ ‘
y W N8 Ay AN
N ’ p v |
WA i r

A
\ A / \
Mt | Wi A b AN My /) s Nl N
WV o L\/\s W vﬂ‘ /‘\' w‘\\\ ‘VUP/ W ‘v“\w‘ Y ‘/‘A/ LW“ " W /\[\ J “\‘*‘Mvr‘/\* \Tw“u“ ! \p |
\

EEGLAB v5.03

File Edit Tools Plot Siuchy Datasets  Help
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Data import and preprocessing

‘{ . ¥

Task 1 Task 5
Import raw data Analysis of ERPs
Re-reference data Export EEG data
Scroll channel data Task 6

Task 2 Reject badchannels
Import channel location file  Task 7

Task 3 Reject continous data
Import data events Task 8

Task 4 Reject data epochs
Extract data epochs
Select epochs/events Exercise...
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Import data events

\:.‘ P Y Chg'gne‘put;ﬁonal
%? Neuroscience
) EEGLAB v5.03 x
‘File | Edit Tools Plot Datasets  Help .
O | * Import events from Matlab array or ASCII file
port data - :
) : . 1tinuous | °
Impgort eventinfe LS rom atiab array or AScllfile [ / » Import from Presentation event file
Export ~ | Frorm data channel <
Load existing dataset From Presentation .LOGS file J
Sawve current datasetis) 1
Sawe current dataset as 732
ol 250
ear dataset(s)
0,000
Create studhy - 34 93E
Load existing stuchy Mo Extract event from channel(s) - pop_chanevent()
SaVE CUFFEnt study Tas
Sawve CUrrent study as ;;56 Event channel(s) | 34 |
Clear stiichy :
Memary options Preprocessing transform (data=""") | Opticnal, B X3
. Transitions to extract? (up|down) M (click to salect)
Save history - Al =
_ Transition length (1=pearfect edgeas) | 0
Quit Assign duration to each evants? ] [set=yas)
Dalete evant channal(s)? N [set = wes)
Delete old aevents if any? 4
All events of same type? ]
| Help | Ok |
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Scroll activity — eegplot()

'Fig_;ure Display Seftings  Help

Computational
Neuroscience

Scale
a0

- Chan.  Time Yalue =
CLOSE | E'-.-'Eﬂt tBI'FIES\ < I il | 4 il e I 1 91818 31457 I al 1
“ “v

| )

\
1\ \ \
\ \ \ \
:
\ 3145973
3145743
\ 3145747
3145741
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,MM [ \‘\ ,

Import data events

) M |
n V A
ATV YN IR VW ir A Vg W ) w )
vy (FM/ U \}L WL\T“M ROV P L ”{V w V\\‘\\”P/'M’\\ﬁ‘ Y iy ﬁ/‘ M\,\/ WW”\ N ﬂ

Swartz

V
Center for
Cmmputational
Neuroscience

EEGLAEB v5.03 :
If event import was

Flle Edit Tools Plot Study Datasets Help
successful,

you will see an
appropriate number

here
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&

g

File

EEGLAB v5.03

Edit  Tools  Plot
Datazet info
Ewvent fields
Ewvent values
Apout this dataset
Channel locations

Review event values

Center for-
Computational
Neuroscience

Select data
Select epochsfevents

oy current dataset
Append datasets
Delete datasets)

Channel locations
[CA waights
Dataset size (Mb)

B=
Datasets  Help |
tinuous
Delete
shopQ&/faces_3.set ' ' ' ' Append event CURRENT
5 Event type' and'latency AFTER event
1 are reCOgnlzed f|e|dS current event
732
0,000
234,336 Edit event field values (currently 732 events) Delate avant |
ﬁg; Latency (sec) ||| 4,964
Yas Type I object
356
Event Num
Insertevent || << | < [ Z | > B >> | Append event |

Insert event
BEFORE
current event

To resort: first

select Main

sorting field

Re-order events {for review only)

Main sorting field: _IClick for decreasing order

secondary sorting fiald: _IClick for decreasing order

Re-sort |

Cancal | Help | Ok, |
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Alternative method for importing events:
Import events from event file

- Computational
\M.,;}j Neuroscience
-} EEGLAB v5.03 =i~
File | Edit Toaols Plat Datasets  Help |
| Import data -

- EEG Data Check alignment between pre-existing (old) and loaded event latencies:
| Import eventinfo (X From Matlab arrayor ASClifile | | Old event latencies (10 first): 10789 21315 31375 41902 51962 62489 ...

Expont ~  From data channel . .
. : _ New event latencies (10 first): 10789 21315 31376 41902 51963 62489 ...
Load existing dataset From Presentation .LOG file
Save Current dataset(s) 1 Best sampling rate ratio found is 0.9999895. Below latencies after adjustment
Save current dataset as i;; Old event latencies (10 first): 10789 21315 31376 41902 51963 62488 ...
Clear dataset(s . .
= 0,000 New event latencies (10 first): 10789 21315 31375 41902 51962 62489 ...
Filter
fhomeswwwieeglah/download? . Import presentation file - pop_importpres()
SRR . i File fizld containing event types Trial j
verwieenlabidowninad:, (S DSEYES LOG E Code
www/eeglab/downinadl. | | |DSEYES.GMA ir2g
TEST.CNT File field containing event latencies Trial -
TEST.DAT E\;ZE Type |
TEST EDF Time_
LR File field containing event durations ] 5
) Evant Type
4 i Code
ol [ ] | ] L AR
Files of type # = MNeote: scroll lists then click to salect fiald
Selection
‘ fhomeswwwieeglah/download/DSEYES LOG Cancel ‘ Help ‘ Ok
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Scroll data with events

&

g~ Computational

.,/ Neuroscience

=

Scroll channel activities — eegplot)

Figure Display Settings Help

|+ EEGLAB v5.03
File Edit Tools W iy Datasets Help

bpl
bpd
obje
bt
abje.
bt

ST TR - | R e o N g M G A
o0z [ e (N A A A 3
_ : — eus%WN%WMW PN A AN A il
#1: faces. Channel data (scroll) . P e i s W N e R ey i eI e ol g
EUEWWWWW i
: Channel spectra and maps T e e SR T R L e e LS L
F||er‘lame: e . ED7WWWWW i
Channel properties a0 e R T I e
RN b S A NS S AN S WA SN O P
. i i e SN NS S, gy e 3
FrEI.mES [rer e Chanmnel ERF (MAHE EHWWWWW J
oz R W SPWoYAY Moy A sy el E
EpOChS Channel ERFs - m%ﬁWWW M/\W"‘J\/MW”M
. E‘AWWWWWWM 4
Evants ERF map series B 0 ISR A NS Y MU Vo N VA VG i
> E\EWWWWWW |
EPNASE  urmy Compare ERP: N S Y e
EpOCh STart I: EWEWWWW“MWW :
. . eld W
B T Y U VN N W NP e e i
Epoch end (s Camponent activations (zcroll) WWWWWM
Avarage rafe Companent spectra and maps EZZWWWWWM
o3 P s oA TN e e e 4
Channel locg  Component maps - 1 AR AT A ovent NSNS I S au MMV AN s RO
i : B PV VTP e BT I WAy Wi e e AP S R RN il
ICA welghts  romponent properties S A RS VO ISl sl SOURTIN A Gehaaa S N
Catasat size . s N S VSIS AU O S
Component ERF image 228 [ o AT e NP UAIP W W NP E VS N
e el Yoy AN g P R e VRIS S AN AR SRS T
Companent EREs I 31 [ SN e WW ;
eazmww\wf\w I
- SumfCompare comp. ERRs B ‘ ] T
Data statistics - — ohject
Chan
Time-freguency transfarms - - S ‘ = = ’T N o
Awerage time-fregquency
__ bpa
Mew Time-fred. transfarms -
byl

— T T
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Data import and preprocessing

(:‘
o

Task 1 Task 5
Import raw data Analysis of ERPs
Re-reference data Export EEG data
Scroll channel data Task 6

Task 2 Reject badchannels
Import channel location file  Task 7

Task 3 Reject continous data
Import data events Task 8

Task 4 Reject data epochs
Extract data epochs
Select epochs/events Exercise...
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—#2:

Filerna
Chanr
Frarms
Epoch
Evant:
sampl
Epoch
Epoch
Avara
Chanr
[ZA w
Datasz:

EEGLAB v5.03

File  Edit - Plot =iuch  Datasets  Help >> eeg_eventtypes (EEG)

Change sampling rate

Filter the data

Fe-reference

Feject continuous data by eve

Extract epochs

Computational

Neuroscience

(usa shift|ctr] to
salect sevaral)

boundary

boundary 1

Extract epochs
FEemaowve baseling
FEeject data epochs

bpl 183
bp4 184

Fun [CA

Remowe components

Feject data using 1CA

Locate dipoles using BESA
Locate dipales using DIPFIT 1.x
Locate dipoles using DIFFIT 2.x
Laplacian

face 182

object 182

Cancel ‘

FMEIE Tools

Crand average catasets
Locate dipoles using LOREET A
PCA pluagin

z T Gy LI

Tima-locking event typeisi([=all) | '; |
Epoch limits [start, end] in seconds | ]
Mame for the new dataset | faces_3_chans removed epochs

Cut-of-hounds EEG limits if any [min max] |

Cancel | Help | Ok,
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Extract epochs

S

ey Centerfor

% Computational
-, Neuroscience
=

e

Epoch baseline removal — pop_rmbase()

Baseline latency range (min_ms max_ms)i([] = whaole epochl
| =100 0 |
Else, baseline points wector (ex: 1561 ([] = whole epoch;

1 N

ovarwritten by latenc
I: x ’ﬁ Dataset infu—pnpnewse ()
| EEGLAB v5.03 (=
What do you want to do with the new dataset] ] S
: File Edit Tools Plot Stucdy  Datasets  Help |
el | Marne it; | faces_3_chans
_| e e | —#3: faces_3_chans removed epochs
Some changes have not been saved. What do :
o s o _ Filemarmes: none
] vern.vnte I.t in meamaory (Set=yas; Unset=Cre Channels per frame 31
_| Saveitas file: | Frames per epoch 750
Epochs 364
Cancel | Hel Events 1500
| sampling rate (Hz) 250
Epoch start (sac) =1.000
Epoch end (sac) 1,996
- ' v - ' _ Avarage refarence I
>> EEG pop_epoch (EEG, {'face object'},[-1 2], ... Sl e e Vi
'newname', 'faces_3_chans removed epochs', ... |CA weights Tes
Cataset siza (M) 706
'epochinfo’', 'yes');
>> EEG = pop_rmbase (EEG, [-1000 0]); | J

>> [ALLEEG EEG CURRENTSET] = pop_newset (ALLEEG, EEG, ...

CURRENTSET, 'setname', 'faces_3_chans removed epochs');
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Select epochs

) EEGLAB v5.03 -l 7
File | Edit Tools Plat Stuchy  Datasets  Help | @
Dataset info : ccgﬁput;ﬁonai‘
TR Event fields tlrll..lﬂl.IS Neuroscience
Ewvent values
Abaout this dataset shaoapﬂﬁffacesj.set
i y Confirmation
Channel locations o :
Select data 1 Warning: delete 37 (out of 364) un—referanced epochs ¢
Select epochs fewvents Gt | Cancel | Ok
oy current dataset -
R 0.000
Append datasets 534 935
Delete datasets) [ ) — = r—
: / Select events -- pop_selectevent = p
Channel [ocations fas B 0 |—J[ﬁ|gl
::I;:i;: : ,l ggfl'lztz (Mb ;;5 g Field Selection Set=HOT THESE
' latency (ms) Mo description | it [iE=¥4 |:|
type Ma de=zcription | [ face| ]
epoch Mo description | - ]
Evert indices (]
|:| Select all events NOT selected above Set thiz button (to left) and "all BUT" buttons (abowe) far logical DR

Rename selected event typels) as type:

Retain ald evernt type natmels) in (hew) field named:

|:| Keep only selected events and remove all ather events
Remove epochs not referenced by any selected event
[ Inwert epoch selection

Cancel | Helgp | Ok

>> EEG = pop_selectevent (EEG, 'type', { 'face'}, ...
'deleteevents', 'off', 'deleteepochs’',6'on');

>> [ALLEEG EEG CURRENTSET] = pop_ newset (ALLEEG, EEG, 4, ...
'setname', 'faces only epochs');



'Do not overwrite

current dataset'

Dataset info — pop_newset()

face epochs Edit description |
Browse

[ Swarez £
Center for
Computational

Neuroscience

Import data
Import epoch info -
Impart event infn -
Export -

Load existing dataset
Sawe Current datasetis)

Save current dataset as

Clear dataset(s)

Create stuchy -

Load existing studhy
SaVE CUFFEnt study
Save Current studhy as
Clear studhy

M ermaory Dpt'innz

Bl Save dataset with .set extension — pop_saveset() X

Sawe history -

It
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1l - A ,‘\W“\M‘M\w\ N M S ey MY NP WA M Wt U L o e Al AT

T Y A TV AR LA™ A ) A LA VYR Bl VALY VWAL A W MM A b A L L A 1 WM

WA Y \ V b} Vo SPIN W e W WA iy
vy

LY l |
\ AN I LA ALy
N Wiy A VWAL WA A /
‘ %\ﬂ ‘\‘\4\1\‘%‘ \AWM B ‘V‘M - ‘ Swartz
‘ Center for
Cmmputational

Neuroscience

File Edit Tools Plot ' |Datasets| Help
 Dataset L:faces_3_continuous New dataset
v Dataset 2:face epl:h:'ﬁi-: ;

created

Select multiple datasets
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Data import and preprocessing

-
A
=

-

Task 1 Task 5
Import raw data Analysis of ERPs
Re-reference data Export EEG data
Scroll channel data Task 6

Task 2 Reject badchannels
Import channel location file  Task 7

Task 3 Reject continous data
Import data events Task 8

Task 4 Reject data epochs
Extract data epochs
Select epochs/events Exercise...
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2 .

5 - d’

=

File Edit Tools

—#2: face—

Filename: ng
Channels pe
Frames per ¢
Epochs
Evants
Sampling rat
Epoch start
Epoch end (=
Avearage refe
Channel locs
[CA weights
Cataset siza

Analysis of ERPs

Datasets  Help

Channel locations ]

Channel data (scroll)
Channel spectra and maps

Channel properties

Channel EREP image

Center
Computational
Neuroscience

Channel ERPs
EFP map series *

SumjCompare ERPs

With scalp maps

In =calpfrect. array

In rect. array

Component activations (scroll)
Component spectra and maps
Component maps »
Component properties
Component EREP image
Companent ERPs *

SumjCompare comp. ERPs

Data statistics *

Time-fregquency transformes »

Ayerage time-frequency

Cluster clataset [Cs

face
| a6 | el?
ey
a33 o325 016 bl 08 o8 a2y
e(?
el15 *‘E‘“&W

;
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File

Edit Tools

—#2: face—

Filename: ng
Channels pe
Frames per ¢
Epochs
Evants
Sampling rat
Epoch start
Epoch end (=
Awearage refe
Channel locs
1CA weights
Cataset size

EEGLAR vb.0b

Plot Datasets Help

Analysis of ERPs

ERP data and scalp maps -- pop_timtopo()

Platting time range (ms
calp map latencias (ms,
Plot title:

Channel locations

Cancel

Mall —= max—-REMS)

scalp map options (see > » halp topoplot)

| Halp

-200 736

165 |

ERF data and scalp maps of

Channel data (scroll)
Channel spectra and maps
Channel properties
Channel EREP image
Channel ERFs

EFP map series

Sum/Compare ERPs

mith scalp rmaps

In scalpfrect. array

In rect. array

Component activations (scroll)
Component spectra and maps
Component maps

Companent properties
Component ERP image
Companent ERP =
Sum/Compare comp. ERPs

10

Data statistics

Time-fregquency transforms

Ayerage time-freqguency
Cluster dataset 1Cs

Potential (uV)

-0

>> pop_timtopo (EEG, [-200 796], [165]

-10r

i

,"ERP d

ata and scalp maps

"),




\%V

File

—#2: face—

| ‘

&

=4
=

v,

Edit Tools

Filemame: ng
Channels pe
Frarmes per ¢
Epochs
Ewvants
Sampling rat
Epoch start
Epoch end (=
Avarage refa
Channel locs
[CA weights
Dataset size

Datasets  Help

Analysis of

ERPs

Plot ERP scalp maps in 2-0 -

Plotting ERP scalp maps at these latancias
{range: =200 to 796 ms, Mall -> emptyl

pop_topoplot()

Plot ti
Plot g4

o —> Ad

Channel lacatiohs

b -

Channel data (scroll)
Channel spectra and maps
Channel properties
Channel EREP image
Channel ERPs

EREP map =eries

SumjfCaompare ERPs

In 2-0

In2-D

Carmponent activations (scroll)
Camponent spectra and maps
Camponent maps

Companent properties
Caomponent ERF image
Component ERPs

SumyjCaompare comp. ERPs

Data statistics

Time-frequency transformes

Axerage time-frequency

Cluster dataset [Cs

face

>>pop_topoplot (EEG, 1, [0:25:200], 'face', [3 3],0, 'electrodes', 'off"');
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File

—#2: face—

Edit Tools

Filename: ng
Channels pe
Frames pear ¢
Epochs
Evants
sampling rat
Epoch start
Epoch end (=
Average refe
Channel locs
[CA weights
Datasat siza

Analysis of ERPs

Datasets  Help

Channel lacations ]

Channel data (scroll)
Channel spectra and magps

Channel properties

Channel ERP image
Channel ERPs ]

EREP map =eries

SumjCompare EREPs

Plotting ERPF s¢
{range: -200 ¢

Component activations (scroll)

Component spectra and maps

Caomponent maps »

Companent properties

Component EREP image

Component ERFs 3
SumjCompare comp. ERPs

Data statistics b
Time-frequency transforms »

Awerage time-frequency

Cluster dataset [Cs

>> pop_headplot (EEG, 1, [0:25:200], 'ERP
'electrodes',

'off');

Figues =lolx|
File Edit “iew Insert Tools Deskiop Window Help N
Dedae| h|RAN|E|0E| =8O

125 ms

Az 19E: 7

176 ms 200 ms

S

-
I S O R S i ) S 00

ERP scalp maps of face

scalp maps', [3 3], ...
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X &

} EEGLAB v4.512

File Edit Tools Plot Datasets Help

Export EEG data

=10 %]

Chrtetl ==

Computational

Neuroscience

Import data 3 X
Irmport epoch info N tn_ )([JDI' Datei Bearbeiten Format  Ansicht  Fenster Hilfe _ |E|X|
Import event info b D@H|%Eﬂ|ﬁ|§|%gm|@
E il ¢ Ol c01 e0Z e03 e04 05 e06 =07 e08 e0% el0 ell el2 e13
Load existing dataset W ® -0.7021 -0.6395 -0.5491 -0.3844 -0.4730 -0.5075 -0.
Save currentdataset N g ~0-7116  -0.7245 -0.4236 -0.2221 -0.4850 -0.7165 -0.
e dotRet M -0.5483 -0.6298 -0.2757 -0.0396 -0.3252 -0.794% -0,
Clear dataset(s) Tl —0.4038 -0.4629 -0.1161 -0.1454 -0.339%3 -0.7880 0.
— Ex —0.3721 -0.3333 -0.1556 -0.3324 -0.4109 -0.7188 -0,
LIS Rl g “0-2317  -0.1250 -0.2646 -0.2754 -0.2334 -0.4372  -0.
Save history b 0. o962 0.2113 -0.0%13 -0.1361 0.0039 0.0085 0.1
o Mufl 0, 5633 0.6851 0.3850 0.0617 0.2508 0.4841 0.5
T ap 0.7854 0.9445 0.7090 0.2071 0.3589 0.6747 0.4
Dot e () 0.3744 0.5905 0.2864 -0.1259 0.0329 0.3895 0.3
-0.0672 0.1176 -0.2224 -0.4370 -0.1789 0.0444 -0
| -0.0826 -0.0019 -0.1886 -0.2928 -0.0028 -0.1215 -0,
-0.0582 -0.0889% -0.1299 -0.1322 0.1167 -0.2183 -0.
-0.118% -0.2618 -0.2840 -0.1262 0.1378 -0.2262  -0.
-0.0765 -0.2820 -0.4683 -0.0749 0.2594 -0.1621  -0.
0.1603 -0.060% -0.3273 0.1355 0.451%9 0.0595 -0.
0. 3770 0.2577 0.0617 0.3868 0.5652 0.3752 -0.
>> pop_export (EEG, 'D:\tmp\faces.dat', 'erp','on', ...
'transpose', 'on', 'time', 'off');
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Data import and preprocessing

Task 1 Task 5
Import raw data Analysis of ERPs
Re-reference data Export EEG data
Scroll channel data Task 6

Task 2 Reject badchannels
Import channel location file  Task 7

Task 3 Reject continous data
Import data events Task 8

Task 4 Reject data epochs
Extract data epochs
Select epochs/events Exercise...
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Load/scroll data

Center
Computational
Neuroscience

I. 7 EEGLAB v5.03 | .5 EEGLAB v5.03
- Edit Tools Plot Study Datasets  Help | File Edit Toaols - Study Datasets  Help
' Impart data = Channel locations -
Impor epoch info P aset —#1: faces. Channel data {scroll)
Impart event info - et : Channel spectra and maps
ad an existing dataset: Filenarme: ...c )
Export ~ |dara" (haw) Channels pe Channel properties
Load existing dataset isting dataset" (old) Frames per & Channel ERF image
Save current dataset(s . Epochs Channel EREs
(=) h info" (data epochs) alse Ep : g
Save CUrrent dataset as Wants ERF rmap series -

tinfo" (continuous data) B ol

Clear dataset(s) "fadd/edit dataset info) sumfCornpare ERFS
Create stuchy " (save dataset) Secatan Component activations (scrolly
“ | Salact dara" Epoch end (s
Load existing study > Rejact continuous Average refe Component spectra and maps
Save CUrrent stuchy = Extract epochs” Char‘mgl loce  Component maps E
Sawve current studhy as Tools > R"emove e wmghts Carmponent properties
= Bun 1A Dataszet size :
Clear study Component EEF image
. Memory options ) Cormpanent ERFs -
- SumfCompare comp. ERRs —
Sawve history -
Quit Data statistics -

Time-frequency transforms -

Awerage time-fregquency

Mew Time-fred. transfarms -

>> EEG = pop_loadset ('faces_3.set', '...\data\');
>> [ALLEEG EEG CURRENTSET] eeg_store (ALLEEG, EEG, 0);
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Reject bad channels

Center for-
CﬁmbutﬂTonaI
o xae B i
} Scroll channel activities -- eegplot() -1o] x| euroscience
Figure Display Seftings Help k]

el1
el2
e03
el4
el5
elf WWWWWWVWWMWMWMW
I R ST e ali e e il T AU VLRV
BT it i A A st e i 7 Tt g g A S e e Al P A
T a3 A L it s abulo e YU NSURGET N,
elld WWWWMMNWWWMWMMM’W’WMM
R e T L e oA AT A PP e SR N T Rer
el? WWWWNW‘WWWWMMWWWMW\W
el3 WwwwwwWWMWMWmWWWW
e T L e LT TS s E LUV TIE AR P E R SR S
BT ity Mt N bt g T VAo AR I AR T 5 8 g Pyt A T NI gl ]
L i T e R o e e i L LA
1 7 [ b N st o A A e A Ao i S b b A1 1 oo B st AN ettty o]
1L b e RN i g, — o S it g W A P A ot P it e et
o ettt oo M AR A i b st b s
N T AT WU
e21 WWMWWW“MWWWWW%W
e22 WWWWWWWMMWMMWWWWWWWM
a3 WWMWWNWWMWMMWW‘W
ej: WW‘WWWWWWWW\MMMWMMMWWWWWMWW
o i i e e e L g PR
e2b
e27
e2i
e2d WMWMMWWWWMWWWWWMWMW
a30 WWWMMWWWWWWWWWMM Seale
e31 WMWWWW%WWWMW“WW

B2 Pttt Ao i TP Rt e T e M g o AT e e b e o i g

71 72 73 74 75 7B i 78 79

Chan. Time alue

.
CANCEL Event types | << | = || 71 = | = | o] 78,8282 77 100 —I REJECT h|

>> pop_eegplot (EEG, 1, 1, 1);
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Reject bad channels

N A
X \N\w M 1 M M i \ N
W m "N oAa 1) WM, IR | / \ m MVR A S |
vy MV W \ A ‘\/L WY WA J | ah L A \« 7\ WA /\“‘K‘f W u‘\“ YA N I LY Y W VTN B N / AN
I Vo W \ W W /‘\\ﬁ\ el \ A WA/ WA N WY VW I
V V \ W (B ; | | | AR | Swartz
A ‘

Center for

Cmmputational
Neuroscience

EEGLAB v5.03

F‘rle-Tnnls Plot Study! Datasets Help
Dataset info
Event fields
Ewent walugs
Apout this dataset
Channel locations

Select data
Select Epﬂths,fe‘uents

Cu:upv current dataset
Append datasets
Delete dataset(s)

Selectdata — pop_select()

15 24

Scrollet
ey |

EEG = pop_select (EEG, 'nochannel', [19 24]);
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Reject bad channels

\ (\\/‘ M A
| [N \ I 'l i )
L (1N A\ N v ‘N\ Ny ’M Vo | | ’ \,\‘ A A
b gl ) /M A W e \VM M Mgl U b A b A ) i Aol N L™ WA | NN
Myl A MEEA s by o S g bty KRN ...
| I Center for

Computational
Dataset info — POp_NEWSE I

ILiNUOU S Edit description |
Browse

EEGLAB v5.03

File Ecit Tools Plot “uiy  Datasets

P
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Data import and preprocessing

Task 1 Task 5
Import raw data Analysis of ERPs
Re-reference data Export EEG data
Scroll channel data Task 6

Task 2 Reject badchannels
Import channel location file  Task 7

Task 3 Reject continous data
Import data events Task 8

Task 4 Reject data epochs
Extract data epochs
Select epochs/events Exercise...
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Reject continuous data

-~ Equivalent!!

[, EEGLAB v5.03 == .- EEGLAB v5.03 =
File Edit - Plat Studly  Datasets Help | File Edit Toaols - study Datasets  Help
Change sampling rate Channel locations -
—#2: f, Filter the data - —#2: faces. Channel data {scrall)
_ Re-reference _ Channel spectra and maps
Filernal . . Filenams: no .
Feject continuous data by eve Channel properties
Chann Channels pa _
Fratre Extract epochs Frames per e Channel ERR image
Epoch Rermove baseline Epochs Channel ERFs =
Ewvents Eeject data epochs = E‘\-’EﬂtSI ERP map series -
sampl RUM ICA sampling fat <, compare ERPs
Epoch Epoch start —
Epoch Femowve companents Epoch end (s Component activations (scrolly
Avara;  Reject data using ICA - Avarage rafe Component spectra and maps
Chann  |ocate dipoles using BESA p Char‘mgl loca  Component maps p
ICA W | ot dipoles using DIPFIT 1.% - ICA weights  comnonent properties
Datase ; _ Dataset size | .
Locate dipaoles using DIFFIT 2.x - Component ERF irmage
Laplacian = Companent EREs =
_—
SumfCompare comp. ERRs
Mark stratches of continuous data for rejection Data statistics -
by dragaing the left mouse button, Click on marked Time-freguency transfarms .-
stretchas to unmark, When done,press "REJECT" 1o ﬁ " ;
axcise marked stratches (Mote: Leawvas rejaction wverage ime-Trequenty
boundary markers in the event table) Mew Tirme-freg. transfarms -
| Cancel | Continue |
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Figure

= blink correction

Disp|

Reject continuous data

Use ICA for eye

S

vartz i8]
Center
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Reject continuous data
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Data import and preprocessing

‘{ . ¥

Task 1 Task 5
Import raw data Analysis of ERPs
Re-reference data Export EEG data
Scroll channel data Task 6

Task 2 Reject badchannels
Import channel location file  Task 7

Task 3 Reject continous data
Import data events Task 8

Task 4 Reject data epochs
Extract data epochs
Select epochs/events Exercise...
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Reject data epochs

Edit

—#1:1

Filare
Chan
Frarre
Epoch
Event
samp
Epoch
Epoch
Avara
Chan
[ A w
Datas

EEGLAE v&.0b

Tools gl Datasetz  Help
Change sampling rate
Filter the data b

Fe-reference
Feject continuous data by eye

Extract epochs

Femove haseline

R A

Femove components

Autamatic epoch rejectian

Eeject cdata epochs

Feject data using [CA b
Locate dipoles using BESA »
Locate dipales using DIFFIT 2.1
Laplacian b
FMEIE Tools ]
Crand average datasets b
Locate dipoles using LORET A k
PCA plugin b

Feject data {all methods)
Feject by inspection

Feject extreme wvalues

Feject by linear trend fvariance
Feject by probability

Feject by kurtosis

Feject by spectra

Expoart marks 1o [CA reject

Feject marked epochs
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Reject data epochs

Swartz

Center for
Cc-mputational
Neuroscience

Reject trials using data statistics - pop_rejmenu(}

scroll Data |

visual

iInspection

]
[oA]

Calc [/ Plot |

151

Calculate | Secroll Data

it

probability

{
L] Lo =
‘ ‘ .
|

Calculate | Scroll Data

Calc | Plot

Show all trials marked for rejection by the measure selected abowe or checked below
W Abnormal appearance R Abnormal values W Abnormal trends
W Improbable epochs W Abnormal distributions W Abnormal spectra

Clear all marks Rejact marked trials
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Reject data epochs

YATLE NS ~
Cén,ge =
Computational

Neuroscience

iqure Warning

Epochs (=trials) marked for rejection hawve been noted,
To actually reject these epochs, use

mW Tools = Reject data epochs = Reject marked epochs
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Reject data epochs

Computational
Neuroscience

File  Edit Plot Datasets  Help N
Change sampling rate

—#1: 1 _ s —
Filter the data b

. Fe-reference
Fileriz t

“han Feject continuous data by eye

Fram: Extract epochs
Epoch
Evant
Sarmp Fun 1CA

Femowve baseline

Epock Remowve components

ii::; Automatic epoch rejection

Chan Feject data epochs Feject data (all methods)

[ A w Feject data using [CA ] Reject by inspection

Datas Locate dipoles using BESA b Feject extreme walues
Locate dipales using DIFFIT 2% # Feject by linear trend fvariance
Laplacian 3 Feject by probability
FMREIE Tools 9 Feject by kurtosis
Crand average datasets b Feject by spectra
Locate dipoles using LORETA 3 Export marks to ICA reject
PiCa, plugin b Feject marked epochs

>> EEG = pop_jointprob (EEG,1,[1:31],5,5,0,0);
>> EEG = pop_rejepoch (EEG, find (EEG.reject.rejglobal),0);
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Data import and preprocessing

]
v’ /’
‘ ; P

Task 1 Task 5
Import raw data Analysis of ERPs
Re-reference data Export EEG data
Scroll channel data Task 6

Task 2 Reject badchannels
Import channel location file  Task 7

Task 3 Reject continous data
Import data events Task 8

Task 4 Reject data epochs
Extract data epochs
Select epochs/events Exercise...
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Exercise 1

ALL

-Load faces_3.set

-Do not save your changes under the same name!
Novice

-Rereference the data to Cz.

-Scroll data and explore plotting options under 'Settings'.

Intermediate

-Load channel locations from .locs file in 'data’ folder, explore
options to transform axes.

-Review events in Edit->Event values, rename an event in Select
epochs/events.

-Create a new event field in Edit->Event fields.

Advanced

-Epoch the data on faces and objects separately, then use
pop_comperp to compare ERPs between conditions.

-Explore other menu options.
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Exercise 2

« ALL
-Load faces 3.set or faces 4.set
-Epoch the data on faces and objects
-From Reject data epochs->All methods menu
-Scroll the data and perform visual rejection
-Try other rejection protocols and compare

-Explore channel probability and abnormal distribution
plots
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