Pre-processing pipeline

1. Import event markers and channel locations
2. Import into EEGLAB
3. Collect high-density EEG data (>30 chan)
4. High pass filter (~0.5 – 1 Hz)
5. Re-examine raw data
6. Re-reference/down-sample (if necessary)
7. Reject bad channels
8. Reject large artifact time points
9. Run ICA
Dense-array EEG
Pre-processing pipeline

1. Collect high-density EEG data (>30 chan)
2. Import into EEGLAB
3. Import event markers and channel locations
4. Re-reference/down-sample (if necessary)
5. High pass filter (~0.5 – 1 Hz)
6. Examine raw data
7. Reject bad channels
8. Reject large artifact time points
9. Run ICA

Novice EEGLAB Workshop, Sept 22, 2011, Mallorca, Spain: Julie Onton – Getting started
EEGLAB Matlab toolbox

main graphic interface

```
/home/arno> matlab -nodesktop

< MATLAB >
Copyright 1984-2002 The MathWorks, Inc.
Version 6.5.0.180913a Release 13
Jun 18 2002

Using Toolbox Path Cache. Type "help toolbox_path_cache" for

To get started, type one of these: helpwin, helpdesk, or demo.
For product information, visit www.mathworks.com.

>> eeglab
```

- Create a new or load an existing dataset:
  Use "File > Import data" (new)
  Or "File > Load existing dataset" (old)
- If new,
  "File > Import epoch info" (data epochs) else
  "File > Import event info" (continuous data)
  "Edit > Dataset info" (add/edit dataset info)
  "File > Save dataset" (save dataset)
- Prune data: "Edit > Select data"
- Reject data: "Tools > Reject continuous"
- Epoch data: "Tools > Extract epochs"
- Remove baseline: "Tools > Remove"
- Run ICA: "Tools > Run ICA"
Importing a dataset

EEGLAB supports many different raw data formats

<table>
<thead>
<tr>
<th>Import data</th>
<th>From ASCII/float file or Matlab array</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>From continuous or seg. EEG .RAW file</td>
</tr>
<tr>
<td></td>
<td>From Multiple seg. EEG .RAW files</td>
</tr>
<tr>
<td></td>
<td>From BCI2000 ASCII file</td>
</tr>
<tr>
<td></td>
<td>From Snapmaster .SMA file</td>
</tr>
<tr>
<td></td>
<td>From Neuroscan .CNT file</td>
</tr>
<tr>
<td></td>
<td>From Neuroscan .EEG file</td>
</tr>
<tr>
<td></td>
<td>From ERPSS .RAW or .RDF file</td>
</tr>
<tr>
<td></td>
<td>From Biosemi .BDF file using BIOSIG</td>
</tr>
<tr>
<td></td>
<td>From other formats using BIOSIG</td>
</tr>
<tr>
<td></td>
<td>From ANT EEProbe .CNT file</td>
</tr>
<tr>
<td></td>
<td>From ANT EEProbe .AVR file</td>
</tr>
<tr>
<td></td>
<td>From Brain Vis. Rec. .vhdr file</td>
</tr>
<tr>
<td></td>
<td>From Brain Vis. Anal. Matlab file</td>
</tr>
<tr>
<td></td>
<td>From CTF folder (MEG)</td>
</tr>
<tr>
<td></td>
<td>From INSStep .ASC file</td>
</tr>
<tr>
<td></td>
<td>From Mayo .MEF files</td>
</tr>
<tr>
<td></td>
<td>From 4D .m4d pdf file</td>
</tr>
<tr>
<td></td>
<td>Troubleshooting, other data formats...</td>
</tr>
</tbody>
</table>
Imported EEG data

EEGLAB GUI displays dataset basics
Load an existing dataset

EEGLAB v10.2.2.1b
File Edit Tools Plot Study Datasets Help
Import data Import epoch info Import event info Export
Load existing dataset
Save current dataset(s) Save current dataset as Clear dataset(s)
Create study
Load existing study Save current study as Clear study
Memory and other options History scripts Quit

Load dataset(s) -- pop_loadset()

- Look in: j074
- File name: stem.set
- Files of type: (*.SET*, *.set)

Name | Date modified | Type     | Size
-----|--------------|----------|-----
ignore.set | 3/6/2009 8:29 AM | SET File | 120,589 KB
memorize.set | 3/6/2009 1:09 PM | SET File | 196,238 KB
probe.set | 3/13/2009 7:29 AM | SET File | 68,307 KB
sources.set | 3/9/2009 4:40 PM | SET File | 1,300 KB
stem.set | 3/9/2009 12:38 PM | SET File | 171,540 KB

Novice EEGLAB Workshop, Sept 22, 2011, Mallorca, Spain: Julie Onton – Getting started
Pre-processing pipeline

1. Collect high-density EEG data (>30 chan)
2. Import into EEGLAB
3. Import event markers and channel locations
4. Re-reference/down-sample (if necessary)
5. High pass filter (~0.5 – 1 Hz)
6. Examine raw data
7. Reject bad channels
8. Reject large artifact time points
9. Run ICA

Novice EEGLAB Workshop, Sept 22, 2011, Mallorca, Spain: Julie Onton – Getting started
Import data events

- Import events from Matlab array or ASCII file
- Import events from data channel
- Import from Presentation event file
- Import from Neuroscan file

(Often imported automatically during data import)
Appearance of an event channel in raw data

Novice EEGLAB Workshop, Sept 22, 2011, Mallorca, Spain: Julie Onton – Getting started
Imported data events

If event import was successful, you will see an appropriate number here.
Review event values

- Number of event fields is unlimited
- Insert event BEFORE current event
- To resort: first select Main sorting field
- Append event AFTER current event
- Delete CURRENT event

Most relevant fields

Novice EEGLAB Workshop, Sept 22, 2011, Mallorca, Spain: Julie Onton – Getting started
Import channel locations

- 7 file formats supported (Polhemus, BESA, …)
### Channel Information

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Channel label</td>
<td>LEYE</td>
</tr>
<tr>
<td>Polar angle (θ)</td>
<td>-45.1543</td>
</tr>
<tr>
<td>Polar radius (r)</td>
<td>0.54374</td>
</tr>
<tr>
<td>Cartesian X (x)</td>
<td>0.79487</td>
</tr>
<tr>
<td>Cartesian Y (y)</td>
<td>0.79917</td>
</tr>
<tr>
<td>Cartesian Z (z)</td>
<td>-0.15585</td>
</tr>
<tr>
<td>Spherical horiz. angle (θ)</td>
<td>45.1543</td>
</tr>
<tr>
<td>Spherical azimuth angle (φ)</td>
<td>-7.8725</td>
</tr>
<tr>
<td>Spherical radius (r)</td>
<td>1.1379</td>
</tr>
<tr>
<td>Channel type</td>
<td></td>
</tr>
<tr>
<td>Reference</td>
<td></td>
</tr>
<tr>
<td>Index in backup structure</td>
<td></td>
</tr>
<tr>
<td>Channel in data array (set=yes)</td>
<td></td>
</tr>
</tbody>
</table>

#### Channel Number (of 71)

- [Delete chan](#)
- [Insert chan](#)
- [Plot 2-D](#)
- [Plot radius (0.2-1, l=auto)](#)
- [Nose along +X](#)
- [Plot 3-D (xyz)](#)

---

**Figure 5**

- [Channel locations](#)

**Figure 4**

- [3D plot of electrode locations](#)

---

*Novice EEGLAB Workshop, Sept 22, 2011, Mallorca, Spain: Julie Onton*
Imported channel locations

#2: Sternberg Continuous -- Rere...

- Filename: none
- Channels per frame: 70
- Frames per epoch: 610133
- Epochs: 1
- Events: 1303
- Sampling rate (Hz): 250
- Epoch start (sec): 0.000
- Epoch end (sec): 2440.528
- Reference: CZ
- Channel locations: Yes
- ICA weights: Yes
- Dataset size (Mb): 349
Pre-processing pipeline

1. Collect high-density EEG data (>30 chan)
2. Import into EEGLAB
3. Import event markers and channel locations
4. Re-reference/down-sample (if necessary)
5. High pass filter (~0.5 – 1 Hz)
6. Examine raw data
7. Reject bad channels
8. Reject large artifact time points
9. Run ICA
Re-reference data (if necessary/desired)

For example, average reference
Re-reference data (if necessary/desired)

OR, re-reference to (i.e.) 'linked mastoids'

\[ \text{EEG} = \text{pop\_reref}(\text{EEG, 39}); \]
Save new dataset, keep old one

\[ \text{pop\_newset(ALLEEG,EEG,1, setname,)...} \]

'Sternberg Continuous -- Reref''d');

Novice EEGLAB Workshop, Sept 22, 2011, Mallorca, Spain: Julie Onton – Getting started
Multiple active datasets (ALLEEG)

#1: Sternberg Continuous Data
- Filename: ...\Australia\STUDY\S04stern.set
- Channels per frame: 71
- Frames per epoch: 810133
- Epochs: 1
- Events: 1303
- Sampling rate (Hz): 250
- Epoch start (sec): 0.000
- Epoch end (sec): 2440.528
- Reference: unknown
- Channel locations: Yes
- ICA weights: Yes
- Dataset size (Mb): 698

#2: Sternberg Continuous
- Filename: none
- Channels per frame: 71
- Frames per epoch: 610133
- Epochs: 1
- Events: 1303
- Sampling rate (Hz): 250
- Epoch start (sec): 0.000
- Epoch end (sec): 2440.528
- Reference: average
- Channel locations: Yes
- ICA weights: No
- Dataset size (Mb): 351.3
Pre-processing pipeline

1. Collect high-density EEG data (>30 chan)
2. Import into EEGLAB
3. Import event markers and channel locations
4. Re-reference/down-sample (if necessary)
5. High pass filter (~0.5 – 1 Hz)
6. Examine raw data
7. Reject bad channels
8. Reject large artifact time points
9. Run ICA
Filter the data (if necessary/desired)

Lower cut off frequencies require longer stretches of continuous data

High-pass needed for ICA
Pre-processing pipeline

1. Collect high-density EEG data (>30 chan)
2. Import into EEGLAB
3. Import event markers and channel locations
4. Re-reference/down-sample (if necessary)
5. High pass filter (~0.5 – 1 Hz)
6. Examine raw data
7. Reject bad channels
8. Reject large artifact time points
9. Run ICA

Re-examine raw data

Novice EEGLAB Workshop, Sept 22, 2011, Mallorca, Spain: Julie Onton – Getting started
Scroll channel data

>> pop_eegplot(EEG,1,1,1);

Novice EEGLAB Workshop, Sept 22, 2011, Mallorca, Spain: Julie Onton – Getting started
Scroll channel data

channels, time, events

sec/epoch

Event markers

Scroll buttons

scaling

Novice EEGLAB Workshop, Sept 22, 2011, Mallorca, Spain: Julie Onton – Getting started
Pre-processing pipeline

- Collect high-density EEG data (>30 chan)
- Import into EEGLAB
- Import event markers and channel locations
- Re-reference/down-sample (if necessary)
- High pass filter (~.5 – 1 Hz)
- Examine raw data
- Reject bad channels
- Reject large artifact time points
- Run ICA

Novice EEGLAB Workshop, Sept 22, 2011, Mallorca, Spain: Julie Onton – Getting started
Remove channel

1) Identify bad channel
Remove channel(s)
Removing channel(s)

If not checked, will result in dataset with one channel
Channel removed

Channel data without 'F6' (see supplementary material for interpolation)
Pre-processing pipeline

1. Collect high-density EEG data (>30 chan)
2. Import into EEGLAB
3. Import event markers and channel locations
4. Re-reference/down-sample (if necessary)
5. Examine raw data
6. High pass filter (~.5 – 1 Hz)
7. Reject bad channels
8. Reject large artifact time points
9. Run ICA
Reject continuous data

Equivalent
Reject continuous data

Click and drag with mouse over noisy data to reject
Rejecting data for ICA

To prepare data for ICA:

- Keep stereotyped artifacts (like eye blinks)
- Reject large muscle or otherwise strange events...

Novice EEGLAB Workshop, Sept 22, 2011, Mallorca, Spain: Julie Onton – Getting started
Pre-processing pipeline

1. Collect high-density EEG data (>30 chan)
2. Import into EEGLAB
3. Import event markers and channel locations
4. Re-reference/down-sample (if necessary)
5. High pass filter (~0.5 – 1 Hz)
6. Examine raw data
7. Reject bad channels
8. Reject large artifact time points
9. Run ICA
Independent Component Analysis

\[ x = \text{scalp EEG} \]

\[ W = \text{unmixing matrix} \]

\[ u = \text{sources} \]

\[ W^*x = u \]

ICA

\[ x = W^{-1}*u \]

\[ W^{-1} \text{ (scalp projections)} \]

Novice EEGLAB Workshop, Sept 22, 2011, Mallorca, Spain: Julie Onton – Getting started
“Secrets” to a good ICA decomposition

➢ Garbage in... garbage out (it's not magic)

➢ Remove large, non-stereotyped artifacts

➢ Do you have enough data? (based mostly on time, not frames)
  * ~30 min of data for 60-70 channels, ~60 min for > 200 channels

➢ High-pass filter to remove slow drifts
  * low-pass/ notch filters usually unnecessary

➢ Remove bad channels

➢ Data must be in double precision (not single)
### Runica options

<table>
<thead>
<tr>
<th>Option</th>
<th>Default</th>
<th>Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td>‘extended’</td>
<td>0</td>
<td>1 is recommended to find sub-gaussians</td>
</tr>
<tr>
<td>‘stop’</td>
<td>1e-7</td>
<td>final weight change → stop</td>
</tr>
<tr>
<td>‘lrate’</td>
<td>determined from data</td>
<td>too small → too long… too large → wts blow up</td>
</tr>
<tr>
<td>‘maxsteps’</td>
<td>512</td>
<td>more channels → more steps</td>
</tr>
<tr>
<td>‘pca’</td>
<td>0 or EEG.nbchan</td>
<td>Decompose only a principal data subspace</td>
</tr>
</tbody>
</table>

Other algorithms: `binica`, `sobi`, `acsobiro`
Runica progress...
ICA weights in EEG structure

```
>> EEG =

setname: 'faces_4 continuous'
filename: 'faces_4.set'
filepath: '/home/julie/workshop06/
subject: ''
group: ''
condition: ''
session: []
comments: [15x1 char]
nbchan: 33
trials: 1
pts: 133175
rate: 250
xmin: 0
xmax: 532.6960
times: []
data: [33x133175 single]
icaact: [33x133175 single]
icaactv: [33x33 double]
icasphere: [33x33 double]
icaweights: [33x33 double]
icachannels: [1x33 double]
chanlocs: [1x33 struct]
uranchanlocs: []
chaninfo: [1x1 struct]
ref: 'common'
event: [1x731 struct]
urevent: [1x731 struct]
eventdescription: []
epoch: []
epochdescription: []
reject: [1x1 struct]
stats: [1x1 struct]
spcdata: []
spcicaact: []
splinesfile: ''
icasplinefile: ''
dpfit: [1x1 struct]
history: [1x1633 char]
saved: 'no'
```

Figure 4

Jo74 Sternberg Continuous
Pre-processing pipeline

1. Collect high-density EEG data (>30 chan)
2. Re-reference/down-sample (if necessary)
3. Re-examine data
4. Reject bad channels
5. High pass filter (~0.5 – 1 Hz)
6. Reject large artifact time points
7. Examine raw data
8. Import into EEGLAB
9. Import event markers and channel locations
10. Run ICA
The example data: Sternberg working memory

**File**  
..EEGLAB_Workshop/data/stern.set

**Data**  
Continuous data (not epoched), ref’d to right mastoid

**Task**  
between 3 and 7 letters to **memorize (colored black)**,  
between 1 and 5 letters to **ignore (colored green)**,  
8 letters presented during each trial  
50% chance of **probe** letter being ‘in-set’

---

**Fixation**  
(5 sec)

| + | M | L | T | G | P | Y | Q | W |

**Memorize**  
Ignore

**SOA**  
(1.4 sec)

**Maintenance**  
(2-4 sec)  
**Probe**  
(RT)

| - | T |

See 'SternbergTaskExplanation.pdf' in workshop folder for more task details.

Was this letter in the memorized set?
Exercise

- **ALL**
  - Load stern.set (continuous data)
  - Do not save your changes under the same filename!

- **Novice**
  - Scroll channel data and explore plotting options under 'Settings'.
  - Reject noisy time points by visual inspection
  - Import standard channel locations

- **Intermediate / Advanced** (requires supplementary material)
  - Check for noisy channels by auto-detection
  - Remove a channel and then replace it by interpolation
    - Compare this signal with the original when you do this with a 'clean' channel
  - Try different filter methods and cut-offs, compare results
Supplementary lessons
Auto-detection of noisy channels

>> EEG = pop_rejchan(EEG, 'elec', [1:71], 'threshold', 5, ...
    'norm', 'on', 'measure', 'prob');
Auto-detected noisy channel
Interpolate bad channel

Choose a channel from other dataset

Auto-select deleted channel from other dataset

Interpolate channel(s) --...

What channel(s) to interpolate
none
- Select from non-data channels
- Select from other dataset
- Use list of other dataset

Interpolation method
Spherical

Cancel Help Ok

Dataset index
1

Cancel Help Ok

Novice EEGLAB Workshop, Sept 22, 2011, Mallorca, Spain: Julie Onton – Getting started
Interpolated channel

Channel order changes, but scalp location is correct
Merge (append) datasets

![EEGLAB window showing Append datasets option]

- Dataset info
- Event fields
- Event values
- About this dataset
- Channel locations
- Select data
- Select data using events
- Select epochs or events
- Copy current dataset
- Append datasets
- Delete dataset(s)

ICA weights: Yes
Dataset size (Mb): 67.6

Dataset indices to merge: 1 2
Preserve ICA weights of the first dataset: Yes

Help  Cancel  Ok
Merged datasets

#3: Merged datasets

- Filename: none
- Channels per frame: 71
- Frames per epoch: 375
- Epochs: 900
- Events: 900
- Sampling rate (Hz): 250
- Epoch start (sec): -0.500
- Epoch end (sec): 0.996
- Reference: unknown
- Channel locations: Yes
- ICA weights: Yes
- Dataset size (Mb): 199.9
Renaming events

1) input original 'type' code
2) input new 'type' code
3) Keep/delete all other events
Renaming events

- Event values: Options include Latency (sec) and Type.
- Event Num: Current event number is 3.
- Re-order events: Options for sorting, including No field selected.
Analysis of channel ERPs

>> pop_timtopo(EEG,[-200 500],[NaN],'ERP data and scalp maps');
Analysis of channel ERPs

EEGLAB v7.1.7.18b

File Edit Tools
Plot Study Datasets Help

Channel locations
- Channel data (scroll)
- Channel spectra and maps
- Channel properties
- Channel ERP image
- Channel ERPs
- ERP map series
- Sum/Compare ERPs
- Component activations (scroll)
- Component spectra and maps
- Component properties
- Component ERP image
- Component ERPs
- Sum/Compare comp. ERPs
- Data statistics

Figure 2: plottopo

Topographic ERP plot - pop_plottopo()

Channels to plot
- 1:71

Plot title
- Sternberg memorize epochs

Plot single trials
- (set=yes)

Plot in rect. array
- (set=yes)

Other plot options (see help)
- 'ydir', 1

Novice EEGLAB Workshop, Sept 22, 2011, Mallorca, Spain: Julie Onton – Getting started
Channel ERP in rectangular array
Analysis of channel ERPs

```
pop_topoplot(EEG,1,[0:25:275], 'Memorize', [3 4], 0, 'electrodes', 'off');
```

Novice EEGLAB Workshop, Sept 22, 2011, Mallorca, Spain: Julie Onton – Getting started
Compare ERPs across conditions

How do 'Memorize' and 'Ignore' ERPs differ?
Compare ERPs across conditions

> pop_comperp(ALLEEG,1,[2 3],[],'addavg','off','addstd','off','addall','on','diffavg','off','diffstd','off','lowpass',20,...

' tplotopt',{'ydir',1});

Novice EEGLAB Workshop, Sept 22, 2011, Mallorca, Spain: Julie Onton – Getting started
Compare ERPs across conditions

Click on an axis to see larger image
Analysis of ERP differences

Plot difference between two conditions

>> pop_comperp(ALLEEG,1, 2, 3,'addavg','off',...'addstd','off', 'diffavg','on','diffstd','off', ...'lowpass',20, 'tplotopt',{ 'ydir',1});
Analysis of ERP differences

ERP difference between 2 conditions
Event durations

Color denotes event duration
Comments in EEGLAB structure

>> EEG.comments

Novice EEGLAB Workshop, Sept 22, 2011, Mallorca, Spain: Julie Onton – Getting started
Memory options

Set when loading a STUDY

- **STUDY options**: Check to keep at most one dataset in memory. Allows processing hundreds of datasets within studies.
- **Memory options**: Check for single precision under Matlab 7.x. Saves RAM but can lead to numerical imprecisions.
- **ICA options**: Precompute ICA activations. Requires more RAM but allows faster plotting.
- **Folder options**: If set, assume the folder/directory of the previous dataset.

Option file: C:\Users\julie\Documents\MATLAB\functions\adminfunc\eeg_options.m