[Eeglablist] ERSP : activity systematically shifted at t=0

Alibou Nabil William Jean-Pierre nabil.alibou at epfl.ch
Thu Sep 5 02:42:58 PDT 2019


Hi Clement,
Thanks you for your response ! what is disturbing is that even with a pre-stimulus baseline (i tested a lot of different baseline) and a erp image which seems "normal" to me:
https://imgur.com/u7PHgW4

I have an enormous activity (the values in the output ersp array are extreme compared to other) at t = 0s and if i replace the data around 0 by the data before i will have this :

https://imgur.com/dM28D4A
The peak of activity will surprisingly shift even more like this (i tried to replace even a bigger part around t = 0s and still have this phenomenon).
Finally, i test to only plotted a part ([-200 100] ms) of my epoch originally equal to [-250 500] ms and the activity won't be anymore around t = 0s but 'graphically' at the same localisation !
=> picture which shows this : https://imgur.com/q0y2HEb

Is my eeglab haunted ?


Best,

Nabil


________________________________
De : Clement Lee <cll008 at eng.ucsd.edu>
Envoyé : mercredi 4 septembre 2019 23:34:19
À : Alibou Nabil William Jean-Pierre
Cc : eeglablist at sccn.ucsd.edu
Objet : Re: [Eeglablist] ERSP : activity systematically shifted at t=0

Hi Nabil,

There is always "activity" throughout an EEG recording (hopefully). I don't use newtimef() regularly, but what shows up as red or blue blobs on ERP/ERSP plots is dependent on how you epoch the data and how you choose the baseline. It looks like your stimulus is 600 ms apart and the recording is not that clean... and that you are using the full epoch as the baseline for newtimef(). Before using time warping, have you checked out ERP image<https://sccn.ucsd.edu/wiki/Chapter_08:_Plotting_ERP_images>?

Best,
Clement Lee
Applications Programmer
Swartz Center for Computational Neuroscience
Institute for Neural Computation, UC San Diego
858-822-7535


On Mon, Sep 2, 2019 at 4:21 AM Alibou Nabil William Jean-Pierre <nabil.alibou at epfl.ch<mailto:nabil.alibou at epfl.ch>> wrote:
I am starting in the eeg analysis field and i was studying the TF analysis of my dataset with newtimef()

but i noticed that the activity, regardless of the event, was always at t = 0s (and for every subject).

Exemple of ERP/ERSP of components from my dataset (with extended epoch) :
https://imgur.com/ptEEpPD

<https://i.imgur.com/ptEEpPD.png>https://imgur.com/yVgDg2k

https://imgur.com/PLLqEMz
https://imgur.com/rUl0q8K
https://imgur.com/ftds9nY


=> However if i test it with a constant signal with a spike at a certain time the spectral activity displayed will be at the corresponding t.
 Im using this parameters :

figure();
        newtimef(EEG.icaact(5,:,:), EEG.pnts, [EEG.xmin EEG.xmax]*1000, EEG.srate,0,'freqscale','linear', ...
            'cycles',[5 0.5],'elocs', EEG.chanlocs, 'chaninfo', EEG.chaninfo,  ...
            'freqs',[5 50], 'maxfreq',50,'baseline',[EEG.xmin EEG.xmax]*1000,'trialbase', 'off','basenorm', 'off', 'plotitc', 'off', ... % divise into 2 portions of frequencies for study easily ?
            'caption','test', 'padratio', 4,'alpha',NaN,'ntimesout',100,'winsize',700, 'erspmax', 0.5);

I have changed almost every parameter but i still have this problem and i don't know the cause, thanks you in advance for your help.
Best regards,

Nabil

_______________________________________________
Eeglablist page: http://sccn.ucsd.edu/eeglab/eeglabmail.html
To unsubscribe, send an empty email to eeglablist-unsubscribe at sccn.ucsd.edu<mailto:eeglablist-unsubscribe at sccn.ucsd.edu>
For digest mode, send an email with the subject "set digest mime" to eeglablist-request at sccn.ucsd.edu<mailto:eeglablist-request at sccn.ucsd.edu>


More information about the eeglablist mailing list