[Eeglablist] Problem with continuous data rejecting script

Nastassja Lopes Fischer fasnlf at nus.edu.sg
Thu Oct 10 00:18:36 PDT 2019


Hi all



I am using a script written by a previous member of my lab. I am testing and adapting the script to run in my computer. However it gives me an error when I am deleting bad sections of the continuous data. I tried to figure out different solutions, but I was not very successful.



    The error is: "Unrecognized function or variable 'on'. Error while evaluating DestroyedObject Callback".



    And the script is:



    [ALLEEG EEG CURRENTSET ALLCOM] = eeglab;

    EEG = pop_loadset('filename',[subName{iSubject} 'Events250HzCleanRawChanRemoved.set'],...

        'filepath',[outputSubjectFolder '/']);

    [ALLEEG, EEG, CURRENTSET] = eeg_store( ALLEEG, EEG, 0 );

    eegplot(EEG.data,'winlength',35,'command','on','srate',250,'events',...

        EEG.event,'eloc_file',EEG.chanlocs,'ploteventdur','on')

               eeglab redraw ;

    badChan = {''};

    save([subName{iSubject} 'badSection.mat']);

    save([subName{iSubject} 'badChan.mat'],'badChan');



    Someone could help me to figure out what is going wrong, please?



    Best wishes,



    Nastassja


________________________________

Important: This email is confidential and may be privileged. If you are not the intended recipient, please delete it and notify us immediately; you should not copy or use it for any purpose, nor disclose its contents to any other person. Thank you.


More information about the eeglablist mailing list