[Eeglablist] Channel locations gone after reading locations

Sebastian Sauppe sauppe.s at gmail.com
Wed Oct 6 07:23:09 PDT 2021


Dear EEGLAB community,

I work on Biosemi BDF files and encounter a problem when adding the channel locations.

I first import the file with 

EEG = pop_biosig("file.bdf", 'importannot','off','ref',1);

Then I want to add the channel locations via Edit > Channel locations > Read locations, using this .ced file: https://urldefense.proofpoint.com/v2/url?u=https-3A__bitbucket.org_palday_biosemi128_src_master_biosemi128.ced&d=DwIFaQ&c=-35OiAkTchMrZOngvJPOeA&r=kB5f6DjXkuOQpM1bq5OFA9kKiQyNm1p6x6e36h3EglE&m=7vxjQgYhvCzqHoNLLK0zsDHTSpOcz9PkGVrVLuuShtg&s=ynDwXyj8lZ5QhPjBBzEyBuLcpNlhakmdXKCpw4D9wbs&e= 

This adds the channel locations, I can see that when plotting the channel locations (both 2D and 3D).

However, when I close the window, the channel locations are gone. When I open the Channel locations window again, I am back to where I was before with no locations present. The same happens when I do it via the command:

EEG = pop_chanedit(EEG,...
    'lookup','eeglab2020_0/plugins/dipfit4.3/standard_BESA/standard-10-5-cap385.elp','rplurchanloc',1,...
    'load',{'biosemi128.ced','filetype','autodetect'});

Also when I first import the locations and then save them as a .loc file and then later use this .loc file for reading in the locations (again), they are gone after I click on „ok“.

Does anyone know how to solve this? Any lead would be highly appreciated.

Kind regards,
Sebastian



More information about the eeglablist mailing list