<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
<style type="text/css" style="display:none"><!-- p { margin-top: 0px; margin-bottom: 0px; }--></style>
</head>
<body dir="ltr">
<div id="divtagdefaultwrapper" style="font-size:12pt;color:#000000;background-color:#FFFFFF;font-family:Calibri,Arial,Helvetica,sans-serif;">
<p>Hi!<br>
</p>
<p>I have the same problem described in the following mail I found surfing eeglablist:&nbsp;</p>
<pre style="white-space: pre-wrap;">On Tue, Dec 9, 2014 at 5:48 PM, Ying Li &lt;<a href="http://sccn.ucsd.edu/mailman/listinfo/eeglablist">yingli.ucla at gmail.com</a>&gt; wrote:
&gt;<em>
</em>&gt;<em> Hi everyone,
</em>&gt;<em>
</em>&gt;<em> Recently I'm using the fmrib plug-in to remove the fMRI-related artifact
</em>&gt;<em> in EEG signal. When I tried to remove the gradient artifacts by clicking
</em>&gt;<em> Tools &gt; FMRIB Tools &gt; FASTR: Remove FMRI gradient artifacts &gt; ok, I met an
</em>&gt;<em> error &quot;Input argument must be double&quot; (as attached).
</em>&gt;<em>
</em>&gt;<em> The matlab version I used is R2011b (Mac) R2012b (in Mac) and R2014a (in
</em>&gt;<em> Windows). All of them will encounter this error. My friend who used R2008
</em>&gt;<em> said it would work, but nowadays it's difficult to find such an old version
</em>&gt;<em> of Matlab.
</em>&gt;<em>
</em>&gt;<em> Thus, I'm wondering whether there are any updated version of fmrib, or are
</em>&gt;<em> there any solutions to fix this error? I'll appreciate your help a lot!
</em>&gt;<em>
</em>&gt;<em> Best wishes,
</em>&gt;<em>
</em>&gt;<em> Ying</em></pre>
<pre style="white-space: pre-wrap;"><span style="font-family: Calibri, Arial, Helvetica, sans-serif;">I'm using the example EEG dataset downloaded directly from the FMRIB plug-in web site (http://fsl.fmrib.ox.ac.uk/eeglab/fmribplugin/) and my matlab version is the R2013b one (Windows).</span><br></pre>
<pre style="white-space: pre-wrap;"><span style="font-family: Calibri, Arial, Helvetica, sans-serif;">I found this answer too: </span><pre style="white-space: pre-wrap;">&gt;Dear Ying,

&gt;Most likely your EEG.data is single. Open EEGLAB options and uncheck 'use
&gt;single precision' to let it use double.

&gt;Makoto<br></pre><pre style="white-space: pre-wrap;"><span style="font-size: 12pt; font-family: Calibri, Arial, Helvetica, sans-serif;">I did as told but nothing has changed and I encounter the same error: &quot;Input argument must be double&quot;<em>. &#8203;</em>What can I do? </span><span style="font-size: 12pt; font-family: Calibri, Arial, Helvetica, sans-serif;">Thanks a lot for any help.</span><br></pre><pre style="white-space: pre-wrap;"><span style="font-family: Calibri, Arial, Helvetica, sans-serif; font-size: 12pt;">Best wishes,</span></pre><pre style="white-space: pre-wrap;"><span style="font-family: Calibri, Arial, Helvetica, sans-serif; font-size: 12pt;">Martina</span></pre><pre style="white-space: pre-wrap;"><br></pre><div><br></div></pre>
<p><br>
</p>
</div>
</body>
</html>