<div dir="ltr">Do any of the developers know how the Nan error in STUDY preclustering could be solved?<div>N</div><div><br></div><div><br><div><br></div><div>On Wed Nov 25 07:41:56, Akshay Maggu wrote:<pre style="white-space:pre-wrap;color:rgb(0,0,0)">Hi Nikola,

I am facing the same issue. All pre-processing steps carefully followed and
ICAs done for all subjects. But still this &#39;Na&#39; error (
<a href="https://www.dropbox.com/s/sw6xvujbalidg24/error_preclustering.JPG?dl=0">https://www.dropbox.com/s/sw6xvujbalidg24/error_preclustering.JPG?dl=0</a>)
pops up saying that some of the datasets have ICA decompositions missing.

Let&#39;s see what experts on the list have to say about it.

Akshay

On Tue, Nov 24, 2015 at 7:33 AM, Nikola Vukovic &lt;<a href="http://sccn.ucsd.edu/mailman/listinfo/eeglablist">vukovicnikola at gmail.com</a>&gt;
wrote:

&gt;<i> Dear EEGLAB list
</i>&gt;<i>
</i>&gt;<i> I would be very grateful is someone could help me out with an error I&#39;ve
</i>&gt;<i> been getting. When I try to precluster components in a given STUDY (it
</i>&gt;<i> happens for several study files), I get the following error:
</i>&gt;<i>
</i>&gt;<i> FOR CLUSTERING, YOU MAY ONLY USE DIPOLE OR SCALP MAP CLUSTERING. This is
</i>&gt;<i> because some datasets do not have ICA pairs. Look for NaN values in
</i>&gt;<i> STUDY.cluster(1).sets which indicate missing datasets. Each column in this
</i>&gt;<i> array indicate datasets with common ICA decompositions.
</i>&gt;<i>
</i>&gt;<i> Looking inside the cluster(1).sets, I can indeed find some NaN fields, suggesting not all files have associated ICA decomposition data. This, however, is puzzling because I made sure to do ICA on each subject&#39;s dataset *before* epoching, meaning that all sets for individual conditions share the same weights for a subject. After getting this error I even tried to copy the weights (EEG.icawinv + EEG.icasphere + EEG.icaweights + EEG.icachansind) from the unepoched set to all the epoched ones.
</i>&gt;<i>
</i>&gt;<i> Did anyone have this error too, and how could it be solved?
</i>&gt;<i>
</i>&gt;<i> Thanks for any help,
</i>&gt;<i>
</i>&gt;<i> Nikola
</i>&gt;<i>
</i>&gt;<i>
</i>&gt;<i> _______________________________________________
</i>&gt;<i> Eeglablist page: <a href="http://sccn.ucsd.edu/eeglab/eeglabmail.html">http://sccn.ucsd.edu/eeglab/eeglabmail.html</a>
</i>&gt;<i> To unsubscribe, send an empty email to
</i>&gt;<i> <a href="http://sccn.ucsd.edu/mailman/listinfo/eeglablist">eeglablist-unsubscribe at sccn.ucsd.edu</a>
</i>&gt;<i> For digest mode, send an email with the subject &quot;set digest mime&quot; to
</i>&gt;<i> <a href="http://sccn.ucsd.edu/mailman/listinfo/eeglablist">eeglablist-request at sccn.ucsd.edu</a>
</i>&gt;<i>
</i>


-- 
Akshay Raj Maggu,
PhD Candidate,
Laboratory for Language, Learning and the Brain,
Department of Linguistics and Modern Languages,
The Chinese University of Hong Kong,
Hong Kong.
Webpage: <a href="http://www.cuhk.edu.hk/lin/new/people/students/maggu/">http://www.cuhk.edu.hk/lin/new/people/students/maggu/</a>
*Save trees.. Save life! Please don&#39;t print this email unless you really
need to.....*
-------------- next part --------------
An HTML attachment was scrubbed...
URL: &lt;<a href="http://sccn.ucsd.edu/pipermail/eeglablist/attachments/20151125/f78bc58e/attachment.html">http://sccn.ucsd.edu/pipermail/eeglablist/attachments/20151125/f78bc58e/attachment.html</a>&gt;</pre></div></div></div>